CEC - is this Normal? - AVS Forum
Forum Jump: 
 
Thread Tools
post #1 of 5 Old 12-12-2011, 01:54 PM - Thread Starter
Member
 
Bengalih's Avatar
 
Join Date: Jul 2005
Location: Chicago
Posts: 155
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Not sure this is the best forum area for this - but hopefully someone will have some insight.

I recently bought new equipment, including a Vizio XVT323SV TV and an Onkyo TX-NR809 receiver.

I wanted to take advantage of the the Audio Return Channel (ARC) feature of HDMI 1.4 on these devices as the TV has built in Internet apps, including Netflix.

After following the instructions in the Onkyo to set this up, I was at a loss to get it working. I contacted Vizio who walked me through enabling CEC function on the TV. Once this was setup, the TV recognized the receiver and the ARC function worked.

So, my first question is: Is this normal to have to force the use of CEC for ARC? I don't know if ARC is dependent on CEC - they would seem to me to be different technologies - but does ARC depend on CEC communications?

The next thing I noticed was that when turning on my receiver, the TV remote's volume controls now were tied to the receiver audio. If I turned off the receiver, the TV remote's volume controls now controlled the TV. This kind of makes sense - as it assumes I am using the ARC function and want to use my receiver to control the volume if its on. However, what also occurs is that when I use my TV remote to turn off my TV, it automatically turns off the receiver as well.

So my second question is: Is the above behavior par-for-the-course for CEC devices? I understand that in *most* scenarios, if you are turning off the TV you probably want the receiver off, but what if I am switching to my projector (2nd HDMI out on receiver) - or what if I just want to listen to music - I then need to turn my receiver back on again.

I believer that Vizio screwed up here in their implementation. I have confirmed with them that this is "as designed" and, I quote their support:
"With the way CEC works, the devices will respond to each other. You would need to disable CEC in order for you to be able to power the receiver on without the tv powering on, or to power the tv off without the receiver also powering off"
But alas, I can't disable CEC without loosing ARC function.

Please advise!
Bengalih is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 12-12-2011, 03:26 PM
Senior Member
 
cshepard's Avatar
 
Join Date: Jan 2009
Location: NC
Posts: 346
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 18
From my experience, what you describe is pretty normal. ARC is a very useful feature, but I can't stand CEC--and as you've discovered, often you can't use ARC without the CEC. I don't have a good suggestion for a solution for you though.
cshepard is offline  
post #3 of 5 Old 12-12-2011, 04:28 PM - Thread Starter
Member
 
Bengalih's Avatar
 
Join Date: Jul 2005
Location: Chicago
Posts: 155
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Ok thanks - so it sounds like Vizio is not alone here. I have found a few more threads with different equipment (Denon AVR, Panasonic TVs, etc.) that seem to show that quite a few manufacturers do some not so intuitive things with CEC.

What I am still most curious about is my first question revolving around the use of CEC for ARC functionality.

Other posters have said things like "Forget about CEC", "Use a universal remote instead" - which is decent advice, assuming ARC isn't effected.

Is CEC necessary for ARC? Or is Vizio just making me turn it on to get their own implementation of ARC working?

thanks
Bengalih is offline  
post #4 of 5 Old 07-11-2013, 04:17 PM
Senior Member
 
vestaviascott's Avatar
 
Join Date: Jul 2013
Location: Vestavia Hills, Al
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 58

Bump. Old thread but I have similar questions. I'm trying to set up ARC between a Vizio M701d TV and A Denon AVR-591 audio receiver.

 

Any help much appreciated. I get "No Device" when trying to use "Device Discovery" on the Vizio to locate the Denon receiver that's connected to its HDMI1 (Arc labeled) port.


My Blog > World's Fastest Website | Vizio Owners Guide | Vizio Calibration (updated)

My Equipment: 70" Vizio M-Series | Directv HR34-700 | Denon AVR-591 | Harmony Smart Control | Samsung LNT-5265 | PS3
vestaviascott is offline  
post #5 of 5 Old 07-14-2013, 12:29 PM
Senior Member
 
vestaviascott's Avatar
 
Join Date: Jul 2013
Location: Vestavia Hills, Al
Posts: 292
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 58

Update: In case anyone is watching this thread or has come here with a similar question, I was able to resolve my issue. The key was that my receiver (Denon AVR-591) refers to ARC as "HDMI Control". That feature was set to "Off" by default and I just had to turn it on using the Denon's onscreen setup tools.

 

Details here > http://www.avsforum.com/t/1480388/official-vizio-m-series-razor-owners-survival-thread/30#post_23524070


My Blog > World's Fastest Website | Vizio Owners Guide | Vizio Calibration (updated)

My Equipment: 70" Vizio M-Series | Directv HR34-700 | Denon AVR-591 | Harmony Smart Control | Samsung LNT-5265 | PS3
vestaviascott is offline  
Reply Remote Control Area

Tags
Vizio Xvt323sv 32 Inch Full Hd 1080p Led Lcd Hdtv With Via Internet Application Black , Onkyo Tx Nr809
Gear in this thread

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off