RUNNING THE TC30 ON A WINDOWS 7 MACHINE??????? - AVS Forum | Home Theater Discussions And Reviews
Baselworld is only a few weeks away. Getting the latest news is easy, Click Here for info on how to join the newsletter list. Follow our team for updates featuring event coverage, new product unveilings, watch industry news & more!

Forum Jump: 
Thread Tools
post #1 of 1 Old 12-31-2012, 09:22 AM - Thread Starter
Bultaco's Avatar
Join Date: Apr 2009
Location: St. Catharines (near Niagara Falls) Ontario, Canada
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
Is anybody doing this? Running the TC30 software on a PC under Win7?

Just wondered.

I'm seeing lots of scary comments about the TC30..........but most of them date back to 2006/7.

Does anyone have any updates as to how to re-program this baby using "current" hardware?

I see frequent comments about NOT updating the software beyond ver. xxxx (I think 1.5.4 or something....have to check).

I happen to have my original Take Control TC30 Installation Software disk sitting on my lap right now. It says Microsoft Windows 98SE, ME, 2000 and XP. (It also says Mac OS X 10.2 or higher)

I have not run this software......or even installed it......since about TWO COMPUTERS ago......back when I was running either XP or Vista.

Windows 7 Home Premium (64bit) is my OS of choice now......and I've made some minor variations with my Home Theatre setup that call for an update to my remote configuration/programming.

Have YOU run this software on YOUR Win7/64 machine and had any luck (or disasters?)

Enquiring minds need to know!! :-)

Thanks for any "update".

Bultaco is offline  
Sponsored Links
Reply Remote Control Area

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Forum Jump: 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off