Kindle Fire Stopped Working - AVS | Home Theater Discussions And Reviews

AVS | Home Theater Discussions And Reviews > A/V Control & Automation > Remote Control Area > Kindle Fire Stopped Working

Remote Control Area

mijotter's Avatar mijotter
03:40 PM Liked: 58
post #1 of 3
10-27-2013 | Posts: 1,189
Joined: Nov 2012
I have a Kindle Fire(NOT HD). I think the battery ended up dying so I plug in the usb charge cord to charge it and the base plug gets hot but after 20 minutes the Kindle will not turn on. I've tried holding down the power button for 10 seconds still nothing. Can anyone assist me please.
KingLeerUK's Avatar KingLeerUK
11:16 AM Liked: 75
post #2 of 3
10-28-2013 | Posts: 384
Joined: Feb 2008
You might try the "hard reset" method:

Short of that, start looking into battery replacements, can be done DIY.
username354's Avatar username354
09:45 PM Liked: 10
post #3 of 3
11-04-2013 | Posts: 4
Joined: Nov 2013
Hello, I also had this issue with my original Kindle Fire. At first I thought it was the charger. No luck. I had the idea to prop it up when I had it plugged in. This worked for 3 weeks and then it just stopped charging. I would first check the charger. If that doesn't work, then I would suggest calling Amazon and asking for a replacement (Your device must still be in warranty). The 1st generation Kindle Fires shipped with defective charging ports. Other than that, the last resort is taking it apart and re-soldering the charging port. I got sick of it and got a Fire HD (I am on my 11th Kindle Fire). The new Fire has broken countless times and I have to keep getting new ones. Hopefully the new Fire HDX isn't like the Fire HD. All in all, you probably should be looking for a new Kindle/Tablet as yours won't last much longer.
Reply Remote Control Area

Subscribe to this Thread

Powered by vBadvanced CMPS v3.2.3