AVS Forum | Home Theater Discussions And Reviews - View Profile: whipit

whipit whipit is online now

AVS Forum Special Member

  About Me

  • About whipit
    Location
    SGF
    Occupation
    65VT60, 50ST30, 54G10

  Statistics

Total Posts
General Information
  • Last Activity: Today 02:28 AM
  • Join Date: 12-06-2009
  • Referrals: 0

  Mentions

04-27-2017
05:45 PM - whipit mentioned turbosteve in post Official ZT60 Owners Thread
turbosteve : This place can als...

  Thread Tags

No results to display...

  Quotes

08-28-2017
03:47 AM - whipit quoted Wafflebird in post Oh the delima
That looks like a good option. ...
08-21-2017
04:36 AM - RichB quoted whipit in post Official ZT60 Owners Thread
According to the ST50 repai...
03:27 AM - whipit quoted RichB in post Official ZT60 Owners Thread
We just moved the 65ZZT60 ...
07-09-2017
01:20 PM - whipit quoted Test Ickles in post Panasonic PX600 Plasma vs Panasonic EZ1000 Oled
If you were there in a darkened ...
08:58 AM - Test Ickles quoted whipit in post Panasonic PX600 Plasma vs Panasonic EZ1000 Oled
It looks like the plasma bl...
04-28-2017
04:40 AM - turbosteve quoted whipit in post Official ZT60 Owners Thread
turbosteve : This place can...
07-18-2016
05:53 PM - whipit quoted sublime600 in post Official Panasonic GT50 Series Discussion Thread [No Street Price Talk]
Anyone have a source to buy a n...
06-03-2016
02:32 PM - RoyMacDonald quoted whipit in post Official ZT60 Owners Thread
Here's something I found. I...
05-30-2016
06:57 PM - whipit quoted jbailey895 in post Installed SSD but not visible?
SSD Is shown in List disk, jus...
05-25-2016
06:18 PM - whipit quoted video_analysis in post Official ZT60 Owners Thread
Just curious where you read about t...
05-22-2016
07:18 PM - jazzycat quoted whipit in post F8500 will be my last high end TV ever, and I'm finally glad plasma is gone
To get the sidebars to work...
05-20-2016
04:00 PM - whipit quoted jazzycat in post F8500 will be my last high end TV ever, and I'm finally glad plasma is gone
How do you do that? I've tri...
03-24-2016
10:02 AM - whipit quoted sooke in post Official ZT60 Owners Thread
Thanks for the tip whipit....
03-23-2016
04:48 PM - whipit quoted sooke in post Official ZT60 Owners Thread
Mini update on my ZT60 tha...
01-18-2016
08:40 PM - whipit quoted PhilipsPhanatic in post Panasonic PX80 Owners Thread
I am in the Service Menu...this is w...
10:00 AM - ford1953jimav quoted whipit in post Panasonic 11G/12G/13G black levels have seemingly doubled overnight?
Make sure you are using an ...
01-17-2016
04:23 PM - whipit quoted ford1953jimav in post Panasonic 11G/12G/13G black levels have seemingly doubled overnight?
I found a firmware update version ...
01-14-2016
10:30 AM - whipit quoted Baron Blood in post Official Panasonic UT50 Series Discussion Thread
Cheers. Unfortunately no though ...
09:23 AM - Baron Blood quoted whipit in post Official Panasonic UT50 Series Discussion Thread
@ Baron: Is there anything ...
01-13-2016
06:01 PM - bob brennan quoted whipit in post Official ZT60 Owners Thread
Just want to add to this: i...

  Reviews

whipit's Recent Reviews
    10-06-2012, 01:58 PM by whipit
    I've had mine for over a year now and it's hooked up to a denon 2310ci and it gets daily tv use. So far so good. Nice clean tight bass and easily goes down very low. For music it is a little more...