AVS Forum | Home Theater Discussions And Reviews - View Profile: whipit

whipit whipit is online now

AVS Forum Special Member

  About Me

  • About whipit
    Location
    SGF
    Occupation
    65VT60, 50ST30, 54G10

  Statistics

Total Posts
General Information
  • Last Activity: Today 03:59 PM
  • Join Date: 12-06-2009
  • Referrals: 0

  Mentions

No results to display...

  Thread Tags

No results to display...

  Quotes

07-18-2016
06:53 PM - whipit quoted sublime600 in post Official Panasonic GT50 Series Discussion Thread [No Street Price Talk]
Anyone have a source to buy a n...
06-03-2016
03:32 PM - RoyMacDonald quoted whipit in post Official ZT60 Owners Thread
Here's something I found. I...
05-30-2016
07:57 PM - whipit quoted jbailey895 in post Installed SSD but not visible?
SSD Is shown in List disk, jus...
05-25-2016
07:18 PM - whipit quoted video_analysis in post Official ZT60 Owners Thread
Just curious where you read about t...
05-22-2016
08:18 PM - jazzycat quoted whipit in post F8500 will be my last high end TV ever, and I'm finally glad plasma is gone
To get the sidebars to work...
05-20-2016
05:00 PM - whipit quoted jazzycat in post F8500 will be my last high end TV ever, and I'm finally glad plasma is gone
How do you do that? I've tri...
03-24-2016
11:02 AM - whipit quoted sooke in post Official ZT60 Owners Thread
Thanks for the tip whipit....
03-23-2016
05:48 PM - whipit quoted sooke in post Official ZT60 Owners Thread
Mini update on my ZT60 tha...
01-18-2016
09:40 PM - whipit quoted PhilipsPhanatic in post Panasonic PX80 Owners Thread
I am in the Service Menu...this is w...
11:00 AM - ford1953jimav quoted whipit in post Panasonic 11G/12G/13G black levels have seemingly doubled overnight?
Make sure you are using an ...
01-17-2016
05:23 PM - whipit quoted ford1953jimav in post Panasonic 11G/12G/13G black levels have seemingly doubled overnight?
I found a firmware update version ...
01-14-2016
11:30 AM - whipit quoted Baron Blood in post Official Panasonic UT50 Series Discussion Thread
Cheers. Unfortunately no though ...
10:23 AM - Baron Blood quoted whipit in post Official Panasonic UT50 Series Discussion Thread
@ Baron: Is there anything ...
01-13-2016
07:01 PM - bob brennan quoted whipit in post Official ZT60 Owners Thread
Just want to add to this: i...
01-11-2016
05:14 AM - m4v3r1ckNL quoted whipit in post Master thread for Panasonic plasma not turning on
Access to the service mode ...
04:28 AM - whipit quoted m4v3r1ckNL in post Master thread for Panasonic plasma not turning on
I think I found the correct doc...
04:02 AM - whipit quoted mrhaboobi in post Official Panasonic VT50 owners thread
Hi, Have had the 55" version ...
03:59 AM - Deleted Posts
01-10-2016
07:32 AM - m4v3r1ckNL quoted whipit in post Service Manual Panasonic TX-P54Z11E
I don't think I said that r...
01-08-2016
05:49 PM - whipit quoted gigas in post Master thread for Panasonic plasma not turning on
Thanks for your response. ...

  Reviews

whipit's Recent Reviews
    10-06-2012, 02:58 PM by whipit
    I've had mine for over a year now and it's hooked up to a denon 2310ci and it gets daily tv use. So far so good. Nice clean tight bass and easily goes down very low. For music it is a little more...