or Connect
New Posts  All Forums:

Posts by omegafiler

Same here, it just started working again. Off to Hulu to checkout what I missed!
Thanks for the follow up. I was actually waiting to hear back from Fox, hoping that it was just a glitch they'd fix soon. I can get some other TV Tuners to get FOX on 7.3 and all TV's are fine. Just not WMC. I even got a new antenna over the weekend thinking the typical weak ch 7 signal I get in East Round Rock was the issue. On the plus side, I should have a nice strong signal whenever they fix it.
These looks pretty cool. Anybody install one?
I've always liked Polk audio, but they really do need to carry Onkyo. CC does and BB has lost my business for that very reason on more than one occasion. As for blu-ray, they'll need to break $300 retail and actually work very well before I buy another blu-ray player. Keeping prices high and/or raising them is not the way to keep me buying stuff.
I really don't care of there is a BR add-on for the 360. I've got the HD-DVD Add-on, which will be fine for the 15 or so HD DVD I still have laying around. And had they not lost the format war, I would have picked up a stand-alone HD player anyways for the full audio support. Not to mention I already have a BD30, which is a great blu-ray player. I primarily bought the 360 for games. And it does that great. If MS wants to offer current HD content, they'll likely...
I'm also in the same boat. Got the BD30 but would like another one. It works so well, why not buy the same one? Well, because they've decided to keep prices the same or in some cases RAISE prices of these players instead of lowering them. I have no intention on investing any more on any blu-ray players until they drop at least $100-$200. Which will be more likely as more players start to surface. But in the past, I've found Amazon a good place to get them - if...
I've had the BD30 for awhile and I do agree that the SD upconversion is kinda sad. Some content is actually 'OK,' while others just look horrible. This is on my 1080p 61" DLP Sammy. I previously had the Sammy 1200 with the Reon chip... now that one did really good SD upconversion. I was quite impressed with it. Too bad blu-ray playback had so many issues. I still have it setup in another room, but I might pickup another blu-ray player when the prices eventually drop...
2nd Update: Well that didn't take long, it died again, same issue. Guess it's off to be repaired...
Update: interestingly the reset actually worked this time. On the first receiver, nothing worked, reset, pulling power, swapping HDMI cables, etc. I decided to try it again since this was a slightly different issue. Just did the standard Onkyo 605 Reset (per owners manual) as I did before. With the unit on, press and hold down the VCR/DVR button, press power button (while holding VCR/DVR). It reads "clear" and powers off. Obviously release buttons and power it back...
Same here. First 605 had HDMI In 1 go out (within 30), kept flashing video on/off. Now the 2nd receiver, just over a month later (out of 30 day return window), the HDMI Out/Monitor port dies. It's flashing video green and no video. Not happy.
New Posts  All Forums: