or Connect
New Posts  All Forums:

Posts by cdtommie

Sorry if this has been covered in the forum, I did a search for this problem with no success. My always reliable E95H now has serious problems related to the northeast storm last week. We were running a generator and to minimize load (lots of components were in standby mode) I unplugged my HT power conditioner and plugged the DVR directly into a dedicated 20 amp outlet reserved for the power conditioner. Used the player to watch some dvd's during the storm (no cable). ...
Interesting thread. My DMR-EH58 just started acting up on Monday (commands seem to lag and then the remote becomes unresponsive, I pull out the power cord and wait, then go through the same process again)...and it just so happens that Charter swapped out a SA 3100HD for a 3250HD on Saturday as I was having some HD issues. I haven't tried pulling the SVideo input cable from the box out yet. Everything is plugged into a Monster Cable power strip.
Thanks CitiBear and jjeff for your input. I'm going to go the Panasonic 58/68 route. I guess the only concern is that these machines don't have a US warranty I assume but since my HS2 has lasted this long I should be good for several years. jjeff, I did read the thread you referenced before posting and it has been invaluable. Thanks again, Tom
Hi there - question for the Panasonic and Pioneer experts - my HS2 appears to be on it's last legs. In the past week there has been a "lag" in responding to some remote control commands...for example: I hit function, timer recording, enter the channel but then when I try to scroll to the date field the screen freezes. If I wait about 30 seconds I can then select the date and then the on time but then when I try to select the off time it again freezes and I have to wait...
We picked these up in Brookfield, CT yesterday. Took three trips with a Honda CRV. I'm 6'3" and I think the backs are pretty comfortable. The seat is fairly firm but for $499 I'll get used to it. They had two sets and a floor model and they were all purchased while I was there. I believe they are about 91" wide.
I use the Ayre K-5xe for the main channels in a Lexicon MC12B/Wilson/Proceed set-up and am satisfied with the results...running in HT bypass using the balanced connection. Only issue is occasional popping noises switching inputs which seems to be resolved by turning amps on last/off first or off before changing inputs. Sonics are much improved relative to using Lexicon analog bypass. Not familiar with the ML38s (use an ARC LS5 Mk 3 in my two channel system). I think...
Saw them at the Meadowlands in NJ back at the end of September and was really impressed with their sound...maybe the best I've heard at a stadium concert.
Thanks Alan, I think I'll do the update since the the cost is modest and we do plan to watch some SD (mostly sports). I'm stuck with Charter Cable in Connecticut which means not much HD programming so far.
Hi, I'm Tom and this is my first post and my RS1 also arrived today from AVS. I was using a NEC LT150 coupled with a Faroudja NRS. I was wondering if I should get the NRS updated ($150 cost) to accept all rates (except for 1080P). I could still use the NRS for occasional LD (mostly music titles) via my Macintosh 7020, standard definition cable and as a HD passthru. Any advice would be appreciated. Right now the only immediate connection I plan for the RS1 is to hook...
New Posts  All Forums: