or Connect
New Posts  All Forums:

Posts by Trialsking

Does anyone know when the Blockbuster On Demand service will be avaliable for the 750 series? I have read a few places that it is supposed to be in a firmware update for the fall 09. Anyone can confirms this?
Do you use these for HDTV? Or do you have a different setting?
+1 to those comments. I had 2 XBR4s that I had to return because of 30+ stuck pixels on each. I loved the XBR4's but the pixel thing did them in. Also there was little to no glare on the XBR, but the Sammy has very noticeable glare.
I had a 52" XBR4 for 3 months and switched to the A750. I have actually had the Sony KDL52W135 Costco model, and 2 KDL52XBR4s. All 3 had many (30+) stick pixels that all appeared within a month of purchase of each one. I really loved all the Sonys, its just that the the pixel issue forced me to give the Samsung a go. Here are somethings to consider: -The XBR4 definitely outshines the a750 in SD content. Although the a750 looks good, the Sony was much better for...
I first purchased a Sony KDL52WL135 from Cost about 2 months ago, but I ended up getting many stuck pixels(like 50+) in large groups. I took that model back and got a SonyKDL52XBR4, and after just 3 days I ended up with many stuck pixels(30+). All I did with both was watch TV and DVDs. I tried the "massage" technique, the "tapping", and the jscreenfix Java program to fix the stuck pixels, all of which did nothing to help. The 135 was from Costco and the XBR was from...
Well I have had my XBR4 for 1 week now and just about 3 days in I had a bunch of stuck pixels. I tried "massaging" them and I tried tapping and even the Jsceen Java program, no luck. I might be going back to get the 135 because they still have it in stock at Costco and the Circuit City where I got my XBR from was the last one. I am the only one who got this many stuck pixels on 2 different Sony's? Is there something I am doing wrong?
Unfortunately I do not have the Planet Earth Series yet. But I am watching some movies on DirecTV that had noticed some artifacts before on my 135. Two I saw last night were 300 and Gladiator. In Gladiator the scene I noticed to have less artifacts than my 135 was the arena fight where Maximus and Comidus meet for the first time. When I was watching that same seen on my 135 I noticed slightly more artifacts. Let me stress that there is a difference, but it is very...
Well I returned my 135 to Costco yesterday and I managed to get an XBR4 for the same price at Circuit City. I kinda like the light up Sony logo. My Logitech Harmony 670 worked exactly the same as with my 135, so I did not have to reprogram it. I all used the exact same settings from my 135. My first impressions are the are small differences. I will need to tweak the picture settings alittle more as the 135 and XBR4 are obviously not the same. Now that I can see for...
After alittle searching, I guess I have a bunch of stuck pixels, as none of them are black(dead). I read a few places saying you can sometimes unstick them with pressure, but I have a bunch. So I will probably take the LCD back for a new one, as I dont think I want to do any more damage to the screen. Maybe I will look into getting an XBR4, so I can have the DRC 2.5.........hmmmm
I have had my 135 for about 2 months now and still love it. But just the other day my wife and I noticed some dead pixels that I am almost sure were not there when I first got it. The are like 3 little rings of pixels, less than half an inch across. I can really only see them from an extreme angle, and from head on, I have to be less than 2 feet away to see them. There are also a few other dead pixels. My question is: Is this normal or acceptable? I am almost...
New Posts  All Forums: