or Connect
New Posts  All Forums:

Posts by xgin

Does the 5900 do the different HD formats? Especially WMV HD and AVI HD? I just sent my LG 390 & LG 690 to Amazon for trade-in money and am thinking about getting this one.
I've finally had it with my BD 690. I found out Amazon buys used players and sold them my BD 690 for $35. I went through the grinding thing, but it was under warranty and they fixed it. The other problems I've had are that if I play my own data discs it "forgets" how to read a blu-ray sometimes and vice vera. I fix it by unplugging it for a bit and when I plug it back in it works fine. Also It doesn't like WMV HD or AVI Hd. The funny thing is I traded in my BD 390 and...
I absolutely think Freemake Video Converter (easy search for it) is the best one I've ever found. Does a pretty darn good jobI've seem to have found a pattern to what my LG690 will play in that it will play the old .wmv - say ones made in 2009, maybe it will play 720s, but will NOT play ay 1280 HDs.My other problem is mine forgets how to read Blu-Rays or see data files. Last night (and this has happened 3 or 4 times) I rented DREDD and wouldn't see it. Tried I,robot which...
Answer: Unplug for a few minutes and let it reboot. Presto Change -O - everything is there.
I can't even guess what's going on with my BD690. I have BD.8.97.423 firmware and it's not reading ANY of my data discs. Every one f them shows empty whether it's AVI or mp4. Help?
In reply to Ron Alum & Lord of the Manor. Had the same problem and sent it in for repair. Luckily it was under warranty and they fixed it for free. On a different note I discovered it would not play all .wmv files so I just spent a huge amount of time converting them to Mp4. It likes the 720s fine, but not the 1920x1080plus a few other sizes.. Also what good is this new update?
Coincidentally, The Avengers in Blu-Ray was the one I was trying to watch when the grinding sounds started and your description of the disk spinning matches exactly. I tend to break things when I work on them, but this is good to know. Thanks much!
Haven't used my 690 in about a month (worked fine then), and put a Blu-ray (The Avengers) from Red Box in and OH the horrible grinding noises!!! Tried a few others and some it would read (after much time & effort) and some it would not. Hooked my old 390 back up and the Avengers works fine. Any suggestions?
Haven't used my 690 in about a month (worked fine then), and put a Blu-ray (The Avengers) from Red Box in and OH the horrible grinding noises!!! Tried a few others and some it would read (after much time & effort) and some it would not. Hooked my old 390 back up and the Avengers works fine. Any suggestions?
Thanks. Kinda expected that.
New Posts  All Forums: