or Connect
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › HD A-20 standard DVD playback issue
New Posts  All Forums:Forum Nav:

HD A-20 standard DVD playback issue

post #1 of 4
Thread Starter 
I was wondering if anyone could shed some light.....I have an A20 hooked up to a Philips 47PFL7422D/37 via HDMI and have had flawless playback of both HD DVDs and SD DVD. The other night I rented Dan in Real Life (standard) and after loading for a couple seconds, I got an "unsupported format" mesage on screen, and then the image went pink. I could hear everything fine, and I could still see the image, however it looked like I was watching it through a pink film. No matter what I did, I could not get the disc to work. The sam thing happened tonight when I tried to watch the SD version of Enchanted, and the exact same thing happened. The problem was solved when I turned off the player and then turned it back on, but as soon as either of the discs loaded, I got a pink screen again. Very odd issue. Has anyone else come across anything similiar?? Thanks for the help!
post #2 of 4
Thread Starter 
Anyone??
post #3 of 4
Have you updated to the latest firmware in your A20? Except that it's worked perfectly up-to these two discs, it does feel like some sort of handshake issue w/HDMI. Any chance your cable has come loose...
post #4 of 4
Thread Starter 
I'm running the latest firmware........I never thought about the cable being an issue. hmm......I will check. thanks!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HD DVD Players
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › HD A-20 standard DVD playback issue