or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Official Pioneer SC-09TX/SC-LX90 Owner's Thread
New Posts  All Forums:Forum Nav:

Official Pioneer SC-09TX/SC-LX90 Owner's Thread - Page 169

post #5041 of 5378
Updated via ilink and dv-79avi!
post #5042 of 5378
Has anyone tried this with an Esoteric X-03 player?
Thanks..
post #5043 of 5378
Thread Starter 
Wow, this thread hasn't seen this much action in a long time. Amazing what a FW update will do

I actually have to buy some CD-R's today. I'm completely out! I'll be updating mine later today.
And I hope Dragnet can report back on the rs232 updates.

edit - question: my burning software turns the wav file into a .cda file, since the instructions called for burning it as a music disc. Is this correct?
post #5044 of 5378
Thread Starter 
Quote:
Originally Posted by George Omoregie View Post

Is this upgrade from Pioneer?
I have a note book with RS232, will it be possible for me to update Susano serial to serial?
btw, what does this upgrade do for the Susano?

Did you get to send your mail/letter to Pioneer big wigs about upgrading the units?

I sent mine via e-mail, but no response yet.

Thanks.

George.

Yes & this update uses a CD-R. It supposed to fix dts-ma problems, incl Star Wars
Yes, if you have the whole Aug 2009 package for all the sub-systems, rs-232 will allow you to install them. Various bug fixes.
Yes, sent that week
No replies either. I PM'd & called Chris Walker on his cell phone, left message. No reply. Either they have something in the works & can't talk about it (doubtful but possible), aren't listening (possible), or have no new information from Pio Japan (probable). I have no idea since Chris & others don't reply.

Some of the Denon folks are complaining because the update takes away the surround B channels in order to do heights/wides/NeoX

At least they get something to complain about.

It wouldn't surprise me if Pioneer is waiting to see how Denon does with this and how many units are actually upgraded before committing any money for the Susano. Or they really could be doing nothing
post #5045 of 5378
Quote:
Originally Posted by George Omoregie View Post

I
Did you get to send your mail/letter to Pioneer big wigs about upgrading the units?

I sent mine via e-mail, but no response yet.

Same here - no replies

After all the updates I did the whole setup again (searching for the microphone for 3 hours) and everything is good now. I tried a problematic disc (Star Wars) I had audio problems before - so far everything is good.
post #5046 of 5378
Thread Starter 
just updated dsp1 - easy to do once I got over my nerves

And I got a bonus - Neural THX. I never could get Neural THX as a mode for disc sources before & the manual reads like it worked on FM. So I had assumed it only worked on FM stations. Early FW may not have it fully implemented, but now it's a choice for CD's along with DPLIIx & it works great.

Thanks, Hkan You've done everyone a great service.

I may try the rs-232 ones later today or Sunday. Still waiting to hear how Dragnet makes out.

And a big to Pioneer, their policy & their crappy communications

Hkan gets the big kudos for helping us out Thanks again!

Sometime this weekend I'll put on a BD that popped on me & make sure it's fixed. I'm not ready yet to watch Star Wars. I'm waiting for the holidays or a winter weekend to do a SW marathon
post #5047 of 5378
Steve.. What player did you use to do the updates? thanks...
post #5048 of 5378
Thread Starter 
I used a Pioneer US DV-59AVI universal player
According to several the 79AVI also worked

I'm afraid I don't personally know about others but in the statement I quoted from manual, there are quite a few other Pio DVD players that work. Also, someone posted he was told by shop that "any Sony DVD player" will work.

I imagine any standalone CD player would work.
post #5049 of 5378
Quote:
Originally Posted by Hkan View Post

The link at twitter seems to be messed up, can't say why!

This is the direct link:
http://www.pioneerfaq.info/click/click.php?id=528

Thanks for hosting the file Hkan!

Do you know where we can get the rest of the firmware updates for the Susano?
post #5050 of 5378
Still looking for my USB -> serial dongle...I had it hooked up previously but not since I hooked up the Pronto serial extender last year...

Does anyone have a README on these earlier serial updates?
post #5051 of 5378
Quote:
Originally Posted by Dragnet View Post

Still looking for my USB -> serial dongle...I had it hooked up previously but not since I hooked up the Pronto serial extender last year...

Does anyone have a README on these earlier serial updates?

What kind of info are you looking for?
There is no README for the updates.

Remember it needs to be a RS-232C cross cable!
post #5052 of 5378
Quote:
Originally Posted by Dutch07 View Post

Thanks for hosting the file Hkan!

Do you know where we can get the rest of the firmware updates for the Susano?

Maybe
post #5053 of 5378
Thread Starter 
Quote:
Originally Posted by Dragnet View Post
Does anyone have a README on these earlier serial updates?
there were txt files in the zip I was given a year ago. here's 3. not sure if this is what you are looking for but this is all I've got

 

CHANGE_HISTORY_TOP(DISPLAY).txt 0.935546875k . file

 

CHANGE_HISTORY_TOP(DSP MAIN).txt 0.837890625k . file

 

SC09TX_HDMI_History.txt 0.830078125k . file
post #5054 of 5378
Thread Starter 
here's the rest

the txt for DSP flash has versions up to 3.012, doesn't have info on 3.014, the one Hkan got us

 

CHANGE_HISTORY_TOP(MAIN).txt 1.05078125k . file

 

CHANGE_HISTORY_TOP(DSP flash).txt 0.3681640625k . file
post #5055 of 5378
Thread Starter 
Quote:
Originally Posted by Dragnet View Post

Still looking for my USB -> serial dongle

Dug mine out of the drawer of PC cables. Checked it out with the MCACC software to make sure it communicates with the receiver. I hadn't used it in 2 yrs

Not going to tackle today, tho. I hope I can do it tomorrow to spend time on auto MCACC & setup stuff again.

I'll let you know how it turns out. I'll either be a happy camper or owner of a brick
post #5056 of 5378
Tried the update with my old Sony CD/MD player through optical but it didn't work. I'll dig out my old-er Sony DVD player and give it a go with that.
my laptop has RS232 on it and the MCACC software and it reads and writes to the LX90 just fine, also works with the Kuro setup for my LX5090 plasma.
Now I guess I should have a word with Hkan about firmware...
post #5057 of 5378
Quote:
Originally Posted by Dragnet View Post

Now, it would be very interesting to see what others here have version wise

Mine reads the same version numbers, and mine is a UK model without the sirrius radio option
post #5058 of 5378
Quote:
Originally Posted by ss9001 View Post

here's the rest

the txt for DSP flash has versions up to 3.012, doesn't have info on 3.014, the one Hkan got us

Thx Steve!

I'm still looking for the dongle but I might have to move around another PC instead (with RS-232) in order to upgrade the serial updates. Alas, I don't have the time for that this weekend. Not the upgrades themselves per se but restoring MCACC, input mapping, signal select, back speaker processing etc

What I can gather from the READMEs is that some multichannel SACD conditions would be improved. (I also have the european version with no tuners - i.e. a pure amplifier).

Tip: be sure to enter the service menu and press OK to go to the "GO ON" mode before starting up the ufu.exe program as any RS-232 activity on the serial port will wake up the amp. The 10 sec timeout is hopefully suspended when in "GO ON" mode.
post #5059 of 5378
Thread Starter 
Quote:
Originally Posted by Dragnet View Post

Alas, I don't have the time for that this weekend. Not the upgrades themselves per se but restoring MCACC, input mapping, signal select, back speaker processing etc

That's my dilemma, too Going thru all that is a lot of time; I've got all the mapping, settigs written down on in excel file but having to set it up from scratch again is something I don't look forward to.

IF not today, I'll fit in sometime next weekend for sure. I'd like to get this out of the way soon. Unlike the dts-ma issues, none of the rs232 updates are interfering with my own use of the AVR so I can take my time. Improving use of Surr B's and SACD with Pure Direct is the only reason I'm even tackling this at all.

I've had this for over a yr so it's not like I'm in a hurry. I admit I was nervous about trying it, but I have you, Hkan & others to thank for getting over my jitters. At least we got the dts-ma bomb fixed!

Thanks very much for the tip, I wouldn't have thought of that

Whenever I tackle it, I'll post how I made out.
post #5060 of 5378
Well with the help of the Pioneer faq site I have just updated the VSX920k and BDP430 in the bedroom.
Now that I have the rest of the firmware for the LX90 I will have a study of it and plan my update.

Big thanks Hkan
post #5061 of 5378
Well I've tried to update the firmware, got the DISP1 to update to 3.014 with my Sony DVD player.
The other firmware I've had no luck with, I can read the MCACC data fine but when I try to write the laptop says it is connected but when I press start I get a communication error and Updade Failed.
I have tried 2 laptops, an old DELL with a RS232 port and my new Lenovo X201T through a USB to Serial adapter, I get the same result Update Failed.
post #5062 of 5378
Thread Starter 
Quote:
Originally Posted by Alicatt View Post

I have tried 2 laptops, an old DELL with a RS232 port and my new Lenovo X201T through a USB to Serial adapter, I get the same result Update Failed.

simple question but did you change the com port in the Pioneer "ufu.exe" program to match the serial port com in the laptops? by default, the program uses com 3, but when the connection is live, com 4 appeared as another radio button choice when I was checking out the connection. since my USB adapter uses com 4, the program must have detected it & provided the other choice.

the other issue is data speed. my USB adapter is 9600 by default but the ufu program wants 19200 base speed & 57600 data send speed.

haven't tried to update yet but before I do, I planned on setting my USB adapter to 57600 or maybe 115200 bps data speed. Maybe yours is also set at 9600, like the old Windows Hyperterminal days.

getting serial devices to communicate sometimes can be tricky. we've all been spoiled by usb.

Also, did you select the "Go On" in the service menu before launching the ufu program?

I sure hope it's something simple. This should work.
post #5063 of 5378
Also make sure it is a crossed cable!
post #5064 of 5378
Thread Starter 
Quote:
Originally Posted by Hkan View Post

Also make sure it is a crossed cable!

excellent point! I forgot that.

It has to be a crossed or null modem cable, the same kind that's needed to use the MCACC software with the receiver. If it's a straight rs-232 cable, it won't communicate.

I'm hoping the problem's the cable or a com port mismatch.

Thanks, Hkan
post #5065 of 5378
Yup it is a X-over cable, the same one I use for MCACC with the Susano and for the isf custom menu on the PDP5090 plasma.

On the Dell (Win XP) it only has the one serial port, com1 and it is com1 with the MCACC too, It does say it is connected until I start the update then it says Comunication Failure and Update Failed.

On the other laptop(Win7 x64) it only has USB so I'm using a Prolific USB/Serial cable to a crossover to the LX90, Again it can read the MCACC on com3 but I get the same Comunication Failure and Update Failed.
If I try other com ports with this then it says Not Connected.
The cable again works with the PDP5090
post #5066 of 5378
You followed the instructions to the letter?
You're in the correct menu in the AVR?
You choose the correct mot file to be used?
Also you might need to turn off the AVR and unplugg the cable between each try that fails!

After set the volume to -- and multi zone to off, do you turn off the AVR?

List your steps here and I'll se iff your doing something wrong!
post #5067 of 5378
Thread Starter 
Hkan,

do u know if updating just the Display system also requires the memory reset? I could try just that one tonight to make sure it works if I didn't have to re-enter settings.
post #5068 of 5378
I chickened out doing the updates myself on this expensive machine but all seems to be good now.

I want to share my confidential panel snapshot after the updates:

post #5069 of 5378
Amp off, laptop on desktop
connect the RS232 to the Amp and laptop
Amp on, volume to --, multizone off, amp shut down.
Press Zone2 and Enter until Amp starts up.
Up arrow to Download menu and then up to Main, right arrow and enter, menu on LX 90 now says Go On.
Start ufu.exe, make sure that Full is selected, click on the radio button for file select and select the "07ter_main_1020(081006).mot" and after a few seconds the main page of ufu opens, I select a base speed of 19,200 and a data send speed of 57,600, check that com1 is selected, check that in the Update info it says that Target Device is connected and then I click on start.
The Update Info boxes report that they are comunicating with the target device and after 4 seconds where it says "Steps" it says Update Failed (in red) and below that it says Target Device failed to comunicate, or Target Device timed out (I have had both those messages)
post #5070 of 5378
Hkan, thank you very, very much! You saved me several hours having to lug my two receivers into a questionable service center for the updates. At the moment, I've updated DSP1 and will give Star Wars or Bridge over the River Kwai a try this evening. I'll save the other updates (and beer) for another weekend.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Official Pioneer SC-09TX/SC-LX90 Owner's Thread