or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › 2008 Samsung HL61A750 LED DLP owners thread and FAQ
New Posts  All Forums:Forum Nav:

2008 Samsung HL61A750 LED DLP owners thread and FAQ - Page 516

post #15451 of 15626
I found out my blue LED was out because my tv had a very obvious green/red hue to it. I didn't have to test anything, but I have heard if you take one of the LED's out and put a 9v battery on it should light up. If it doesn't then it is bad. In order to do this you will need to tear into the tv though. It's not difficult but can be a hassle if you find it's not the LED. You will have to put it back together and it won't be fixed. For me this would be a bummer, cause you know you will be opening it again soon to try something else. I'm no tech But I have changed my DMD chip, and a blue LED. Maybe someone else has a better answer them me.
post #15452 of 15626
Quote:
How would I know which of the LED is bad? Please help.
Did you understand the part above about "doing troubleshooting as described in the service manual" ?
post #15453 of 15626
Before I open the back I wanted to know the sequence to testing, meaning which ones to test first, the power supply 1 or 2, LED 1 2 3, or color wheel?

Here is what happened when I turned it on again this morning, first the green light blinks with the starting chime then a few more times by it self it tries to turn on with chime and green light blinking and finally, the three blinking light come on and continue blinking with no result.

Any guidance will help me figure out what to do, repair it my self or call a service center OR give it away.

Any help will surely be appreciated, I know many of you have done this before, please help.
post #15454 of 15626
Quote:
Originally Posted by afsariq View Post

Good morning guys!

I am a proud owner of Samsung HL61A750 for the past 5 years and was extremely happy until last night. It didn't power on and the lights started blinking one by one, after a while all three lights started blinking and it is not taking any remote commands and not even responding to the power button.
I love this Tv and my friends and family always admire the picture quality on this set, please advice me what might be the problem and solution to this issue, I will appreciate your inputs.

Thanks!!!
ASSY PCB MAIN;HL61A7
Part #: BP94-02326A

or

Samsung BP44-01001A Power Supply Board

or


Both
post #15455 of 15626
Cosmic...... Thank you for your help. I will download the manual and see I can figure out the cause of these three blinking light.

Domingoes38 is suggesting the power supply boards may be bad, what do you think?

Afsariq
post #15456 of 15626
Quote:
Originally Posted by afsariq View Post

Cosmic...... Thank you for your help. I will download the manual and see I can figure out the cause of these three blinking light.
Domingoes38 is suggesting the power supply boards may be bad, what do you think?
It could be a lot of potential problems, that's why you need to go through the testing. I didn't immediately suspect the power supplies, since the main board appears to be functioning to attemp the startup and blink the lights. So I wouldn't guess without more info, which you can get without having to buy anything... (unless you need to buy a voltmeter to do the measurements).
post #15457 of 15626
Good suggestions! I will be testing them with a voltmeter on coming Saturday. Is the required voltages listed in the links you provided earlier?

Then I will test the LED's and finally Color wheel I guess.

Thank you,

Afsariq
post #15458 of 15626
Quote:
Originally Posted by afsariq View Post

Good suggestions! I will be testing them with a voltmeter on coming Saturday. Is the required voltages listed in the links you provided earlier?

Then I will test the LED's and finally Color wheel I guess.

Thank you,

Afsariq

there is no color wheel
post #15459 of 15626
Quote:
Originally Posted by afsariq View Post

Cosmic...... Thank you for your help. I will download the manual and see I can figure out the cause of these three blinking light.

Domingoes38 is suggesting the power supply boards may be bad, what do you think?

Afsariq

my tv had the exact same symptoms and i had to replace both
post #15460 of 15626
Domingos38,
Please send me the links that will explain the procedure to test and replace these power supply boards.
Thanks!
post #15461 of 15626
post #15462 of 15626
Thank you Cosmicvoid for the link.

Afsar
post #15463 of 15626
Semi cross posting as its related, as this monlithic thread is hugetastic..

http://www.avsforum.com/t/1493442/samsung-hl61a750-led-driver-fault-heatsink-on-replacement


When I had just an LED fail, the TV still worked fine, missing the single color channel of course... Blue LED failed, twice, Green and Red worked fine. Replacing the LED is about twice as difficult as changing a CPU and heatsink on a PC. LED Driver module is easy to swap as well.

When my LED driver board was failing, (only when I had a blue LED installed ) the TV did not fire up, and I got the 3 LED blink up front. I suspect my failing LED driver card is what killed the blue LED on my set. Check the other post, not going to duplicate.

Both are easy to swap. Really taking your time It should take tops an hour.

The first time I opened up my set, it was 5 years old. So I spent an extra hour cleaning all the dust out. Cleaned all the fans out and reapplied thermal paste. As with most factory installed heatsinks, there was -way- too much thermal paste between the DLP chip copper back plate and the heatsink plates. I cleaned and reapplied a much smaller amount of Arctic Silver 5. Remember its copper against copper that provides the best heat removal. The paste is just to fill in the microscopic voids that would otherwise be insulating open air pockets between the copper plates.
post #15464 of 15626
Anyone know where I can still find the main power supply for this tv? Part number BP44-01001A?
post #15465 of 15626
Quote:
Originally Posted by boylez View Post

Anyone know where I can still find the main power supply for this tv? Part number BP44-01001A?

www.shopjimmy.com
post #15466 of 15626
Quote:
Originally Posted by SeekingNirvana View Post

www.shopjimmy.com

I can find it at a lot of sites, but all of them I checked, including shopjimmy, are out of stock.
post #15467 of 15626
Oh sorry, I figured shop jimmy had everything. Maybe contact them and see if they have some coming in. When I ordered my DMD chip from them they were out, but a week later they were in stock.
post #15468 of 15626
Quote:
Originally Posted by SeekingNirvana View Post

Oh sorry, I figured shop jimmy had everything. Maybe contact them and see if they have some coming in. When I ordered my DMD chip from them they were out, but a week later they were in stock.

OK, thx for the quick replies. I will check with them.
post #15469 of 15626
post #15470 of 15626
post #15471 of 15626
I am needing part no. BP94-02327A, Assy PCB S-LED Drive. It seems to be no longer available from Samsung. It appears Samsung is dropping replacements for these DLP TV's. If this is Samsung's way to force people into a new TV how do they think you would buy another Samsung product when they didn't take care of their customers before.
post #15472 of 15626
Quote:
Originally Posted by CADZOOM View Post

I am needing part no. BP94-02327A, Assy PCB S-LED Drive. It seems to be no longer available from Samsung. It appears Samsung is dropping replacements for these DLP TV's. If this is Samsung's way to force people into a new TV how do they think you would buy another Samsung product when they didn't take care of their customers before.

There are a ton on Ebay. As for their support, think about it. Mitsubishi made the 3D adapter for this set and Samsung left us hanging out to dry. These sets are plagued with issues and false promises of over 20,000 hours for the LEDs used in them. Love my set, but I doubt that I will ever buy another product from this company.
post #15473 of 15626
Quote:
Originally Posted by nickels55 View Post

There are a ton on Ebay.
Actually, there aren't any on ebay, at this time.
post #15474 of 15626

Been looking for over 2 weeks. Just missed one on Amazon. If any one see's one available please let me know! Thx

post #15475 of 15626

Found one @ Bestbuy Parts online.

post #15476 of 15626
just had mine fixed by an authorized Samsung repair group, I have the 61 incher and it white spotted on my after five years. They replaced the DMD chip, probably twenty minutes or so work. Would love his remote, instant diagnostics and the like. I was going to buy a Plasma, but with Panny exiting the market and nothing looking all that great no matter where I went to view them i figured its best to repair this set and wait for OLED to come down. I am still in love with the picture this set presents
post #15477 of 15626
Quote:
Originally Posted by Washu View Post

just had mine fixed by an authorized Samsung repair group, I have the 61 incher and it white spotted on my after five years. They replaced the DMD chip, probably twenty minutes or so work. Would love his remote, instant diagnostics and the like. I was going to buy a Plasma, but with Panny exiting the market and nothing looking all that great no matter where I went to view them i figured its best to repair this set and wait for OLED to come down. I am still in love with the picture this set presents

I have a 61" set with the white dots. I am deciding whether to have it fixed or buy a new set. Can I ask what the total bill was, parts and labor? Also, did you find the repair place on your own or did you contact Samsung? If you contacted Samsung, do you have a phone number? Thanks.

By the way, i started with 2 white dots many months ago, now i have about 65, and growing daily it seems.
post #15478 of 15626
Ok I have the 67" version and this morning the TV would not come on according to my wife.....When I got up and went in the living room it was on but only red was showing. I turned the TV off and back on and it was normal. Is this a certain sign of things are about to fail? If only the red was visible does this mean I need to order the blue and green leds?
post #15479 of 15626

67A750 here. Have the no chime blank screen flashing lights, etc. Read through most of the posts thought it was the led driver BP94-02327A. Ordered it from Bestbuy parts. Installed it and have same problem. Any other ideas?

post #15480 of 15626
I bought my Samsung 67" HL67A750 LED DLP in March 2009. In early 2013, it developed the left side shadow due to bad light tunnel.
Samsung replaced the entire light engine with a new one on 5/30/13. Problem solved.

Sometime in August 2013, I saw these on the screen:



I have left several phone messages with the authorized Samsung repair shop that installed the new engine and they don't return my calls.

Does anyone know what these circles are?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › 2008 Samsung HL61A750 LED DLP owners thread and FAQ