or Connect
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › The Official Samsung BD-P1500 Owner's Thread
New Posts  All Forums:Forum Nav:

The Official Samsung BD-P1500 Owner's Thread - Page 15

post #421 of 5645
Quote:
Originally Posted by aaranddeeman View Post

Why you don't like magnavox? This is the same as Philips BDP7200 (minus 5.1 anolog and a handful of decoding).
I agree that buying a smasung (if only $50 more) is no-brainer? But mag is not bad either as it is available.

I just read on the Funai/Mag thread that someone couldn't play a standard DVD on it- the mag.
post #422 of 5645
The Mag does play standard DVD's there has been an issue with a few disks but it if because of a new type of copy protection. It is the disk not the player. I have played with both players and the Mag seems to be built much better than the Samsung. The Mag also uses the Panasonic chipset and there is a rumor that it is also using a Sony loader. On the other hand the Mag will always stay at profile 1.1 and the Samsung will be upgradable with firmware to profile 2.0. The Samsung also had a eithernet connection. If you don't need profile 2.0 the Mag is a nice unit. PC World just rated the Phillips number 1 in their reviews and the Mag is very similar with a few less features. They should give up on these new copy protections. They only cause problems for honest buyers of disks and they are often broken in a few days by hackers.
Sony should concentrate on pushing Blu-Ray which has much harder copy protection and is much more difficult to break.
post #423 of 5645
It's not just the Mag, it's a few of the player out there (not just BD) that are having problems with the new copy protections.
post #424 of 5645
Hi, just bought 1500 having problem outputting Audiophile Bitstream to Denon 3808. All that shows up on denon is 5ch Stereo already own Toshiba A35 and it works fine when you select True HD and DTS-HD Master ( German Tomb Raider) front panel of 3808 says so. When select on PCM on 1500 it says Multi Ch In thats right but either BITSTREAM's just 5CH STEREO. If anyone has any thoughts thanks in advance.


mark
post #425 of 5645
Quote:
Originally Posted by sparky7 View Post

Hi, just bought 1500 having problem outputting Audiophile Bitstream to Denon 3808. All that shows up on denon is 5ch Stereo already own Toshiba A35 and it works fine when you select True HD and DTS-HD Master ( German Tomb Raider) front panel of 3808 says so. When select on PCM on 1500 it says Multi Ch In thats right but either BITSTREAM's just 5CH STEREO. If anyone has any thoughts thanks in advance.


mark

Mark, If you have the 1500 set to bitstream and I know this is something you may have done but press the standard button on the 3808's front panel under the cover. But usually the denon will switch automatically to the digital signal when it is received. I would recheck the 1500's settings. I have a 4308 and 1500 and they work great together. Mike
Mark also another stupid thing make sure and hit the input mode button until it goes back around to auto.
post #426 of 5645
Got the samsung 1500 last night at walmart...last one and got the $100 gift card too. Worked beautifully out of the box and very impressed! I have a sony 5.1 stereo that I used the optical out to (and hdmi direct from blu-ray to samsung lcd), and I only have 2 front Advent speakers...no center or rear speakers yet, due to the room layout. What audio setting should I set the blu-ray too?? I think it was set up on PCM (?) and sounded very nice even with 2 speakers. Is there a better setting? Also, should the 24 frame rate be set to on or off?? I have a 46" Samsung model 550...thanks for the help!!
post #427 of 5645
I watched the WAR lastnight with my sammy 1500, How do you access the bonus view? I tried pressing the bonus view button in the remote of sammy 1500 but it won't give access to it. Please help, Is there a feature in disc for me to choose while watching? Right after I chose the audio setting on the disc I went straight to play movie and could not access bonus view.
post #428 of 5645
I'm loving this player regarding the video quality. However, I'm having terrible lip sync problems with it. My receiver has adjustments for this but it doesn't seem to help much. Never encountered a moments problem with my Toshiba HD-A2 HD player so I'm not sure what the problem is here.
post #429 of 5645
Quote:
Originally Posted by FCEEVIPER View Post

I called 11 walmarts today and none of them had the Sam1500 in stock, but the 12th Wallmart did!

I got it for $348 with the $100 GC, I have already got 3 BD movies on sale for $15 with the GC.

The Wallmart in Covina Ca. only had 1 in stock, lucky me!

Review of the player later.

So, I setup the player yesterday on my XB4 40", man it looks great!

I watched 300 and it looked awesome!

Sofar no audio drops, and no other major problems. I love it.
post #430 of 5645
Watched Oceans 13 last night and had no audio or video issues (other than the fact that the movie itself looks like crap - I assume by design).
post #431 of 5645
Quote:
Originally Posted by rutlian View Post

I watched the WAR lastnight with my sammy 1500, How do you access the bonus view? I tried pressing the bonus view button in the remote of sammy 1500 but it won't give access to it. Please help, Is there a feature in disc for me to choose while watching? Right after I chose the audio setting on the disc I went straight to play movie and could not access bonus view.

Can anyone give me some help regarding Bonus view, I thought that if the disc specify a feature of bonus view, all you have to do is press bonus view
in 1500 remote and you can access it. Thanks in advance.
post #432 of 5645
If I remember right, when you first start playing the main movie on WAR it says to press up, down, left, or right (the direction arrows) to start the bonus view feature. Did you try pressing them instead of the bonus view button?
post #433 of 5645
Does the 1500 or 1400 have a sleep function?
My TV does and so do my Tvix streamers, and I really like being able to set them to sleep after 15/30/45/60/90/120/180 minutes for watching late night stuff.
post #434 of 5645
Quote:
Originally Posted by Beerstalker View Post

If I remember right, when you first start playing the main movie on WAR it says to press up, down, left, or right (the direction arrows) to start the bonus view feature. Did you try pressing them instead of the bonus view button?


I noticed that but I thought that is for the blu line features, I tried that but it give me where you are at the movie, But I will check it again tonight. Thanks.

I am glad more and more are buying the Sammy 1500, Goodluck to everyone keep sharing your concern, experiences with it. I for instance loving the picture quality watched the WAR last night and the sammy 1500 really delivers great PQ and AQ.
post #435 of 5645
Just got mine from Circuit City so far no problems except that it runs a little bit hot.
post #436 of 5645
Quote:
Originally Posted by mtmcrawford View Post

Mark, If you have the 1500 set to bitstream and I know this is something you may have done but press the standard button on the 3808's front panel under the cover. But usually the denon will switch automatically to the digital signal when it is received. I would recheck the 1500's settings. I have a 4308 and 1500 and they work great together. Mike
Mark also another stupid thing make sure and hit the input mode button until it goes back around to auto.

I'm talking to Samsung service tech right now he says I can only use Optical for BITSTREAM? Only stereo thru HDMI? Big help.

mark
post #437 of 5645
The service techs are amazing. They often have little or no knowledge about the player and give out wrong information. I had the same issue with the Mag player that I will be setting up for a friend.
post #438 of 5645
First, I have a few Samsung LCD displays and they have been perfect. Next, I am going to get a Samsung 650 to replace my big old heavy Sony HI Def CRT. Finally, I have an Onkyo 705, so I can decode bitstream. The price is right; it looks like Samsung is dedicated to improvement in its BluRay players and they are staying on top of firmware upgrades. I could have gotten a Panasonic BD30 a little cheaper at WalMart today, but I chose to get the Samsung. So far, it looks fantastic. Also, I have an Oppo 983H for standard DVD's so I am not worried about upscaling.

Also, thanks to other forum members for posting the bottom heat issue. I ordered an Antec laptop cooler. Can't hurt.

And finally, and a big reason, this forum and this thread in particular gives out really good feedback from members.
post #439 of 5645
Quote:
Originally Posted by rwestley View Post

The service techs are amazing. They often have little or no knowledge about the player and give out wrong information. I had the same issue with the Mag player that I will be setting up for a friend.

I 1st got hold a women CSR and told her my problem and she did the best she could but its little overwhelming trying to explain the problem. So asked to speak to a REAL SERVICE TECH. I should have just stuck to her.

mark
post #440 of 5645
Quote:
Originally Posted by rutlian View Post

I am glad more and more are buying the Sammy 1500, Goodluck to everyone keep sharing your concern, experiences with it. I for instance loving the picture quality watched the WAR last night and the sammy 1500 really delivers great PQ and AQ.

Thanks and I will.
post #441 of 5645
Quote:
Originally Posted by Har Katir View Post

Just got mine from Circuit City so far no problems except that it runs a little bit hot.

I placed mine in my rack on top of rubber stoppers. This gets it up in the air a little as the player looks like it draws air from underneath. I'll check temp later to see if it's cooler. I also have plenty of space between shelves for airflow
post #442 of 5645
Quote:
Originally Posted by gja View Post

I placed mine in my rack on top of rubber stoppers. This gets it up in the air a little as the player looks like it draws air from underneath. I'll check temp later to see if it's cooler. I also have plenty of space between shelves for airflow

What you've done is a good idea but it doesnt "draw air" at all since it doesn't have a fan.
post #443 of 5645
Quote:
Originally Posted by mtmcrawford View Post

Mark, If you have the 1500 set to bitstream and I know this is something you may have done but press the standard button on the 3808's front panel under the cover. But usually the denon will switch automatically to the digital signal when it is received. I would recheck the 1500's settings. I have a 4308 and 1500 and they work great together. Mike
Mark also another stupid thing make sure and hit the input mode button until it goes back around to auto.

Mike, I did try what you said about press the STANDARD button then Video Select button. The 1st time nothing happened tried diff. disc did it again and what ya know TRUE HD. Thanks for the tips seems like the A35 works a little friendlier with Denon. Just selected TRUE HD and it was there. So I'll see if it keeps working. Thanks again


mark
post #444 of 5645
Quote:
Originally Posted by aaranddeeman View Post

Why you don't like magnavox? This is the same as Philips BDP7200 (minus 5.1 anolog and a handful of decoding).
I agree that buying a smasung (if only $50 more) is no-brainer? But mag is not bad either as it is available.

Well, I'm biased toward the samsung because I own a new samsung tv. And also because I want to be able to use the samsung anynet feature. The mag also does not have optical audio out, which i prefer over coax out.

Im gonna go back to walmart tonight and see if i can get them to give me the bluray for 348-100
post #445 of 5645
Quote:
Originally Posted by sparky7 View Post

Mike, I did try what you said about press the STANDARD button then Video Select button. The 1st time nothing happened tried diff. disc did it again and what ya know TRUE HD. Thanks for the tips seems like the A35 works a little friendlier with Denon. Just selected TRUE HD and it was there. So I'll see if it keeps working. Thanks again


mark

Just glad I could help.
post #446 of 5645
Anybody having problems with having to press the remote several times or aim it just right in order for it to work? This seems to be my only issue other than it sounding a little clunky when loading up and reading a disc, I have not watched an entire movie on it yet though.
post #447 of 5645
Quote:
Originally Posted by soldonandy View Post

Anybody having problems with having to press the remote several times or aim it just right in order for it to work? This seems to be my only issue other than it sounding a little clunky when loading up and reading a disc, I have not watched an entire movie on it yet though.

+1

mark
post #448 of 5645
I've just watched The Game Plan and this player choked on several occasions. I had to skip 10 minutes at one scene + got choppy video on some other scenes. It's a rental disc so I hope that's the problem, not the player but I looked at the disc and the surface is good as new.

Anyone happened to play "The Game Plan" (blu-ray) on this player before?
post #449 of 5645
I have watched Pan's, Bee Movie(kids) and No Country with no problems of any sort.
post #450 of 5645
Quote:
Originally Posted by midnightman View Post

I've just watched The Game Plan and this player choked on several occasions. I had to skip 10 minutes at one scene + got choppy video on some other scenes. It's a rental disc so I hope that's the problem, not the player but I looked at the disc and the surface is good as new.

Anyone happened to play "The Game Plan" (blu-ray) on this player before?

I don't have the game plan but I tried lot of bluray with no problem so far. Did you tyr other Bluray movies? I Know you mention the disc surface is clean but still could be the disc not the player.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Blu-ray Players
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › The Official Samsung BD-P1500 Owner's Thread