or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Onkyo 606 - Problems
New Posts  All Forums:Forum Nav:

Onkyo 606 - Problems

post #1 of 7
Thread Starter 
I just bought the 606 recently. I like many of the features, but am disappointed in the sound quality while listening to music. Has anyone else noticed this? It actually sounds worse than my previous reciever (a low-grade 10 yr old Sony). Are these Home Theater receivers worse at reproducing music or is it just the one I picked out.
post #2 of 7
What are you using to listen to music? How is it connected?
post #3 of 7
Did you run the Room EQ setup software?
post #4 of 7
Thread Starter 
Quote:
Originally Posted by MandM View Post

What are you using to listen to music? How is it connected?

FM Stereo through the receiver and CD's through an optical digital cable. It just sounds tinny and seems to lack mids and lows.

I did run the EQ when I first set it up, but I've since changed the settings to try for improvement.
post #5 of 7
There are several sound options available. Did you increase bass/treble? Boost db? Did you turn on the music optimizer?
post #6 of 7
Thread Starter 
Quote:
Originally Posted by bhazard View Post

There are several sound options available. Did you increase bass/treble? Boost db? Did you turn on the music optimizer?

I'm trying all of those things, but it doesn't seem like it should be necessary. I guess I expected a deeper, richer sound.
post #7 of 7
for what its worth, i had the 605 for almost a month and my older 602 sounds way better. i hate to speculate but i think that onkyo's quality has gone downhill considerably in recent years. this is very sad because i have been a long time fan of onkyo but i am going to switch to either yamaha or pioneer. i really like the sound of both of these.

good luck
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Onkyo 606 - Problems