or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › 2008 Samsung HL67A750 LED DLP owners thread
New Posts  All Forums:Forum Nav:

2008 Samsung HL67A750 LED DLP owners thread - Page 85

post #2521 of 2719
Thanks Kinmanc, that does make sense as we have a very dusty area here. I just have to get the guts to open up the guts so to speak...

Appreciate it and I will keep you posted.
post #2522 of 2719
Quote:
Originally Posted by wipster View Post

Thanks Kinmanc, that does make sense as we have a very dusty area here. I just have to get the guts to open up the guts so to speak...

Appreciate it and I will keep you posted.

That happened to me with my previous Samsung DLP HDTV - HL-R5688W. After the Samsung tech almost gave up and said he didn't see the smudges, I grabbed a blanket and covered the screen with him under it and wallah, he saw the problem. They were very faint but all over the screen. He said the DMD board was bad--basically the DLP chip that has all the mirrors was mis-aligned and was causing those shadows. Luckily it was under warranty.
post #2523 of 2719
Are the Panasonic BT-110 series 3D Blu Ray players also Checkerboard compatible? I know the BT-100 is. How can you tell? I cant find in the literature what type of 3D they output.
post #2524 of 2719
Quote:
Originally Posted by larrylwill View Post

Are the Panasonic BT-110 series 3D Blu Ray players also Checkerboard compatible? I know the BT-100 is. How can you tell? I cant find in the literature what type of 3D they output.

The 110 has an option to output checkerboard.
post #2525 of 2719
I started reading the whole thread on the BD110 and one guy said that it would not out checkerboard when converting DVD's to 3D but would output it for 3D blu rays. Although I have not seen anyone confirm this. That would be a bummer.
post #2526 of 2719
Can anyone confirm if the LG AG-S110 glasses work with this TV?
post #2527 of 2719
hi folks...
post #2528 of 2719
i have a problem with my Samsung HL67A750
post #2529 of 2719
It is out of warranty...and the details are in my next post...please forgive me for posting so many messages...I have to get through the 3post limit to include any links...
post #2530 of 2719
Quote:
Originally Posted by Just4Kicks View Post

That happened to me with my previous Samsung DLP HDTV - HL-R5688W. After the Samsung tech almost gave up and said he didn't see the smudges, I grabbed a blanket and covered the screen with him under it and wallah, he saw the problem. They were very faint but all over the screen. He said the DMD board was bad--basically the DLP chip that has all the mirrors was mis-aligned and was causing those shadows. Luckily it was under warranty.


My HL67A750 was working fine until recently, and one day images started flickering/jumping all over the screen....no matter what video source...even the TV menus were jumping up and down....it kept doing it once every 30secs....i turned it off for a week.

Tried it again, but it had gotten worse every time...and now it is at a point where...I turn it on...it makes the startup sound then gives this blue screen and then the display goes blank. I have no idea what is going on.....appreciate any help. thanks


Please see the video here


Some pics here...

I bought this TV in May 2009, had warranty for 12+3 (15months)...I have this in my basement, as my home theater TV, I rarely use it, I would guesstimate and say that I'v used it for <150-200hrs.

Called Samsung, standard answer, out of warranty, u gotta go to the website, and get a quote for paid service.

Anyway..my question is that is this a common problem? Can anyone suggest any fixes....I personally don't want to hang on to an Old TV...i would rather buy a new one ( DEFINITELY NOT A SAMSUNG EVER!! AGAIN)....than put $$$$ into this old one.

thanks for your inputs...and help.
post #2531 of 2719
the screen is stretched left/right, up/down. Cannot read the banners scrolling along the bottom of the screen. Some of the football stats are chopped off at the top corner, can;t read. none of the settings menu help. is there a simple way to fix (adjust) this or do I need to find a Samsung tech here in Oklahoma City. thanks for your help
post #2532 of 2719
Ray...this may seem too simple, and too optimistic, but have you tried pushing the P/Size button?
post #2533 of 2719
True 1080p/24

I've been away from this thread for quite a while. Was is ever said conclusively whether the hl67a750 can do true 24fps? It displays at 120hz, correct? Does that mean it does a 5:5 pulldown, or 3:2 doubled? If the latter, does it matter if I send bluray video from my HTPC at 24?
post #2534 of 2719
I have had the TV for 3 years. A few months ago it randomly started to lower the volume by itself. It wasn't a big deal, after a minute it would stop acting up. Yesterday it didn't stop lowering the volume, like the volume button was stuck. I am using a receiver, so I continued watching a movie. After 30 minutes, it started cycling through channels by itself. I couldn't use the remote, couldn't use the buttons on the side of TV. I unplugged it, waited for an hour, turned it back on and it started cycling through channels right away. I searched this forum, someone suggested unpluging the connection to the button module (buttons on the side of the TV). I did that, it has been off all night and I just turned it on and it started cycling through the channels right away. I am out of ideas now. Please help.
post #2535 of 2719
Update:

It stopped cycling through the channels. The volume is still stuck. I was able to switch channels using the remote but with a lot of difficulty. It would work once in every five or ten times I push the CH+ button. I was able to get sound output to the receiver, so it is usable. However, I cannot change input source and use it with my HTPC.
post #2536 of 2719
^^^ I'm sure you've ruled out the remote.
post #2537 of 2719
Yes, the remote is ruled out. As well as the board responsible for the buttons on the side of the TV. I unpluged it. Appreciate any other ideas.
post #2538 of 2719
Sorry, can't think of anything else, unless another piece of equipment is interfering. Might be time for a service call.
post #2539 of 2719
Update:

The volume is not stuck anymore, but the TV cycles through channels, which is worse, because I could use my receiver for the sound. So, the TV is totally unusable again.
post #2540 of 2719
How is your TV set up for the broadcast signal?
post #2541 of 2719
I am using Comcast cable (without a box). It worked fine for 3 years. But the volume thing started happening first several months ago. So that tells me there is something wrong with one of the boards. When I wrote my previous post, I left the TV on to cycle through channels. Then 30 minutes later I went back and it stopped. But the volume was stuck (which is not a big deal since I use a receiver). I was glad to be able to turn channel 6, even though it wasn't easy. Like I said I push the CH button 5 to 10 times and it would move 1 channel. So, I was able to watch the second half of the show.
post #2542 of 2719
I guess your only recourse is to call Samsung.
post #2543 of 2719
Since the TV is 3 years old and out of warranty, would Samsung even listen to me? I was thinking about a local TV repair shop. Please, let me know as I haven't had any experience with Samsung customer support in the past. Thanks.
post #2544 of 2719
I haven't either, but, from what others have stated, they will direct you to an authorized Samsung service shop in your area. Probably your best bet. Good luck.
post #2545 of 2719
Mine is still going strong, and even though I bought a new panasonic 3D plasma it will still be my main theater for 3D movies and blurays. I haven't checked in for so long. I was just wondering can someone give me a good picture settings for 2D movies? I want to get the most out of movies like Avatar, X-men, and so on. And I probably don't have the best settings.
post #2546 of 2719
Quote:
Originally Posted by Teremei View Post

Mine is still going strong, and even though I bought a new panasonic 3D plasma it will still be my main theater for 3D movies and blurays. I haven't checked in for so long. I was just wondering can someone give me a good picture settings for 2D movies? I want to get the most out of movies like Avatar, X-men, and so on. And I probably don't have the best settings.

See this thread. There are some recommended settings in the first post.
post #2547 of 2719
Quote:
Originally Posted by nickr336 View Post

Since the TV is 3 years old and out of warranty, would Samsung even listen to me? I was thinking about a local TV repair shop. Please, let me know as I haven't had any experience with Samsung customer support in the past. Thanks.

I've contacted Samsung support a few times and while they were for warranty repairs, I've received great service from authorized in-home service centers.
post #2548 of 2719
Hi, I have had the Samsung 67A750 for almost 3 years now - great TV.

Recently and quite suddenly, the blue color has stopped showing - so everything is either red or green or shades of grey/black. I'm assuming the Blue LED has malfunctioned.

Since the other colors are working fine and the picture is fine otherwise without any weird ghosting or banding or halos, I assume it's not the board itself.

I see the blue LED (BP07-00031A) going for about ~$100. Has anyone replaced the LED themselves, and was it difficult?

Any help/pointers much appreciated.
post #2549 of 2719
Quote:
Originally Posted by solara View Post

Hi, I have had the Samsung 67A750 for almost 3 years now - great TV.

Recently and quite suddenly, the blue color has stopped showing - so everything is either red or green or shades of grey/black. I'm assuming the Blue LED has malfunctioned.

Since the other colors are working fine and the picture is fine otherwise without any weird ghosting or banding or halos, I assume it's not the board itself.

I see the blue LED (BP07-00031A) going for about ~$100. Has anyone replaced the LED themselves, and was it difficult?

Any help/pointers much appreciated.

http://www.youtube.com/watch?v=xHE1knzJSfQ
post #2550 of 2719
I got the TV fixed today. The main board had to be replaced. I am having a problem programming the channels. I used to have digital channels like CBS, it was channel 6-1. Now there it is gone and I can't get in high definition. Nothing changed as far as cable. I connect Comcast cable directly to the TV and then do Auto programming using Cable option. For the type of the cable I selected STD. I also tried the other types unseccessfully. Please, help.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › 2008 Samsung HL67A750 LED DLP owners thread