or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › 2008 Samsung HL67A750 LED DLP owners thread
New Posts  All Forums:Forum Nav:

2008 Samsung HL67A750 LED DLP owners thread - Page 88

post #2611 of 2719
I currently have my Samsung HL61A750 hooked up to a Panasonic DMP-BDT310 3D Blu-ray player and 3-pin IR emitter and pair of active shutter glasses from from Ultimade3dheaven.com

434

The DMP-BDT310 is set to checkerboard output and the 3D looks pretty good with my current setup.

For those that already have the Tru3D kit..is it really as promised? I'd like to be able to take advantage of more 3D sources, particularly 3D broadcast TV and Comcast 3D on demand, and understand I need to convert the "side by side" 3D to the "checkerboard" format my TV can handle Will the Tru3D kit work with my current setup? I'm hoping I can simply re-use my existing emitter and 3D glasses and simply buy the "Samsung 3D TV adapter kit" for $240.

275

I know the Mitsubishi Mitsubishi 3DA-1 and 3DC-100S adapters will work, but I'm looking to re-use my existing glasses and emitter and not spend $400+ on a new 3D setup and pay for an emitter and glasses I don't need.

It does seem like a lot of hoops to jump through to get 3D on my LED DLP, but I'm not in a position to spend $1500+ on a new 60 inch 3D LCD or plasma TV, especially when my DLP still works great.



Thanks...
post #2612 of 2719
Over time my TV has started getting some transparent blue lines on both sides of the TV. Can anybody help me out with this problem? I searched, but didnt find a solution. Whats going on here??
post #2613 of 2719
update on my issue. Mack camera was great to deal with. have a brand new "light engine" in my 67" and am good to go!
post #2614 of 2719
My HL67A750 caught a case of no screen. Not sure whats causing it but i removed the light engine in an attempt to replace any blown out LED...no i realize how much those things cost online to order so i kinda wanna be sure. Anyone know how to determine if and which LED is out(i'd assume its one of the darker colors, blue or green)?

Also i also realize it could be motherboard or power supply issues so my 2nd thought is to lug it to Best Buy and get a Geek Squad quote on it...but was wondering would i need to take the whole tv or could i just take the already removed light engine?
post #2615 of 2719
my house was hit by a lightning strike( not direct strike,just nearby) and now my HL67A750 will not power up,no picture and the LED light flashes green.
is it a goner?
can it be fixed?

thanks
post #2616 of 2719
Time to call your insurance company.
post #2617 of 2719
Quote:
Originally Posted by Lord Vader View Post

Time to call your insurance company.
no kidding
it fried 2 tv's and 1 pool pump
not sure its worth calling them ,cause i have a $2500 deductible and my premium will probably go up
post #2618 of 2719
Wow. That's quite a large deductible.
post #2619 of 2719
no screen and all lights blinking, sounds like the Led driver board, i did lots of research and mine seems bad, looks corroded, but the rest of the components look good, oh and ANYONE know where i can get the Led driver board part number BP94-02327A, for less then $100 shopjimmy is out of stock
post #2620 of 2719
I haven't posted here in quite a while, but my TV is having a problem and was wondering if any experts had any advice.

Ok, about a week ago I noticed my colors looked off, almost like everything was too red or pink. Most noticeable on skin tones and whites. Then, occasionally I noticed the TV would sort of flash back to normal for a second, then back to pinkish. Then after a few days, I totally lost all green. I then ordered a new green LED and waited for it to come. Yesterday I got it, and took the light engine assy. out of the TV to replace it. Before I put the new LED in, I tested the old one with a battery. It worked fine. So, I reinstalled the old one (with new heat sink compound) and reinstalled everything. All is well and I have green again...except my color is still off. Still too much red/pink with the occasional flash to normal. Also, I noticed a few peculiar things in the menu. When I try to change the LED control, it doesn't seem to make any difference. Whether MIN or MAX, it looks the same. Also, I don't think changing the color temp. was doing anything. Warm 2 look the same as Normal and even Cool.

Any ideas are appreciated.
post #2621 of 2719
Quote:
Originally Posted by XCALIBURPCS View Post

no screen and all lights blinking, sounds like the Led driver board, i did lots of research and mine seems bad, looks corroded, but the rest of the components look good, oh and ANYONE know where i can get the Lelood driver board part number BP94-02327A, for less then $100 shopjimmy is out of stock


looks like u need a new power supply and new main board
post #2622 of 2719
Quote:
Originally Posted by rmac694203 View Post

I haven't posted here in quite a while, but my TV is having a problem and was wondering if any experts had any advice.

Ok, about a week ago I noticed my colors looked off, almost like everything was too red or pink. Most noticeable on skin tones and whites. Then, occasionally I noticed the TV would sort of flash back to normal for a second, then back to pinkish. Then after a few days, I totally lost all green. I then ordered a new green LED and waited for it to come. Yesterday I got it, and took the light engine assy. out of the TV to replace it. Before I put the new LED in, I tested the old one with a battery. It worked fine. So, I reinstalled the old one (with new heat sink compound) and reinstalled everything. All is well and I have green again...except my color is still off. Still too much red/pink with the occasional flash to normal. Also, I noticed a few peculiar things in the menu. When I try to change the LED control, it doesn't seem to make any difference. Whether MIN or MAX, it looks the same. Also, I don't think changing the color temp. was doing anything. Warm 2 look the same as Normal and even Cool.

Any ideas are appreciated.

And....I just lost green again. Ugh

...Tapatalking
post #2623 of 2719
NEED HELP WITH CRACKED SCREEN.

So my two year old decided to throw a hard plastic toy microphone at my HL61A750. Now, I have two cracks running up from the bottom of the screen. I've read up a little on replacing the screen. It appears there are actually two screens, a lenticular and a fresnel. Samsung sells the parts for like $198 a piece.

My questions are how do I know if I need to replace both screens and is there an off-brand manufacturer to buy them from? At ths point in the life of the tv, I would hate to put in 400-500 bucks for repairs. That's assuming that I can do the repair myself without screwing it up!

Any help is much appreciated.
post #2624 of 2719
i am about to put in $310 worth of new components in my HL67A750
New power supply and new Main board Love this tv
post #2625 of 2719
Quote:
Originally Posted by domingos38 View Post

i am about to put in $310 worth of new components in my HL67A750
New power supply and new Main board Love this tv

As my extended warranty ran out in June, I'm just waiting for something to go wrong now. rolleyes.gif $310 seems like a reasonable rate for the parts. Are you doing the repairs yourself?. I'd be curious to know how easy/hard it was for you to do.
post #2626 of 2719
i had a tech come out to diagnose the problem .he replaced the main board and the power supply and bam the tv was fixed. he wanted $600 for the parts and labor and i told him to forget about it .
he took out the new parts ,i paid him $99 trip charge and he left me an written estimate with the parts #'s
i went online and order the parts and i'll be installing them when they come in. very easy and i watched him do it
$310 including a $53 core charge .i'll get the $53 back if i ship the used main board back to them so the total will actually be $260 for parts
post #2627 of 2719
I'm in the same boat-waiting for something to go wrong. I just wanted to ask you folks where you were buying parts these days. It sounds like you're getting good prices ansd I wanted to stash any and all parts sorces away while there are still people talking about it.I love this TV! Is anyone making LED DLPs anymore?
post #2628 of 2719
Quote:
Originally Posted by GEOD998 View Post

I'm in the same boat-waiting for something to go wrong. I just wanted to ask you folks where you were buying parts these days. It sounds like you're getting good prices ansd I wanted to stash any and all parts sorces away while there are still people talking about it.I love this TV! Is anyone making LED DLPs anymore?

partstore.com

no more LED DLP's are made
post #2629 of 2719
Quote:
Originally Posted by rmac694203 View Post

I haven't posted here in quite a while, but my TV is having a problem and was wondering if any experts had any advice.
Ok, about a week ago I noticed my colors looked off, almost like everything was too red or pink. Most noticeable on skin tones and whites. Then, occasionally I noticed the TV would sort of flash back to normal for a second, then back to pinkish. Then after a few days, I totally lost all green. I then ordered a new green LED and waited for it to come. Yesterday I got it, and took the light engine assy. out of the TV to replace it. Before I put the new LED in, I tested the old one with a battery. It worked fine. So, I reinstalled the old one (with new heat sink compound) and reinstalled everything. All is well and I have green again...except my color is still off. Still too much red/pink with the occasional flash to normal. Also, I noticed a few peculiar things in the menu. When I try to change the LED control, it doesn't seem to make any difference. Whether MIN or MAX, it looks the same. Also, I don't think changing the color temp. was doing anything. Warm 2 look the same as Normal and even Cool.
Any ideas are appreciated.

How exactly did u check the LED to know it was fine? Just curious about the technique so i can troubleshoot my own LED's.



Also on the power supply and main board anybody know ways either of those can be easily checked and ruled out? I want to order parts and get my tv back up and running. My symptoms sound like what XCALIBURPCS described.
post #2630 of 2719
Quote:
Originally Posted by Egomaniacal1 View Post

Quote:
Originally Posted by rmac694203 View Post

I haven't posted here in quite a while, but my TV is having a problem and was wondering if any experts had any advice.
Ok, about a week ago I noticed my colors looked off, almost like everything was too red or pink. Most noticeable on skin tones and whites. Then, occasionally I noticed the TV would sort of flash back to normal for a second, then back to pinkish. Then after a few days, I totally lost all green. I then ordered a new green LED and waited for it to come. Yesterday I got it, and took the light engine assy. out of the TV to replace it. Before I put the new LED in, I tested the old one with a battery. It worked fine. So, I reinstalled the old one (with new heat sink compound) and reinstalled everything. All is well and I have green again...except my color is still off. Still too much red/pink with the occasional flash to normal. Also, I noticed a few peculiar things in the menu. When I try to change the LED control, it doesn't seem to make any difference. Whether MIN or MAX, it looks the same. Also, I don't think changing the color temp. was doing anything. Warm 2 look the same as Normal and even Cool.
Any ideas are appreciated.

How exactly did u check the LED to know it was fine? Just curious about the technique so i can troubleshoot my own LED's.

When you take the light engine out, then remove the heat sink, the phlat is kind of stuck to it (with thermal paste). Before I separated them, I just took a 9v battery and touched the + and - contacts on the phlat and it lit right up. Also, I tested the voltages the phlats were receiving while the tv was running, and found the green was way off.

...Tapatalking
post #2631 of 2719
An update to my problem, i replaced the powersupply, checked the service manual and was not getting 16v going to the main board, was only getting 5 volts, i replaced the powersupply and bam, bingo set came back to life.
post #2632 of 2719
Quote:
Originally Posted by XCALIBURPCS View Post

An update to my problem, i replaced the powersupply, checked the service manual and was not getting 16v going to the main board, was only getting 5 volts, i replaced the powersupply and bam, bingo set came back to life.

Same here!! Much thanks to rmac694203 for giving me an easy way to check my LEDs and narrow down what my issue was which led me to replace the power supply(bp96-01726b is the part number for anyone following after me that needs to know).

Now i just wish i had never started on my light engine initially because now i have the 2" shaded area on the left side of tv which i read online is caused by the light tunnel. Anyone know what part number for the light tunnel or the whole light engine itself is? If it ain't one thing its another.
post #2633 of 2719
In anticipation of the Avengers 3d bluray release I FINALLY took the plunge into 3d with this 67 inch tv. I paired it up with a new Panasonic DMP-BDT500 and some Optoma ZD101 glasses. The BDT500 is one of their newer players and I can confirm it has the checkerboard option these tvs use. So far I've only watched Imax Under the Sea 3d and I am simply blown away by the quality of the 3d picture. The depth is amazing. The popout effect is amazing. Brightness, detail, I could go on and on. Maybe the cinemas around here don't set up their 3d properly because I've never seen anything that comes close.
post #2634 of 2719
Quote:
Originally Posted by justinmc View Post

In anticipation of the Avengers 3d bluray release I FINALLY took the plunge into 3d with this 67 inch tv. I paired it up with a new Panasonic DMP-BDT500 and some Optoma ZD101 glasses. The BDT500 is one of their newer players and I can confirm it has the checkerboard option these tvs use. So far I've only watched Imax Under the Sea 3d and I am simply blown away by the quality of the 3d picture. The depth is amazing. The popout effect is amazing. Brightness, detail, I could go on and on. Maybe the cinemas around here don't set up their 3d properly because I've never seen anything that comes close.

can u help me out?
i have this tv but can't get to it display in 3D
can u post the exact settings (what u did in the menu) to turn 3D on?

thanks
post #2635 of 2719
First I set the player to checkerboard and started the test pattern. I then went into the picture settings on the tv menu. Under the picture options tab I set the 3d effect to mode 2. The glasses immediately picked up the signal. I think there has to be 3d video on the screen in order for the 3d effect option to become selectable. Also, you have to use the hdmi 3 input on the tv and change the label to pc. It's kind of a hassle to have to go back and select the 3d effect in the tv menu every time you watch a bluray but in the end it's SO worth it.
post #2636 of 2719
You can also use the Tools button on the remote to select the 3D mode. It's a little faster.
post #2637 of 2719
got it to work
looks glorious


thanks guys for your help
post #2638 of 2719
Quote:
Originally Posted by bruce73 View Post

You can also use the Tools button on the remote to select the 3D mode. It's a little faster.


I don't think I had ever used the tools button. Thanks for the tip!
post #2639 of 2719
Does Directv 3D work on the Samsung?
post #2640 of 2719
Quote:
Originally Posted by JackB View Post

Does Directv 3D work on the Samsung?

it works , but u need the mitsubishi adapter
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › 2008 Samsung HL67A750 LED DLP owners thread