or Connect
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › Official Pioneer Elite BDP-05FD & BDP-51FD Owners Thread / Vs 1.32 DTS-HD MA
New Posts  All Forums:Forum Nav:

Official Pioneer Elite BDP-05FD & BDP-51FD Owners Thread / Vs 1.32 DTS-HD MA - Page 994

post #29791 of 30708
Quote:
Originally Posted by blowabs View Post

Ok ..gonna get my 1.7 SW update disc next week.
Never upgraded from the day I bought it 3 years ago.
Any advice?
Thanks guys n girls
Allan

1.72 is the latest. I would update it to that and be done with it. I'm at 1.72 with no problems.

Here's a LINK to find the latest updates and how to download and install them.
post #29792 of 30708
Quote:
Originally Posted by info_dan View Post

blowabs, what is your firmware's current version?

You -might- have to upgrade to -one- intermediary version if yours is really old, others had problems in the past upgrading from one of the first versions to the most recent.

But before we get all in a huff about it, let's wait to see what is your current version.

Dan.

Guys
I have never upgraded. I guess i will try look and see what version that is. Probably 1.0.
G...you went straight from stock to to 1.72. I did see last year that guys were, sometimes, having trouble going straight up without a stop in between ??? thx
post #29793 of 30708
Quote:
Originally Posted by info_dan View Post

blowabs, what is your firmware's current version?

You -might- have to upgrade to -one- intermediary version if yours is really old, others had problems in the past upgrading from one of the first versions to the most recent.

But before we get all in a huff about it, let's wait to see what is your current version.

Dan.

I said that then and I will say this now: Nothing is stated by Pioneer that an intermediate fw release is needed. Somewhere in the multitude of threads back then it was 'prescribed as fact' and is someone's erroneous believe stated probably to earn some limelight in a somewhat dismal time in firmware updates.
post #29794 of 30708
....hmmm...okaaaaaay...now I'm scared...
post #29795 of 30708
Quote:
Originally Posted by blowabs View Post

Ok ..gonna get my 1.7 SW update disc next week.
Never upgraded from the day I bought it 3 years ago.
Any advice?
Thanks guys n girls
Allan

blowabs,

What is prompting the update? You have been very fortunate that you have not required an update during your ownership. I probably could have gotten by with less frequent updates beyond 1.32 which implemented DTS-HD MA.
post #29796 of 30708
Quote:
Originally Posted by blowabs View Post

Guys
I have never upgraded. I guess i will try look and see what version that is. Probably 1.0.
G...you went straight from stock to to 1.72. I did see last year that guys were, sometimes, having trouble going straight up without a stop in between ??? thx

As Toshiman stated it is not documented by Pioneer that updates should be done sequential since the updates should be cumulative.
post #29797 of 30708
Well ...I wanted to use this unit in the living room because musically it sounded better (w/ music BDs) than my Panny 58k. So while the Pio was in the bedroom- no probe. Tried "Rise of the Planet of The Apes" and nothing happened. ??? Figured it is time to with a FW to start watching new movies so i don't have to have two BD players in the loving room.
post #29798 of 30708
Toshiman, bakerwi: I agree with you that updates should be cumulative and that you *should* only need to update to the latest one.

My statement to blowabs was that he *might* have to update to *one* intermediary update, based on that discussion some time ago.

blowabs:
No need to be scared! Just try to update straight to 1.72 first. If it goes well, you're done. If not, we can dig out a previous firmware for you.

To check your firmware version:
* In the player setup menu, go to "Video Out," highlight 16:9 under TV Aspect Ratio and press the blue button.

Either way, let us know so we can have another data point on this discussion.

Thanks!

Dan.
post #29799 of 30708
Quote:
Originally Posted by info_dan View Post

Toshiman, bakerwi: I agree with you that updates should be cumulative and that you *should* only need to update to the latest one.

My statement to blowabs was that he *might* have to update to *one* intermediary update, based on that discussion some time ago.

blowabs:
No need to be scared! Just try to update straight to 1.72 first. If it goes well, you're done. If not, we can dig out a previous firmware for you.

To check your firmware version:
* In the player setup menu, go to "Video Out," highlight 16:9 under TV Aspect Ratio and press the blue button.

Either way, let us know so we can have another data point on this discussion.

Thanks!

Dan.

Dan
Ok...got version:1.21,,,so....what is next in the software saga
post #29800 of 30708
Quote:
Originally Posted by info_dan View Post

Toshiman, bakerwi: I agree with you that updates should be cumulative and that you *should* only need to update to the latest one.

My statement to blowabs was that he *might* have to update to *one* intermediary update, based on that discussion some time ago.

blowabs:
No need to be scared! Just try to update straight to 1.72 first. If it goes well, you're done. If not, we can dig out a previous firmware for you.

To check your firmware version:
* In the player setup menu, go to "Video Out," highlight 16:9 under TV Aspect Ratio and press the blue button.

Either way, let us know so we can have another data point on this discussion.

Thanks!

Dan.

Dan,

While Pioneer doesn't mandate that we update sequentially; I personally would probably update to a few earlier firmwares as opposed to going from 1.0 to 1.72. Firmware updates can be very finicky. Also, an earlier firmware may remedy whatever problem he is experiencing without having to jump straight to 1.72.
post #29801 of 30708
"No need to be scared! Just try to update straight to 1.72 first. If it goes well, you're done. If not, we can dig out a previous firmware for you.

To check your firmware version:
* In the player setup menu, go to "Video Out," highlight 16:9 under TV Aspect Ratio and press the blue button.

Either way, let us know so we can have another data point on this discussion."

So maybe someone has SW ver. 1.32 here. The reason i also never upgraded was because of all the problems people had with updates. I guess i just need 1.3 for now because I think that covers Java playback....??...
post #29802 of 30708
Quote:
Originally Posted by blowabs View Post

Dan
Ok...got version:1.21,,,so....what is next in the software saga

You can prepare an update disk, v1.72, per the instructions on the Pioneer site and update your machine. Or you can call or order an update disk, v1.72, direct from Pioneer. If Pioneer required intermediate updates to update to the newest firmware, it would be provided for on the update site in the form of down load firmware and instructions.

Your third choice is to guess which intermediate firmware you should try or ask the question here and wait for the conjecture.

The BDP-05FD and BDP-51FD are four year old machines. If there were a problem otherwise for updates, it seems reasonable the problem would be well documented by now doesn't it?

I had a NIB BDP-51FD that I sold last year. It had earlier firmware on it and as a condition of sale I was required to preform the update. I updated direct to v1.71 with no problem.

Good luck!
post #29803 of 30708
Quote:
Originally Posted by b curry View Post

You can prepare an update disk, v1.72, per the instructions on the Pioneer site and update your machine. Or you can call or order an update disk, v1.72, direct from Pioneer. If Pioneer required intermediate updates to update to the newest firmware, it would be provided for on the update site in the form of down load firmware and instructions.

Your third choice is to guess which intermediate firmware you should try or ask the question here and wait for the conjecture.

The BDP-05FD and BDP-51FD are four year old machines. If there were a problem otherwise for updates, it seems reasonable the problem would be well documented by now doesn't it?

I had a NIB BDP-51FD that I sold last year. It had earlier firmware on it and as a condition of sale I was required to preform the update. I updated direct to v1.71 with no problem.

Good luck!

You were going great till .."Good Luck!"
I ordered the disc from Pioneer on friday, and they said it would take 5 bus. days. I will ask them on monday if i should update to an earlier ver. first (they will prob. tell me that no i don't have to). SW ver. 1.32 started some major upgrades it looks like. Question: Do you have to keep your fingers crossed while the CD is updating??
post #29804 of 30708
Quote:
Originally Posted by info_dan View Post

...................

My statement to blowabs was that he *might* have to update to *one* intermediary update, based on that discussion some time ago.

...............

I remember that discussion. There was an owner that wasn't able to go directly to the most recent firmware.

If I had to make a guess, perhaps v1.32 might the the intermediate step needed since it was a major update? Now that I think of it, wasn't v1.17 another "big" update?
post #29805 of 30708
Quote:
Originally Posted by Saturn94 View Post

I remember that discussion. There was an owner that wasn't able to go directly to the most recent firmware.

If I had to make a guess, perhaps v1.32 might the the intermediate step needed since it was a major update? Now that I think of it, wasn't v1.17 another "big" update?

Ok then...whoever would like to donate their 1.32 disc (I will pay for shipping going and coming) it would be greatly appreciated???!!! Thx Pio folks!!
Allan
post #29806 of 30708
You find all firmwares at PioneerFAQ
post #29807 of 30708
I updated my firmware to 1.71 last year on my 05 FD from the first version that came with the player without a problem.
post #29808 of 30708
There was a Technical Bulletin sent out regarding the update problem!
I can't check now as my (external)HD with all the Pioneer stuff on it has crashed!
post #29809 of 30708
Quote:
Originally Posted by blowabs View Post

Ok then...whoever would like to donate their 1.32 disc (I will pay for shipping going and coming) it would be greatly appreciated???!!! Thx Pio folks!!
Allan

When I sold my 51 I gave the person all my update discs as well. Sorry.

I see Hkan posted a link to the previous updates. You could make your own update disc if so inclined.
post #29810 of 30708
Quote:
Originally Posted by Hkan View Post

There was a Technical Bulletin sent out regarding the update problem!
I can't check now as my (external)HD with all the Pioneer stuff on it has crashed!



Did you have a backup?
post #29811 of 30708
Quote:
Originally Posted by Saturn94 View Post



Did you have a backup?

The external HD was my backup in the begining, how ever due to a large amount of data collected during the yrs the bckup HD become an original HD due to that mt PC HD become more and more full! so no no bckup!
But some stuff is still on main HD. Most of the data is availble to me again if needed. Just hard to know what I did have as the index file was lost too.
How ever some of the stuff is hard to get.
Well HD will be sent away for recovery!
Hopefully it will be recoverble! And not to costly, lost a lot of photos too so need to have it recoverd!
Oh well lesson lernt to have 2 or 3 backups!

We start all over again
New external HD orderd!
All stuff at web pages are still availble
post #29812 of 30708
Quote:
Originally Posted by blowabs View Post

You were going great till .."Good Luck!"
I ordered the disc from Pioneer on friday, and they said it would take 5 bus. days. I will ask them on monday if i should update to an earlier ver. first (they will prob. tell me that no i don't have to). SW ver. 1.32 started some major upgrades it looks like. Question: Do you have to keep your fingers crossed while the CD is updating??



Yes, I understand. I added "Good Luck" as I still have a bad taste from a firmware update that went wrong last night. I have a WDTV Live that I updated yesterday and it bricked. I down loaded the firmware and installed it very carefully following Western Digitals instructions. Everything went as it should until the last second. The screen froze and the unit bricked; it will not reset. I then spent two hours on the phone with WD's tech support. They first said that they are aware that there have been firmware problems with their servers; downloading corrupt firmware. They acknowledge that there is/was a bad batch of WDTV's that were susceptible to "bricking". They then informed me that my unit could not be replaced because it was out of warranty saying that the warranty is calculated from the build date vs. the purchase date. When I asked about repair I was told that they do not repair them they only replace them if the unit is in warranty. I have a case number and have appealed to level three customer service at this time.

So, in this world where it seems you must have a computer to do anything and products are delivered with promised features that will not work until supported by firmware that does not yet exisit... A firmware update can always be a little bit of a crap shoot.

In your case, you can't watch some of the newer movies unless you update the firmware. OTOH you're afraid to update fearing the machine not working after the update. Either way, you have a machine that doesn't work.

Anyhow, you get the point. Put in the disk and update to v1.72.

Good Luck!
post #29813 of 30708
I thank Hkan for trying to get me 1.32. Hope you get your ext. hd going again. My 'good luck' wisher

i hope WD does the right thing soon for you...

i may just skip the intermediate update and go for the whole tamale when i get Pio's 1.72b disc...at least i have 1.21 on my machine. I forgot I upgraded when i fist got the machine and it updated with no problem.

The software saga saunters on...:roll eyes:

[anybody besides"Chasl52" do a 1.71 from zero??thx]
post #29814 of 30708
Quote:
Originally Posted by blowabs View Post

I thank Hkan for trying to get me 1.32. Hope you get your ext. hd going again. My 'good luck' wisher

i hope WD does the right thing soon for you...

i may just skip the intermediate update and go for the whole tamale when i get Pio's 1.72b disc...at least i have 1.21 on my machine. I forgot I upgraded when i fist got the machine and it updated with no problem.

The software saga saunters on...:roll eyes:

[anybody besides"Chasl52" do a 1.71 from zero??thx]

Which version do you need? I'm pretty sure I have every version.

edit: here's a link for 1.32, let me know if you need a different version.

http://www.sendspace.com/file/bc31z3
post #29815 of 30708
Quote:
Originally Posted by kemitchell View Post

Which version do you need? I'm pretty sure I have every version.

edit: here's a link for 1.32, let me know if you need a different version.

http://www.sendspace.com/file/bc31z3

Thanks a lot.... Kyle
Guy say they've had trouble with zips and prefer the Pio disc....true?
[btw...did you do updates in increments?]
post #29816 of 30708
Quote:
Originally Posted by blowabs View Post

Thanks a lot.... Kyle
Guy say they've had trouble with zips and prefer the Pio disc....true?
[btw...did you do updates in increments?]

I have two 51's. The first I bought was one of the pre-release BB units with the demo FW. It's been updated with every single FW update as they were released (and some before they were released).

My second 51 had sat in the box for a year or so before I hooked it up. It still had the original 1.00 FW on it. At the time I hooked it up 1.70 was the latest FW. I tried to update it straight to 1.70 from 1.00 and could never get it to update. I then tried updating it to an older FW, I'm thinking it may have been 1.32 but I'm not 100% sure. It updated no problem and immediately after that I was able to update to 1.70.

I've never had any trouble updating FW with discs I burnt from the zip files (other than trying to update from 1.00 to 1.70 that is).
post #29817 of 30708
Quote:
Originally Posted by blowabs View Post

Thanks a lot.... Kyle
Guy say they've had trouble with zips and prefer the Pio disc....true?
[btw...did you do updates in increments?]

When I had my 51 (came with v1.0), I downloaded every available update and burned my own update discs and never had a problem (my 51 had v1.65 on it when I sold it).

I've done the same with my 320 and also have not had any problems.

Just make sure you follow the instructions.
post #29818 of 30708
Quote:
Originally Posted by blowabs View Post

So maybe someone has SW ver. 1.32 here. The reason i also never upgraded was because of all the problems people had with updates. I guess i just need 1.3 for now because I think that covers Java playback....??...

1.72 has been updated by a lot of people and seems very stable, so right now that would be my target version.

Quote:
Originally Posted by blowabs View Post

You were going great till .."Good Luck!"
I ordered the disc from Pioneer on friday, and they said it would take 5 bus. days. I will ask them on monday if i should update to an earlier ver. first (they will prob. tell me that no i don't have to). SW ver. 1.32 started some major upgrades it looks like. Question: Do you have to keep your fingers crossed while the CD is updating??

Forget about Pioneer, that will just be a waste of time IMHO...

If you are comfortable burning a CD from an .iso file, you can just download the 1.72 update from the Pioneer web site. The .iso is in a zip file, so when you extract it, it is verified for integrity.

1.32 had the DTS-HD MA decoding within the player. This thread still has the title of it! It was THE major update, and I also have kept a copy of all the firmwares I downloaded (I never ordered a CD from Pioneer). But again, try the 1.72 update directly first.

You don't need luck, but you need patience to follow the instructions and wait, and ideally have the unit plugged into a UPS in the very, very, very bad luck case you have a utility power failure at the wrong time during the update.

Dan.
post #29819 of 30708
Quote:
Originally Posted by info_dan View Post

1.72 has been updated by a lot of people and seems very stable, so right now that would be my target version.



Forget about Pioneer, that will just be a waste of time IMHO...

If you are comfortable burning a CD from an .iso file, you can just download the 1.72 update from the Pioneer web site. The .iso is in a zip file, so when you extract it, it is verified for integrity.

1.32 had the DTS-HD MA decoding within the player. This thread still has the title of it! It was THE major update, and I also have kept a copy of all the firmwares I downloaded (I never ordered a CD from Pioneer). But again, try the 1.72 update directly first.

You don't need luck, but you need patience to follow the instructions and wait, and ideally have the unit plugged into a UPS in the very, very, very bad luck case you have a utility power failure at the wrong time during the update.

Dan.

Dan
Are you saying that if the 1.72b disc does not work (going from 1.21) -- i can then put in 1.32zip which Kyle was nice enuff to send & revive my machine?? thx allan
post #29820 of 30708
Quote:
Originally Posted by blowabs View Post

Dan
Are you saying that if the 1.72b disc does not work (going from 1.21) -- i can then put in 1.32zip which Kyle was nice enuff to send & revive my machine?? thx allan

That's what I would do, I'd try the latest version first and if it won't take then try the older version I posted.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Blu-ray Players
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › Official Pioneer Elite BDP-05FD & BDP-51FD Owners Thread / Vs 1.32 DTS-HD MA