or Connect
AVS › AVS Forum › Display Devices › Ultra Hi-End HT Gear ($20,000+) › Problem with my Tact TCS Mk II, please help.
New Posts  All Forums:Forum Nav:

Problem with my Tact TCS Mk II, please help.

post #1 of 9
Thread Starter 
Hello all,

I flashed my TCS Mk II with the latest firmware version. After flashing it said Programming OK and it rebooted itself as it is supposed to do.

After that I get the following in the display

TCS MKII CALIBRATION
*********

And after a few * it said:

TCS MKII CALIBRATION
DONE

And after a few seconds I'm getting the * again:
TCS MKII CALIBRATION
*********

So it keeps repeating, it looks like it is stuck in a loop.

I already disconnected every cable, but even with only the power cable plugged in it stays in the loop.

I still can get it in Programming Mode and flash it again, but even after flashing with the original firmware on the original CD, it is still stuck in the loop.

I already emailed Tact, but haven't heard from them yet.

Anyone have/had the same experience with hist TCS or can tell me what to do?

Thank you in advance!

Regards,
Alain
post #2 of 9
Give them a phone call. E-mail support does not work with TacT.

(I'm still waiting for the answer to 3 e-mails I sent Boz maybe 2 months ago. I know I'm going to have to call him, but since it's not urgent I haven't done it yet).

Peter
post #3 of 9
Thread Starter 
Quote:
Originally Posted by Peter Nielsen View Post

Give them a phone call. E-mail support does not work with TacT.

(I'm still waiting for the answer to 3 e-mails I sent Boz maybe 2 months ago. I know I'm going to have to call him, but since it's not urgent I haven't done it yet).

Peter

Hi Peter,

I already contacted db-systems in france and sent the unit to them. I got it back two days ago. They suspect my unit got a 'power-surge' because it got six broken boards (I/O-board, main dsp board, and 4 other dsp boards).

But it is working again now, so I'm again.

Thank you for your answer however.

All the best,
Alain
post #4 of 9
I just upgraded my firmware and have the exact same problem! Has anyone else had this same problem?
post #5 of 9
Quote:
Originally Posted by shaun5 View Post

I just upgraded my firmware and have the exact same problem! Has anyone else had this same problem?

shaun5,

I was going to suggest you try the Tact Audio group at Yahoo groups.

However, I note that this problem is also posted there by "s.haun5"

TacT software is one place where I follow the maxim:

If it isn't broke; don't fix it.
post #6 of 9
Boz fixed my TCS over the phone! It seems the firmware on the website and my original CD is corrupt. He emailed me a new firmware and everything was back up and running.
post #7 of 9

Hi Shaun5,

 

I have thesame problem after updating the software on my Tact TCS MKII. Do still have the right software to fix this problem? I already tried both versions posted on the Yahoo Groupsite, but they both didn't work.

 

Tried both: V1.0.43F12  &  V1.0.44F11.

 

I sincerely hope that you can help me out.

 

Thanks in advance,

 

Teun

post #8 of 9
Mine became a door stop too after I did the firmware upgrade. Boz and TacT was of no help frown.gif.
post #9 of 9
Quote:
Originally Posted by amirm View Post

Mine became a door stop too after I did the firmware upgrade. Boz and TacT was of no help frown.gif.

Before March 2012 Boz was of help if you had the patience to deal with him. Unfortunately it's impossible to get hold of Boz (or anyone else at TacT) since May 2012.

Nevertheless, Amir may be right: Without Boz help, it's probably a doorstop cool.gif
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Ultra Hi-End HT Gear ($20,000+)
AVS › AVS Forum › Display Devices › Ultra Hi-End HT Gear ($20,000+) › Problem with my Tact TCS Mk II, please help.