or Connect
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › The Official Sony BDP-S550 Owner's Thread
New Posts  All Forums:Forum Nav:

The Official Sony BDP-S550 Owner's Thread - Page 131

post #3901 of 3979
So the problem is that US Sony players do not play back 25fps, and I am sure this is an intentional firmware issue. I re-converted the titles to 29.97fps with ImageMixer and they work fine. This investigation also led me to the very nice Nero Video 11 featuring GPU acceleration for the conversion, and it does burn to blu-ray, for only $30.
post #3902 of 3979
The US Sony S590 plays 1080i50 mpeg-ts file but not on a BD-ROM, as reported in that thread. It looks like the restriction is on BD media so another media might work. No harm trying.
post #3903 of 3979
I don't care for 25fps anyway, motion is jerky. How I ended up with it is still a mystery.
post #3904 of 3979
i'm with you drc72,

my s550 is a beast. no need to upgrade. the 6-channel outputs into my anthem avs-30 inpts and eek.gif
post #3905 of 3979
Quote:
Originally Posted by donaldsonjune View Post

i'm with you drc72,
my s550 is a beast. no need to upgrade. the 6-channel outputs into my anthem avs-30 inpts and eek.gif
Cool! I originally used the 7.1 analog outs on an older receiver that I use to own, and it sounded great, but I was ready to move to an HDMI receiver so I don't need the analog outs anymore. I just have my 550 bitstream over HDMI to my Pioneer which can decode all the lossless codecs.
post #3906 of 3979
Warning, there may be a serious problem with the manufacturing of this disk. I just purchased the 3D/2D version today from BB in Southern NH. Got home, and, because I had already seen the movie in the theater I first tried to run the extended "extras" 2D Bluray disk and had problems getting it to even boot up or to play. The furthest I got was the Menu Screen but the disk either wouldn't load or would freeze my Bluray player. Sometimes the menu screen would work but it was impossible to navigate anywhere or to get any of the special features to play. I own the SONY BDP-S550 Bluray player (plays 2D only), it has the latest firmware update and have never had any problems playing any Bluray disk before, never until today. After it wouldn't play I cleaned the lense, tried blowing high pressure air on the lense and this disk still would not play or play properly. On the other hand every other Bluray disk I placed in the machine after that worked flawlessly. I then put in the 2D Bluray copy of Prometheus. It also took a very long time for the 2D movie disk to boot up but when it did, the menu screen and everything played perfectly throughout the first half of the film. The problems start when the film is over half over, when Shaw enters the room where David is washing the feet of Weyland who has been revived from hyper sleep. From that point on in the disk, MASSIVE MACRO BLOCKING and all sorts of video distortion and artifacts presents itself. The movie is nearly unwatchable throughout the remainder of the film. The audio is fine and appears unaffected. As for this 2D Bluray disk, the pause, and play work but the menu screen does not function properly either.

I examined both 2D disks and they appear normal, flawless and glossy, no scratches whatsoever which leads me to believe there may be a serious, massive pressing problem. I hope this is not the case. Please other AVS members with the S550 and this 3D, 2D version, please report your findings.

Looks like this goes back first thing tomorrow frown.gif
post #3907 of 3979
Quote:
Originally Posted by Jmouse007 View Post

Warning, there may be a serious problem with the manufacturing of this disk. I just purchased the 3D/2D version today from BB in Southern NH. Got home, and, because I had already seen the movie in the theater I first tried to run the extended "extras" 2D Bluray disk and had problems getting it to even boot up or to play. The furthest I got was the Menu Screen but the disk either wouldn't load or would freeze my Bluray player. Sometimes the menu screen would work but it was impossible to navigate anywhere or to get any of the special features to play. I own the SONY BDP-S550 Bluray player (plays 2D only), it has the latest firmware update and have never had any problems playing any Bluray disk before, never until today. After it wouldn't play I cleaned the lense, tried blowing high pressure air on the lense and this disk still would not play or play properly. On the other hand every other Bluray disk I placed in the machine after that worked flawlessly. I then put in the 2D Bluray copy of Prometheus. It also took a very long time for the 2D movie disk to boot up but when it did, the menu screen and everything played perfectly throughout the first half of the film. The problems start when the film is over half over, when Shaw enters the room where David is washing the feet of Weyland who has been revived from hyper sleep. From that point on in the disk, MASSIVE MACRO BLOCKING and all sorts of video distortion and artifacts presents itself. The movie is nearly unwatchable throughout the remainder of the film. The audio is fine and appears unaffected. As for this 2D Bluray disk, the pause, and play work but the menu screen does not function properly either.
I examined both 2D disks and they appear normal, flawless and glossy, no scratches whatsoever which leads me to believe there may be a serious, massive pressing problem. I hope this is not the case. Please other AVS members with the S550 and this 3D, 2D version, please report your findings.
Looks like this goes back first thing tomorrow frown.gif
I''m sorry what was the first movie you where having an issue with?????
post #3908 of 3979
Quote:
Originally Posted by DRC72 View Post

I''m sorry what was the first movie you where having an issue with?????

I had problems with both 2D bluray disks.

The first 2D disc I tried to play was the extended extras Bluray disk that comes as a bonus with the 3D version of the movie.

The 4 disc, 3D version contains:

A 3D disc/version of the movie which I can not play so I do not know if there are any issues with it.

The 2D Bluray of the film: As mentioned above: I had lots of trouble loading the disk, but the movie played fine without any problems until Shaw enters the room where David is washing the feet of Weyland who has been revived from hyper sleep. From that point on in the disk, MASSIVE MACRO BLOCKING and all sorts of video distortion and artifacts presents itself. The movie is nearly unwatchable throughout the remainder of the film. The audio is fine and appears unaffected. As for this 2D Bluray disk of the movie, the pause, and play work but the menu screen does not function properly and I could not get the back or forward scene function to work either.

The 3rd disc is a 2D Bluray extended features disk. This material is NOT available in the 2D Bluray version of the film set. This is the first Bluray disc I was talking about in my previous post. I could not get this 2D disc to play properly at all. Sometimes I could get the menu screen to load but nothing worked, every feature was frozen and could not be accessed. Other times the menu screen wouldn't even load. After playing this disc my S550 bricked every time. I could not eject the disc and every function on my S55o froze up. I literally had to unplug the player in order to do a hard reset just to eject the disc! One funny thing happened. Once after the menu screen loaded and it bricked my player I pulled the plug, did a hard reboot and ejected the disc. When I installed a totally different movie, a Weyland insignia background screen appeared and was the first image presented! This image lasted a good 30 seconds before it disappeared and the different Bluray movie I had placed in the S550 (ALIEN) loaded and began to play properly.

The final disc is the digital copy of the film.

Needless to say, I am VERY disappointed in FOX and the quality of this disc set. I have never experienced the massive problems described above with any single Bluray or Bluray disc set before. frown.gif

The only other problem I ever had playing any disc with our SONY S550 was with one disc in the SPARTACUS series. One of the episodes on the 3rd disc froze at a certain point in the show. It was a factory pressing issue they were aware of. I sent the disc back it was replaced and the new disc worked properly.

One more thing, I double checked. My S550 firmware was updated September 16, 2012 so I have the latest version.
post #3909 of 3979
Am I the only one that can't figure out what DVD set poster is complaining about?
post #3910 of 3979
He mentioned Prometheus in his op, so I assume that
post #3911 of 3979
Quote:
Originally Posted by DRC72 View Post

I''m sorry what was the first movie you where having an issue with?????


PROMETHEUS 2D Bluray, not DVD. Sorry I didn't make myself clear earlier. Exchanged the PROMETHEUS 3D Bluray set will attempt to rewatch tonight. Since I returned it to a different BB for exchange. I am hoping the problem rests with the 2D Bluray discs and not with the SONY S550's ability to play them. I should know by the end of the evening. If this is the case, it will be the first 2D Blurays my S550 has not been able to play, ever.
post #3912 of 3979
Quote:
Originally Posted by Jmouse007 View Post

PROMETHEUS 2D Bluray, not DVD. Sorry I didn't make myself clear earlier. Exchanged the PROMETHEUS 3D Bluray set will attempt to rewatch tonight. Since I returned it to a different BB for exchange. I am hoping the problem rests with the 2D Bluray discs and not with the SONY S550's ability to play them. I should know by the end of the evening. If this is the case, it will be the first 2D Blurays my S550 has not been able to play, ever.
Well from what I gathered from your post, I more inclined to believe it's a disc issue. Although somehow the data in it is bricking your 550? Very weird.
post #3913 of 3979
Good news/Bad news:

I watched the 3D Prometheus Bluray set I exchanged at a different BB today and here are the results:

1) The Good News: Both the 2D Bluray movie Prometheus and the 2D Bluray Extended Extras discs played flawlessly on our SONY BDP-S550 and exhibited none of the serious problems I listed earlier. No bricking of my player, no macro blocking, no freezing of functions on the Bluray remote or player... nothing. Everything worked and played exactly like it was supposed to: Exceptional Audio and Video.

2) The Bad News: There are definitely some copies of this 3D/2D set of Prometheus that have serious problems that are factory/pressing related (the macro blocking occured at the exact same spots and in exactly the same way every time and everywhere I rewound and checked throughout the entire last 1/4 of the film, indicating that the problems were imbedded in the disc and not a malfunction of our player. So let the buyer beware. *If anyone on AVS experiences any of the problems/issues I listed in my original post regarding the 3D set of Prometheus, immediately return the set and exchange it for another one (preferably from a different location because the batch the store had you purchased yours from may have more defective sets from the same pressing).

I hope these findings prove helpful to everyone interested in purchasing the Blu-ray version of Prometheus.
post #3914 of 3979
Posted this in the Prometheus Bluray thread:

Not sure whether I got lucky and bought a non-defective set. My Sony BDPS550 didn't exhibit any of the glitches reported by other users of the same player and disc. Just wondering though, if the severe macroblocking is the result of having one's BD Live connected, as it has been reported that with this player there are slight malfunctions playing discs due to BD Live. I'm still on factory firmware. The disc loaded at about the same speed as other Blurays I have. Bloody amazing. Watching Prometheus credits as I post this. I also used my destatic gun on it before playing.
post #3915 of 3979
My copy of prometheus blu ray is also macroblocking in the same place when the the team is entering the room. I exchanged a new copy from amazon but the new copy does the same thing. I think the Sony S550 is having issues with this movie, my other blu rays play fine. I have over 200 blu ray movies, many of them BD live without any problems on any of them.
Edited by kingair - 10/18/12 at 6:16am
post #3916 of 3979
My 2D copy plays fine...a couple of times the "pop up menu" appeared..but after I hit ther button on the remote...it went away...
post #3917 of 3979
I also have the same exact problem you are describing. I had to unplug the unit and plug it back in before it would work right with Prometheus. Found another thread that states you need to turn off the Internet (Select "Don't Allow") The first time it broke up on me was during the big head in the chamber sequence. Second time was same scene you described.
post #3918 of 3979

Sony BDP-S550 Firmware Version V020

Does anyone know where I can download this version of firmware?? All the ones that I click on, send me to Sony and they will only let you download version 026:confused:

Thank You:D
post #3919 of 3979
Quote:
Originally Posted by arnie920 View Post

Does anyone know where I can download this version of firmware?? All the ones that I click on, send me to Sony and they will only let you download version 026:confused:
Thank You:D

Why do you want version 020? 026 works fine.
post #3920 of 3979
I have used DVDFAB for the last 4-5 years backing up my DVDs. Its always done fine until the Cinavia came out. I know everything that I have read, says that version 026 does not contain anything pertaining to Cinavia. Seeing the date when Version 020 came out I thought this would solve my problem. I gave up on Spiderman, and Expendables 2 I have tried 5 times with no luck.....the dvd player does not even recognize the dvd. But thedvd will play perfect on my computer and it will also play fine in my car, and the audio is fine through the whole movie, so I presumed it was the Sony BDP-S550. I have read on the DVDFAB forum that others have been able to back these dvds up.....so if the problem is not the player,I guess it has to be with the software that I am using, or the way I am trying to back it up:confused:

Thank You
post #3921 of 3979
Looks like Cinavia infected the 550 after all?????
post #3922 of 3979
No, not with the latest firmware.
post #3923 of 3979
Leaving aside the presence of cinevia or not, I dont think you can roll back to previous firmwares anyway. I do have 020, but a Region B version, which probably isnt much good to you.
post #3924 of 3979
Quote:
Originally Posted by ausdavep View Post

Leaving aside the presence of cinevia or not, I dont think you can roll back to previous firmwares anyway. I do have 020, but a Region B version, which probably isnt much good to you.


Thanks, you are probably right about the rollback.................................thanks for the offer of 020
post #3925 of 3979
Firmware #026 for the Sony BDP-S550 IS NOT infected with cinavia. I have a S550, I updated the firmware to 026, and I tested the player to ensure it remained clean. The same goes for the S350, as it uses the same firmware, and I updated and tested one of those also. What you are describing does not sound like cinavia processing at all. Something else is going wrong with your back-up process.
Be sure you are using the latest version of DVDFab for starters. You might peruse the DVDFab forum or ask a question there to get some help. Describe exactly the process you are following in the forum as well as your results and ask for suggestions.
post #3926 of 3979
Hi guys , I also had the same problem with the blu-ray micro blocking in PROMETHEUS . My friend brought his new copy over last night to watch and it happened again. . I had already seen it a couple of months back when the movie was first released on blu-ray and had exactly the same issues with micro blocking in exactly the same part of the film as everyone here describes .In the end I thought it was just a bad rental bluray copy back then, I also tried cleaning my lens with compressed air and it still made no difference.

In the end I uplugged its power supply to get the BDPS550 to start to work again.. I've played many other movies since then and never had the same issue again untill last night,. PROMETHEUS did it again..

I only connected to BD live two weeks ago so that was not the issue for me causing the problem 3 months ago and I've had the latest firmaware update for around a year . Has there been any newer firmware updates this year that might solve this problem ?
post #3927 of 3979
Quote:
Originally Posted by whitespark View Post

Hi guys , I also had the same problem with the blu-ray micro blocking in PROMETHEUS . My friend brought his new copy over last night to watch and it happened again. . I had already seen it a couple of months back when the movie was first released on blu-ray and had exactly the same issues with micro blocking in exactly the same part of the film as everyone here describes .In the end I thought it was just a bad rental bluray copy back then, I also tried cleaning my lens with compressed air and it still made no difference.
In the end I uplugged its power supply to get the BDPS550 to start to work again.. I've played many other movies since then and never had the same issue again untill last night,. PROMETHEUS did it again..
I only connected to BD live two weeks ago so that was not the issue for me causing the problem 3 months ago and I've had the latest firmaware update for around a year . Has there been any newer firmware updates this year that might solve this problem ?

Firmware #026 released in June-2012 is the most current firmware for the S550.
I watched my Prometheus 2D blu-ray on my S1000ES - and it played perfectly.
If you tell me exactly where your Prometheus 2D blu-ray disc starts macroblocking, I will drag my S550 out of the box in the closet and test it.
Can you tell me chapter and approximate time where the problem occurs?
post #3928 of 3979
G'day Rich86,
I just checked my software version on the s550 and its 07,2,024 .. Do you know if the 026 version is meant for region B (Australia), I know the firmware updates are usually indigenous to each region?. As far as exact chapter of the fault in the Prometheus movie,that's a little hard to determine because it's my friends BD Disc .But it was well into the movie past half way just before the part where Whalen ( Guy Pierce ) comes on the seen, around where the doctor has her own self administrated operation.
cheers Rick.
post #3929 of 3979
I just did a quick check on Sony Australia and version 024 is the latest update firmware for our region which came out in May 2011 . MMMM!!! interesting ..
post #3930 of 3979
I emailed sony au about whether an update would be forthcoming for our units and got a very typical lazy response, this was a long time ago now.i don't have Prometheus but I recommend sending an email with your experiences and maybe a link here to indicate it is well and truly a known issue.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Blu-ray Players
AVS › AVS Forum › Blu-ray & HD DVD › Blu-ray Players › The Official Sony BDP-S550 Owner's Thread