or Connect
AVS › AVS Forum › Gaming & Content Streaming › HD Radio › Denon S-52 - Internet Radio Problems
New Posts  All Forums:Forum Nav:

Denon S-52 - Internet Radio Problems

post #1 of 4
Thread Starter 
I have a Denon S-52 and cannot for my life get the Internet Radio to work at home. Damn it, I'm getting desperate. Does anyone have a clue?

I'm not a complete idiot when it comes to computer stuff, but I'm willing to be classified as one as long as I get some help on this. :-)

The machine works at the store, verified by staff. I've tried the Internet Radio with wireless (WEP security) at my job, and got it to work myself . So there is some verification that it is not completely broken (And that I'm not completely lost).

I don't know the configuration of those networks.

I've also had it working at home by bypassing the Router, and connect it directly to the cable modem. This works as well. But then I have no connection for computers, etc.

At home, I have a cable modem , and a NETGEAR Router connected to that. I've tried connecting the S-52 to my router with wireless, and with a wire. I can get it to connect with all sorts of security settings (WEP, None, WPA) "Connection succeeded", and then after ages of waiting it comes up "Empty" when trying to get to the Internet Radio Channles. (IF I try with faulty security parameters I get "Connection failed", as expected).

I've reconfigured my Router to basic settings, upgraded it to the latest firmware. I'm out of ideas.

It will not work at my home network. And in addition to this, as soon as I try, it screws up my network, and all other units (wired computer and wireless lapton) loses their connections.

So, somehow it seems as if the problem is not related to the S-52, at least not completely. But on the other hand, I have no problems with connecting all sorts of equipment to my wireless router.

Any clues?
post #2 of 4
I'm not sure if this will totally help but I recently had a cable modem problem...

Do you have more than one connection actually in the radio? USB for some reason doesn't jive that well if the ethernet was connected too. Simply unplugging the usb made the ethernet work. Having more than one thing connected makes it get confused...
post #3 of 4
This is a late response but I just purchased one of these units refurbished from an authorized DENON reseller and I had trouble connecting to internet radio via wireless router.

I found a reset option for the radio in the manual which involves disconnecting the power cable, holding the SNOOZE button and the Track Forward Button (>>|) down simultaneously while reattaching the power cable, all the while waiting for the display to show "INITIALIZE" to release the buttons. I then could set up the network wirelessly with the DHCP "on" option and entering the Security Key.

Works perfectly now! But these steps have to be repeated whenever the power is disconnected or interrupted.
post #4 of 4
Just a few notes on this, otherwise, old thread:

There's a recent firmware update for the Denon S-52 (I updated mine around 2012-03-01).

I've had better luck with a hard wired setup than wireless.

If you want to go wireless and DHCP is giving you fits, try just assigning it a static IP for your network. I had better luck with that (this was before the latest firmware update - I don't know if they addressed this issue or not).

One other thing that took me a while to get sorted was a DLNA server for my Mac. I went through a few before ending up on Twonky and I've had very good luck with Twonky on the Denon S-52.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HD Radio
AVS › AVS Forum › Gaming & Content Streaming › HD Radio › Denon S-52 - Internet Radio Problems