or Connect
AVS › AVS Forum › Display Devices › Digital Hi-End Projectors - $3,000+ USD MSRP › Official JVC RS10/HD350 Owners Thread!
New Posts  All Forums:Forum Nav:

Official JVC RS10/HD350 Owners Thread! - Page 51

post #1501 of 2036
Quote:
Originally Posted by adidino View Post

Yes, they are physically identical.

I thought so. That's really interesting.
post #1502 of 2036
Quote:
Originally Posted by Canary_Jules View Post

I thought so. That's really interesting.

Actually, a JVC dude over on the UK AVF has stated that the hardware is different enough that you couldn't just load up the firmware from one to the other. It just wouldn't work.
post #1503 of 2036
Quote:
Originally Posted by AdrianMills View Post

Actually, a JVC dude over on the UK AVF has stated that the hardware is different enough that you couldn't just load up the firmware from one to the other. It just wouldn't work.

That's prob due to components added for color management. Outside of that, they are the same unit.
post #1504 of 2036
Quote:
Originally Posted by adidino View Post

Yes, they are physically identical.

No they're not. The RS20 has a D-Sub PC input.
post #1505 of 2036
Quote:
Originally Posted by GaryB_UK View Post

No they're not. The RS20 has a D-Sub PC input.

Canary_Jules - The RS20 has a D-Sub PC Input... not sure if that matters to you..
post #1506 of 2036
I hope someone has some advice for this situation. I very recently purchased one of jason's RS10s to replace our AE900. Everything was humming along fine for the first 50 hours and then this afternoon we all gathered to watch a movie with the kids (Old Dogs) and the image froze on the disney castle. I assumed that the HDDVD player had hiccuped on the redbox disk as has happened in the past. The audio continued but the image remained frozen. Still thinking it with the HDDVD player, I powered it down. No change on the screen. We were still looking at the magic castle with no image being sent to the projector. The projector would not respond to remote control or direct commands. It stayed stubbornly frozen. Turning the HDDVD player back on and even switching to the bluray player had no effect on the projector. Does anyone have any ideas? Thanks in advance - Dave
post #1507 of 2036
Quote:
Originally Posted by adidino View Post

Canary_Jules - The RS20 has a D-Sub PC Input... not sure if that matters to you..

Nope. Any way my interest was purely academic.
post #1508 of 2036
I presume you had to turn off the RS10 at the mains if it wouldn't respond to the remote? If so did it work again once you'd turned it back on (might be better to wait 30 minutes before powering it back on to left the lamp cool fully)?

Re the HD350 verses the HD750 debate I understood there was a difference in terms of hardware (makes sense as the CMS requires some processing and therefore a chip or two to do this). Some manufacturers will use the same PCB for different models, but only put the components in for the appropriate model (I've seen PCBs with 'missing' components before when I've taken the case off other equipment). I've never opened my HD350 so I don't know if this is the case here though. At the least there is the better (selected?) panels/improved light engine in the HD750 as the CR was claimed to be 20,000:1 higher, some would pay the extra just for that difference (not unlike RS35 owners do these days).

FWIW I went with the HD350 as a home demo at the time showed my room was more of a limit and I couldn't see the value in the dearer option. Nowadays I've improved my room and also bought a (beta) VideoEQ Pro so I may have been better getting that HD750 from the start, though it still would have cost me more in the UK to do this, but I would have had better CR also.
post #1509 of 2036
Yes, I eventually had to do a hard power down and no, it does not power on correctly.
post #1510 of 2036
Quote:
Originally Posted by davidcrowe View Post

Yes, I eventually had to do a hard power down and no, it does not power on correctly.

Oh dear, that sounds terminal then I guess.
post #1511 of 2036
I just placed an order for the RS10 with Jason here at AVS. Can't wait.
post #1512 of 2036
Quote:
Originally Posted by Kelvin1965S View Post

Oh dear, that sounds terminal then I guess.

Yes, the RS10 seems to be dead and I am looking for a reasonable solution.
post #1513 of 2036
Quote:
Originally Posted by davidcrowe View Post

Yes, the RS10 seems to be dead and I am looking for a reasonable solution.

Warranty? Very few JVC pj's have ever needed warranty work that I've heard of. But it's a 2 year warranty.
post #1514 of 2036
Quote:
Originally Posted by davidcrowe View Post

Yes, the RS10 seems to be dead and I am looking for a reasonable solution.

Call 1st thing in the morning and get that thing in A.S.A.P. Sorry to hear that
post #1515 of 2036
Quote:
Originally Posted by davidcrowe View Post

Yes, I eventually had to do a hard power down and no, it does not power on correctly.

As in, pull the AC plug?

If you haven't already, you should pull the AC plug (with PJ off of course), for at least 5 mins (I sometimes do it for 30 mins to be safe). Then plug back in and try again.

This sometimes works on frozen PJ's.
post #1516 of 2036
Quote:
Originally Posted by fleaman View Post

As in, pull the AC plug?

If you haven't already, you should pull the AC plug (with PJ off of course), for at least 5 mins (I sometimes do it for 30 mins to be safe). Then plug back in and try again.

This sometimes works on frozen PJ's.

I the odd hope that sitting unplugged since sunday might help, I plugged it back in. It wakes up with the remote but still goes into standby after ~90 seconds and then shuts down. I don't want to send a unit in for repair while I'm still looking at next months AMEX which has the new pj on it. Doesn't seem right to me.
post #1517 of 2036
Quote:
Originally Posted by davidcrowe View Post

I the odd hope that sitting unplugged since sunday might help, I plugged it back in. It wakes up with the remote but still goes into standby after ~90 seconds and then shuts down. I don't want to send a unit in for repair while I'm still looking at next months AMEX which has the new pj on it. Doesn't seem right to me.

Unless you had an exchange agreement with your re-seller or you can talk them into an exchange, isn't that how warranties work? Bummer I know. Epson's policy is much better, but some new 8500 users are on their 6th projector and a lot are on their 4th! So... pick your poison I guess.
post #1518 of 2036
Quote:
Originally Posted by davidcrowe View Post

I don't want to send a unit in for repair while I'm still looking at next months AMEX which has the new pj on it. Doesn't seem right to me.

While I sympathise with it 'not seeming right' you've tried turning it off and on again (in true IT support style ) and even left it for a few days, but it seems that it needs a repair visit to cure it. I'd get it back sooner rather than later if it were me. The only other thing you could try is removing and reseating the lamp, though I don't see what this could have to do with the original issue it's worth a shot I suppose, before you box it up.
post #1519 of 2036
Has anyone experienced a sudden power shut down while in use with the HD350? While playing Xbox today my unit powered down by itself and the lens closed. I was able to power it back on but it was like the thing was turned off by a ghost. Any thoughts?

-Alan
post #1520 of 2036
Quote:
Originally Posted by ox1216 View Post

Has anyone experienced a sudden power shut down while in use with the HD350? While playing Xbox today my unit powered down by itself and the lens closed. I was able to power it back on but it was like the thing was turned off by a ghost. Any thoughts?

-Alan

Any chance it was the shut off timer that kicked in?
____
Axel
post #1521 of 2036
Quote:
Originally Posted by Axel View Post

Any chance it was the shut off timer that kicked in?
____
Axel



Axel. . . . . I have to be the biggest GOOFBALL this side of the Mississippi. I had the timer set to 2 hours Thanks ... I feel stupid but not paniced.

-Alan
post #1522 of 2036
Quote:
Originally Posted by ox1216 View Post

Axel. . . . . I have to be the biggest GOOFBALL this side of the Mississippi. I had the timer set to 2 hours Thanks ... I feel stupid but not paniced.

-Alan

No worries, Alan - been there done that

This timer is actually my biggest pet peeve with this projector. I simply do not understand why JVC had to implement a timer with absolute durations, rather than having the unit turn off after xx time (user selectable) after it no longer receives a video signal.
I have been hoping JVC would fix it with a simple f/w update....

I have set mine to 4 hrs just to have a stop gap in case I forget to turn it off. I am a bit neurotic it would stay on for several days with nobody using it but still burning up lamp hours.
____
Axel
post #1523 of 2036
Quote:
Originally Posted by Axel View Post

No worries, Alan - been there done that

This timer is actually my biggest pet peeve with this projector. I simply do not understand why JVC had to implement a timer with absolute durations, rather than having the unit turn off after xx time (user selectable) after it no longer receives a video signal.
I have been hoping JVC would fix it with a simple f/w update....

I have set mine to 4 hrs just to have a stop gap in case I forget to turn it off. I am a bit neurotic it would stay on for several days with nobody using it but still burning up lamp hours.
____
Axel

I put mine to 4 hours as well & for the same reasons. You're not alone.
post #1524 of 2036
Quote:
Originally Posted by Goosey View Post

I just placed an order for the RS10 with Jason here at AVS. Can't wait.

I did the same. Just an amazing deal!!

What a joy not having to mull over all the choices from the $1200-$2200 range like I've been doing for weeks.... and just being able to order the clear cut best projector compared to all the alternative models...

Hello owners! I plan on reading through this entire thread before I get the RS10 sometime next week.... any quick newbie advice other than turn on and drop jaw =)=) ??
post #1525 of 2036
Quote:
Originally Posted by ohcello View Post

I did the same. Just an amazing deal!!

What a joy not having to mull over all the choices from the $1200-$2200 range like I've been doing for weeks.... and just being able to order the clear cut best projector compared to all the alternative models...

Hello owners! I plan on reading through this entire thread before I get the RS10 sometime next week.... any quick newbie advice other than turn on and drop jaw =)=) ??

I totally know what you mean. I've been reading those different owner threads for months and the projectors are either priced too high for its performance level, don't work well in my room (no lens shift), or they have problems/issues. To get a projector that just works it seems you have to pay more for the HW15, and the JVCs are just better.

I wonder when the RS10 will arrive. Can't wait.
post #1526 of 2036
Quote:
Originally Posted by Goosey View Post

I totally know what you mean. I've been reading those different owner threads for months and the projectors are either priced too high for its performance level, don't work well in my room (no lens shift), or they have problems/issues. To get a projector that just works it seems you have to pay more for the HW15, and the JVCs are just better.

I wonder when the RS10 will arrive. Can't wait.

I was told mine would ship out next week sometime...
post #1527 of 2036
Quote:
Originally Posted by adidino View Post

Yes, they are physically identical.

They have many parts which are the same, but there are definitely differences.

It has been reported that the RS20 uses the DILA panels from the RS2 and the RS10 uses the RS1's panels. Other than the panel differences and the CMS I think they are identical.
post #1528 of 2036
Hey guys, I have a quick question about the RS10 before I take the plunge. I have searched but can't find the answer.

I know the RS10 supports the vertical stretch needed for anamorphic lens support. In my case I have a fixed UH380, so I also need a 4:3 mode to watch native 16:9 content. Does the RS10 have a 4:3 mode?

Also, I know the RS1/RS2 models had 'ghosting' issues with the UH380 lens. Does the RS10 have similar issues?

Thanks
post #1529 of 2036
looking at the RS10 ... I have a Optoma HD20 .. will I notice a huge difference
in picture quality, contrast , and Sharpness?

Thanks
post #1530 of 2036
Quote:
Originally Posted by Goingpoor View Post

looking at the RS10 ... I have a Optoma HD20 .. will I notice a huge difference
in picture quality, contrast , and Sharpness?

Thanks

Yes. It's in a different league. The colors may be a bit truer on the HD20 and the brightness is competitive, but everything else is light years behind the RS10. The contrast/black levels will probably be the most noticeable; the difference is major.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Display Devices › Digital Hi-End Projectors - $3,000+ USD MSRP › Official JVC RS10/HD350 Owners Thread!