or Connect
AVS › AVS Forum › Audio › Speakers › **Official EMP Owner's Thread**
New Posts  All Forums:Forum Nav:

**Official EMP Owner's Thread** - Page 61

post #1801 of 3147
Well....take back everything I said about the rw-12d's. Noticed a very high pitched whine that was EASILY audible from a few feet away from the sub and audible if you listened for it in a quiet room, but that's besides the point. The amp is obviously bad. Upon turning the sub on and off, it makes horrible popping/crackling/screeching sounds. The other one I have is silent. I remember it working, but maybe it wasn't working to the levels it should have been. The single rw-12d sounds louder and packs more punch in the lower frequencies, so either I'm getting cancellations (likely, but hopefully not to that extent) or the amp was bad the entire time and I wasn't getting what I thought I was getting with duals. Again, I remember both working, but the bad one now BARELY plays anything. It's "on" if you touch the cone, but being able to barely feel it move is about the loudest it'll go now. So back it goes. Still deciding if both should go back or not. frown.gif

With one it didn't sound all that bad. Honestly, with 2 it was very smooth and never drew attention to themselves. They sounded a little resonant/bad in the upper bass (70+), but again I won't make much of a judgement call until I know both are working like they should. Under 40hz sounds about the same as it did with 2. So either I'm getting cancellations OR that one was always bad.

My luck.
post #1802 of 3147
Wow, your not making me feel too confident about my recent rw-12 purchase! I am beginning to believe that klipsch lower end stuff is crap!
post #1803 of 3147
Quote:
Originally Posted by Elihawk View Post

Wow, your not making me feel too confident about my recent rw-12 purchase! I am beginning to believe that klipsch lower end stuff is crap!

Technically the RW12 was a part of their high end like 4 years or so ago
post #1804 of 3147
4th of july is coming. is there a chance for emp tek to have a sale?
post #1805 of 3147
Quote:
Originally Posted by jaygax View Post

4th of july is coming. is there a chance for emp tek to have a sale?

I sure hope so biggrin.gif I spoke with Brian from EMP a few weeks ago, but he was unable to give me much information about a possible sale.
post #1806 of 3147
Aren't they having a sale right now?
post #1807 of 3147
Quote:
Originally Posted by Elihawk View Post

Aren't they having a sale right now?

I think its a permanent price reduction. They adjusted their audition policy to not include return shipping, so the lower prices reflect that. Also in the newsletter, it said "new everyday prices". Given that they just lowered prices, it would probably be more likely to see a Black Friday sale again.
post #1808 of 3147
$347/ea is still VERY low for a speaker that's gorgeous and measures +/- 2db
post #1809 of 3147
Quote:
Originally Posted by ousooner2 View Post

$347/ea is still VERY low for a speaker that's gorgeous and measures +/- 2db

Very true! I have been enjoying mine greatly since last October and am very pleased with my purchase. Also getting them for $477/pair made my decision a little easier wink.gif
post #1810 of 3147
ive been having some problems uploading my HT pictures here. the window just closed right after I hit submit. I already reduced my file to 1200x700 pixels.
post #1811 of 3147
Are you using the little picture upload icon? You can pick a size and it will scale them for the forum automatically.
post #1812 of 3147








used google chrome to upload. got some problems with internet explorer browser i guess. but here it is. my HT room. dimensions are 15'w x 25'l x 8'h. open space on the right side connected to the kitchen. back wall is all glass window. hoping all of these speakers will be replaced this year. and an emotiva XPR5 amp too. xbox should go too. ill get PS4 by november.
post #1813 of 3147
Quote:
Originally Posted by Transmaniacon View Post

Very true! I have been enjoying mine greatly since last October and am very pleased with my purchase. Also getting them for $477/pair made my decision a little easier wink.gif

Ah..w.ell now everyone knows our secret why we like them so much! biggrin.gif

Quote:
Originally Posted by jaygax View Post

ive been having some problems uploading my HT pictures here. the window just closed right after I hit submit. I already reduced my file to 1200x700 pixels.

Use something like tinypic.com

Upload it as a "message board" size and copy the 2nd link it gives you straight into the reply area and post it. Could just be an issue with the encoding on the websites end
post #1814 of 3147
as you can see, all my speakers are mixed. so timber matching is zero. when i built this, i don't have any idea about timber matching at all. the rack is a DIY project. took me a whole week to finish it. sanding is a pain in the butt.

i just recently purchased an audio technica atlp60 turntable because of those vinyl records i've got from an estate sale.

my speakers : fronts : polk SDA 2a
center: klipsch (i already forgot what series that is)
front presence and rear surrounds: klipsch quintets
side surrounds: polk rti bookshelf
sub: bic acoustech PL200. (loving this sub so far) wishing for a cylindrical SVS.
post #1815 of 3147
We are seriously considering a set of EMP speakers to go with a Yamaha A820 and a pair of Klipsch RW12D subs.

Is there anyone in the Atlanta/Alpharetta area that would be willing to let us listen to their set?

Thanks in advance.

Paul
post #1816 of 3147
So, the amplifier on one of my ES1010i subwoofers is suddenly blowing fuses, left and right on the power supply. I don't know what the hell the deal is. The other sub is working great and I love them. I've already been in contact with EMP Tek and I'll likely be troubleshooting with them tomorrow (Mon) and getting it resolved or having a replacement sent out. This is most disappointing, because these are very decent subs. Also, my one year warranty on the amp runs out in about a week and a half. Talk about cutting it close. LOL!
post #1817 of 3147
Have you been pushing them harder than normal? You might need something more powerful biggrin.gif
post #1818 of 3147
Quote:
Originally Posted by ousooner2 View Post

Have you been pushing them harder than normal? You might need something more powerful biggrin.gif

While the temptation to upgrade is always great, I just don't need anything bigger or better. The fuses end up blowing within a minute of replacing them, when I don't even have anything playing, so this is a real noodle scratcher.
post #1819 of 3147
Definitely a short on the board in the amp. Are they sending you an amp or the entire sub? I would worry about it. They have great customer service and that could happen to anything electronic.
post #1820 of 3147
After talking with Brian and doing some troubleshooting over the phone with John, we concluded that it was the amp. They just wanted to make sure something inside one of the subs wasn't causing the fuse to pop. So they'll be shipping me a new amp. What a great company and terrific customer service.
post #1821 of 3147
No one in the Atlanta/Alpharetta area that wants to show off the eMP Tek system?

Paul
post #1822 of 3147
well, they didn't have an independence day sale. so, i'll just save up for black Friday then. if they'll have a sale by then, I swear i'll get two pairs of e55ti tower's.
post #1823 of 3147
Ousooner2, did you get your RW-12D replaced? Hopefully things will improve for you.

Also just wanted to mention I am thoroughly enjoying the benefits of Audyssey MultEQ XT. All my blu-rays sound so much better, the imaging has improved so much and the experience is much more immersive. I plan on getting the E56Ci soon, and then I am sure the upgrade bug will have me shopping for a new sub rolleyes.gif
post #1824 of 3147
Speaking of, I"m in the process of reading this guide. Pretty cool read for us Audyssey owners. Makes me feel better about the way I approach my setup.
http://www.hometheatershack.com/forums/audio-processing/68407-audyssey-multeq-faq-setup-guide.html
post #1825 of 3147
Quote:
Originally Posted by Transmaniacon View Post

Ousooner2, did you get your RW-12D replaced? Hopefully things will improve for you.

Also just wanted to mention I am thoroughly enjoying the benefits of Audyssey MultEQ XT. All my blu-rays sound so much better, the imaging has improved so much and the experience is much more immersive. I plan on getting the E56Ci soon, and then I am sure the upgrade bug will have me shopping for a new sub rolleyes.gif

Nope. Still waiting. They received it on July 2nd at like 4am, but they STILL haven't processed it. I understand they were off on the 4th (Thursday), but dang. We're going on 5 days now and the lady said it was still being "processed". I'm not sure how much processing needs to be done lol....plug it in to test it and you'll see the amp is completely messed up. Send replacement. frown.gif

I will say that the rw-12d is sounding better. I can see a few shortcomings of it at certain peaky frequencies, but hopefully when I get them both set up and can use the SPL meter I can figure out where my problem area's are and find a way to fix them. I'd like to play with the x-over and hopefully be able to setting on 60hz. Not as easy to locate and not so close to the 110hz crossover of the mains 6.5's

I tell ya what though...for under $1,500, this is one helluva setup. biggrin.gif
post #1826 of 3147
I just replaced my faulty ES1010 amp with the new one. Everything is slammin' again. Kudos to EMP Tek for the amazing support. Now, I just hope I'm done having issues.
post #1827 of 3147
So a couple of things.

1. I'm having a bit of a heart attack since yesterday bercause im hearing some distortion in peoples voice, not quite sure whats going on. I don't think its the speakers, but oddly im hearing what I think is some distortion in peoples voice at certain times.

I watched Brave for the first time last night with the Wife and kid (probably one of my favorite animated movies, it was fun to watch and the sound/visuals were amazing, think it might be my all around reference movie next to the dark knight and the dark knight rises) and at the start of the movie when the mother/daugter are talking I thought I heard a bit of distortion at the top end of their voice, I got up next to my speakers and listened closely but never really heard it. Sat back down and nearly **** myself because I thought I began to hear it again.. I'll be honest i feel like it goes away every time I get near it.

Never had this issue before, watched a little "live free or die hard" and I swear I heard a bit again.

Maybe its in my head, I don't know but I swear I hear it and its driving me nuts.

2. I decided in light of this to play around with Audyssey a bit again after ousooners post. I set my Mic points all around my love seat, generally i set in the same spot on the left side all the time so I decided to run a tight grouped set of readings with the MultiEQ. In doing so I completed negated the EQ on my sub. I had previouslly run audyssey and then used the DSP on my iNuke to fix the issues that presented (dips and spikes in certani frequencies)

So, all pissed off knowing I now have to spend a good hour or two re-eqing my sub myself I took my readings, (which were now completely off, even after running audyssey with the EQ on the iNuke off, then trying to apply the settings afterwards.. It was close but still off quite a bit)

So I took my readings and began to edjust.. then I for the first time clicked the EQ button in rew, and **** me wouldent you know that you can use that nifty little EQ button in rew to give yhou the adjustments you need to make on the iNuke.

It's meant to directly connect with an amps EQ and apply manually but you can get it to give you the corrections that I can just put in by hand, and wouldent you know it.. I now have a nearly flat responce. It's about as good as its going to get for a living room with no treatment, but compared to my old graph it looks fan****ingtastic.


PLEASE NOTE THESE HAVE NO SMOOTHING (I know some people who post sub graphcs opt for the 1/6th or 1/3rd smoothing)

Also please note that the DB targets (95 in the old one, 80 in the new one) are just how things were when I was taking measurements.

Before, doing adjustments by hand.



After, using the EQ suggested adjustments in REW

post #1828 of 3147
You did right by posting your low end with no smoothing. Your dealing with a tight range, so no smoothing is needed. +\- 3 looks good bro.
post #1829 of 3147
Does your wife notice the distortion?
post #1830 of 3147
Quote:
Originally Posted by Shady195 View Post

1. I'm having a bit of a heart attack since yesterday bercause im hearing some distortion in peoples voice, not quite sure whats going on. I don't think its the speakers, but oddly im hearing what I think is some distortion in peoples voice at certain times.

I watched Brave for the first time last night with the Wife and kid (probably one of my favorite animated movies, it was fun to watch and the sound/visuals were amazing, think it might be my all around reference movie next to the dark knight and the dark knight rises) and at the start of the movie when the mother/daugter are talking I thought I heard a bit of distortion at the top end of their voice, I got up next to my speakers and listened closely but never really heard it. Sat back down and nearly **** myself because I thought I began to hear it again.. I'll be honest i feel like it goes away every time I get near it.

I've heard sibilance from the EMPs before too, though not lately (I don't get much time to listen to them and they're in a different room now). It's not present in the frequency response so you'd really have to dig deeper to find the problem.

Potential culprits I narrowed it to but didn't really examine that carefully:

1) The Amp i was using - this is a long shot but sometimes phase shifts in electronics can cascade and be offensive right in the sibilance region. Still, I doubt it was this because I think I heard it on different electronics.

2) The room is too reflective. With the flush dome tweeter, you've got a lot of >4-6khz content being sprayed around the room compared to, say, 2khz. That energy could be the problem. Experiment judiciously with room treatment, starting with possible ceiling and floor reflection points. You wouldn't hear these things close to the speaker, because it's being amplified by the room acoustics.

3) Baffle diffraction rearing its ugly head. If you've got the speakers toed in, toe them straight forward instead, and vice versa to test. Does that change anything? Do you have any coffee tables etc near-or-in-the-way of the speakers?

4) One tweeter is damaged and can't handle long excursions. It's a possibility... hopefully not the case though!

5) It's just the nature of the speaker design. Too much content bleeding into the tweeter's bottom range. That or the mylar dome tweeter is just not pistonic in that frequency range. Or Midrange driver breakup bleeding through. The speakers do use 5" metal mids with 2nd order crossovers, which might be breaking up right in the sibilance range. You can test by putting your ear on the MIDs rather than the tweeter and listening. But All-in-all I would give RBH credit as they must have spent time voicing these speakers,

6) It's not the speakers, it's the original recording. This is the real wrench in things, because you could spend hours chasing after a problem that isn't really in your room. I never heard sibilance on music content, rather on close-miked sports commentating.
Edited by Eternal Velocity - 7/9/13 at 9:39pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Speakers
AVS › AVS Forum › Audio › Speakers › **Official EMP Owner's Thread**