or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › Samsung DLP HL-R5067 Dark Screen
New Posts  All Forums:Forum Nav:

Samsung DLP HL-R5067 Dark Screen

post #1 of 5
Thread Starter 
Good afternoon. I am a service member stationed in Spain and am unable to simply send out my DLP TV for repair.

My Samsung DLP HL-R5067 stopped working one day while watching it, the screen simply quit and the "Temp, Lamp, and Timer" lights starting flashing. According to the manual that means replace the bulb and since its 4 years old that made sense. So i ordered a new bulb from Samsung Parts and it didn't work. They sent me another and still no luck, both gave me the same indication.

I taped down (and up) the switch in the back with all 3 bulbs, still no luck.

All 3 lamps light-up for about 5 seconds but then extingush, set makes a beep, and then all lights flash.

Any ideas???

I was an electrician about 6 years ago (for 2 years) and know my way around a multimeter, but am a bit rusty.
post #2 of 5
The only thing I can think of might be that the ballast needs to be replaced. But that is just a guess as sometimes both the lamp and ballast go out at the same time.
post #3 of 5
Thread Starter 
I'll try that next, thanks.
post #4 of 5
Plug in and turn on. You should hear the colorwheel spin up (high-pitch whur), if you don't then the ballast will never fire and it could be colorwheel or DMD board. After the colorwheel starts up the ballast should fire (ticking sound), if you don't hear the ballast firing then could be ballst or powersupply need to check voltages.
post #5 of 5
Thread Starter 
I hear the whir, and the lamp lights for a few seconds. If the ballast was bad would the lamp light?

Where do i put the leads to check voltage
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › Samsung DLP HL-R5067 Dark Screen