or Connect
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › HD-XA1 Will Not Eject
New Posts  All Forums:Forum Nav:

HD-XA1 Will Not Eject

post #1 of 3
Thread Starter 
Inserted a DVD and it's stuck in "LOADING, LOADING, LOADING......"
Buttons will not respond except for the player's on/off button. There is no pin size hole in front of the tray. Is there any way I can get the disk to eject besides openning it up? If I have to open it up how do I do that? Any help will be appreciated. Thanx.

Make that an HD-XA2

cheezz
post #2 of 3
Quote:
Originally Posted by cheezz View Post

Inserted a DVD and it's stuck in "LOADING, LOADING, LOADING......"
Buttons will not respond except for the player's on/off button. There is no pin size hole in front of the tray. Is there any way I can get the disk to eject besides openning it up? If I have to open it up how do I do that? Any help will be appreciated. Thanx.

Make that an HD-XA2

cheezz

on my XA1 there is small button under the drive bay (inside the door) . use a pencil to push the button - it's just inside a small hole. at times I've also needed to shut it off, restart and then push the button. I think I need to re-update the firmware
post #3 of 3
Thread Starter 
Thanx Randomcreek. There is no button under the drive bay, however, there's a gearlike wheel. I think it's the mechanism to open the tray. Pushed it to the side (as if turning it) several times and it nudge the tray to open a bit. Then I pressed the eject button on the remote and out it came. Thanx for the idea, my friend. Cheers!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HD DVD Players
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › HD-XA1 Will Not Eject