or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › Replaced ty-la1000 bulb, now smell plastic burning
New Posts  All Forums:Forum Nav:

Replaced ty-la1000 bulb, now smell plastic burning

post #1 of 6
Thread Starter 
I replaced my Panasonic rear projection tv bulb a few days ago and ever since, when I turn the tv on, a few minutes later I smell plastic burning. I thought maybe there was a protective film on the bulb assembly or maybe it was a break in thing but that's not it. Any thoughts or advice? The bulb works perfect by the way, I just cant deal with the smell or thought I am ruining the tv.
Thanks
Steven
post #2 of 6
It does not appear normal.

I would pull out the lamp assembly and carefully look both on the lamp cage and inside the TV with a light and see if there is any evidence of melting.

Maybe there is a coating on the lamp assembly that might be giving the smell, or the lamp maybe is drawing too much current and is overheating some electronic component. The lamp does get very hot!

Either way, it would be best to try to determine the cause before the chance of fire.
post #3 of 6
Thread Starter 
I googled the problem and the only thing I found was a place selling filter cleaning said it could be the dust filter causing an optical engine melt down.
I have taken it apart and looked, no signs of burning or melting plastic that I can see.

I haven't run the tv much yet because I am trying to fix this first, any more tips?
post #4 of 6
Is it the exact bulb you had before or a compatible one. Does it have the same wattage as the one you took out. Some people have had problems with bulbs made by different manufacturers than the originals.
post #5 of 6
Thread Starter 
It's a ty-la 1000 but I got it from ebay. I checked around and found that there are a bunch of different brands.

Is there a way for me to check to see if the smell is coming from the bulb or if something else went out? The tv wont turn on without the bulb being installed so I don't know how I'd do that.
thanks in advance
post #6 of 6
Thread Starter 
Any ideas?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › Replaced ty-la1000 bulb, now smell plastic burning