or Connect
AVS › AVS Forum › Display Devices › Digital Projectors - Under $3,000 USD MSRP › HC1500 - Won't power on. Stay's solid red.
New Posts  All Forums:Forum Nav:

HC1500 - Won't power on. Stay's solid red.

post #1 of 9
Thread Starter 
Just bought this project 37 days ago.

When I try to power it on, it does nothing. Just stays solid red. I have tried to press power directly on project and via remote. I have also tried unplugging for several minutes before plugging back in and trying again.

I will be dealing with Mits. tech support tonight when I get home, but just seeing if anyone else has dealt with something like this before and what they had to do to resolve.

Thanks in advance... (BTW.. This of course happens the day I load up on new Blu-ray movies )
post #2 of 9
Condolences. Do you have another power cord that you could try? Maybe temporarily use the one for your PC or monitor...

I just googled "mitsubishi hc1500 troubleshoot power" and saw some other things you could try, but some of the threads point towards a bad bulb, sorry...
post #3 of 9
this happened to me a while ago, had only 100+ hrs on the new pj.

sent to mits, did some phone battling with different people.long story) but i prevailed..

got fixed for free, minus shipping to them.

they said it was bad bulb....did some research and found that i had not given enough time for bulb to cool off between cycles one day (very hot humid day) and it blew...

keep that thing cool, remember heat rises that's my tip of the day...
post #4 of 9
37 days ownership, yes, should still be under warranty. Worse thing will be the down time with a smaller TV, unless you have a backup pj...
post #5 of 9
Thread Starter 
ARRGH... Projector that I sent in for repair is doing the same thing again. They did admit they were not able to recreate the problem, that maybe it "knocked back in shape" during shipment (which is a lousy answer).

It worked for about a month when it came back to me. I am going to try the different power cord this time but I doubt that will do anything. I sent them an email and am asking for a replacement. This unit is obviously a lemon if they can't find the problem to resolve. I am out $20 every time I ship this thing, and the week or two while it is gone. What a pain!
post #6 of 9
Is your pj operating in a hot environment? I seem to remember the manual saying something about the upper operating temp being 90 or 95 degrees F...

I make sure I have an air con blowing at my pj when temps are >80 F...
post #7 of 9
exactly what i said, these puppies will outright die if get to hot. or not letting enough time pass on turn off and ons.....
post #8 of 9
Quote:
Originally Posted by ditch-digger View Post

this happened to me a while ago, had only 100+ hrs on the new pj...

100 hrs? Man, you are lucky!

Mine HC-1500 works only few hours (with few hungups and no response from remote or buttons on PJ's control panel), then screen stay green, no picture, and worst, with no possibility of turning it off by remote or power button on PJ!!! After 90 minuts of that behaviour I'm just pull off the power plug!

Next day I send PJ to Mitz service in Poland, where I live, they exchange main board, send me back HC after one week, but PJ need more service calibrations - picture looks near like .jpg in 256 colours, colours gradients sucks, especially in darks...

Than my Mitz go to service in Netherlands, and back to me after three weeks... That was in autumn last year, and as far up today everything is fine.

Of course, shipping costs not bother me, couriers fees pays Mitsubishi service!
post #9 of 9
Thread Starter 
Quote:
Originally Posted by Brown Radagast View Post

Is your pj operating in a hot environment? I seem to remember the manual saying something about the upper operating temp being 90 or 95 degrees F...

I make sure I have an air con blowing at my pj when temps are >80 F...


No. It is in the coolest point of the house in open space (not enclosed). It has been off for over a day and will not power on. Just the steady RED light. Now Mits is not responding to me.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Display Devices › Digital Projectors - Under $3,000 USD MSRP › HC1500 - Won't power on. Stay's solid red.