or Connect
AVS › AVS Forum › Display Devices › Digital Hi-End Projectors - $3,000+ USD MSRP › Video Static with Audio - Projector Issue?
New Posts  All Forums:Forum Nav:

Video Static with Audio - Projector Issue?

post #1 of 5
Thread Starter 
Hi all, need help badly.

My current setup is a PS3 to an Onkyo 605 Receiver using HDMI to a Panny AE3000U projector. As of last week, my image keeps popping on and off. Audio is heard fine but every so often the video turns into static as evidenced by the image attached.

Does anyone know if this is the projectors doing? The reciever? Or the PS3?

HELP!
LL
post #2 of 5
Likely an HDMI problem. How long is your HDMI cable to the projector? Did everything work fine before last week? If so, did you change anything last week? Have you checked your HDMI connectors to make sure they are securely seated?
post #3 of 5
Thread Starter 
Hi there, the only thing I can think of is the cleaning lady came through there last Saturday. I only replaced the cable from the PS3 to the receiver. The connections are secure on all ends.
post #4 of 5
If your cable to the projector is long (>25 feet), you may need an HDMI booster. Just Google hdmi booster. If your setup worked for a long time before last week, it is more likely that one of your HDMI transceivers is failing. You might try a different HDMI input on the receiver, or try taking the receiver out of the path and going direct from PS3 to Panny to see if that clears the problem.
post #5 of 5
Thread Starter 
It's the receiver, great. I had the Onkyo 605. Should I send it in for repair or buy a different unit?
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Display Devices › Digital Hi-End Projectors - $3,000+ USD MSRP › Video Static with Audio - Projector Issue?