or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Westy LVM-37W1 Problem. Need suggestions
New Posts  All Forums:Forum Nav:

Westy LVM-37W1 Problem. Need suggestions

post #1 of 3
Thread Starter 
The TV stopped turning on after only 4 years. Not under warranty anymore.

Researched and found the problem is usually the power supply ($178.00), or it could be the control board. I've also read where some have said its usually just 2 capacitors that go bad (about $1.50/ea.) Problem is, which 2?

I've got the back of the TV off and removed the protective cover to the PS. Only 4 screw and 4 plugs to swap it out....seriously easy.

I'm just worried about spending $180.00 and it doesn't fix it.

Anyone else had this issue? How did you fix it?

I hate to junk a $1200 TV after only 4 years, but dont want to blow my money on unnecessary parts either.

Any guidance?
post #2 of 3
Thread Starter 
Well, I called the guys at Discount-merchant.com, described the problem, and it sounds like it definitely the PS.

I just ordered one and will install it when it get here.

If it corrects the problem, I can do a DIY write up if anyone is interested.
I've seen where others have had the same problem, so maybe I can help other owners out.

Let me know.
post #3 of 3
A note to help someone who still has one of these.

My old LVM-37w1 finally started to power off (no picture) after running for a while and then it just quit with nothing but the orange led one day. The problem with mine was on the power supply. A bad solder joint in the switching power driver section of the board on a capacitor lead.

http://flic.kr/p/cYCEFy
http://flic.kr/p/cYCECN

If you have one sitting in a closet with this problem this might be a easy fix.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Westy LVM-37W1 Problem. Need suggestions