or Connect
AVS › AVS Forum › Audio › Speakers › Cannot get 5.1 Sound from Logitech Z-680 + PS3 + HDTV
New Posts  All Forums:Forum Nav:

Cannot get 5.1 Sound from Logitech Z-680 + PS3 + HDTV

post #1 of 13
Thread Starter 
Hi Friends,

I cannot get 5.1 sound from a logitech Z-680 HTIB when connected to PS3 and my Samsung 650 52 inch TV (touch of red). Have tried PS3 to 680 with optical and tried HDTV to 680 with optical. Logitech told me I could only do it with the PS3 optical to the Z 680. When I do that (with the PS3 set to 5.1 sound via optical) I get muted sound from all front and rear four speakers and no sound from the center channel at all. In fact, I cannot get sound from the center channel no matter what I do! The center channel worked for a while, but stopped, and it is not the speaker itself, nor the speaker wire or optical cable or their connections. Finally the remote stopped working. I fear the cross-over board inside the subwoffer enclosure has gone bad?

Please help me if you have suggestions. I received the Logitech Z-680 as a gift from a friend and it is in new condition right out of the box. I have spend many hours trouble shooting and could use your help.
post #2 of 13
Sounds like you need to put everything back in the box and get an exchange or refund and buy something that works.
post #3 of 13
Thread Starter 
Well, the 2X stereo w/ sub works...
post #4 of 13
What do you have your PS3 audio output setting to? It should be set to Bitstream.
post #5 of 13
Thread Starter 
Thanks for replying! To try this, should I have the optical go directly from the PS3 to the HTIB (or should I have the PS3 go via HDMI to the HDTV and then run the optical cable to the HTIB?)?
post #6 of 13
Run optical cable to the HTIB for audio, and HDMI to the TV for video. Make sure your PS3 is set to bitstream for audio.
Usually if you run optical from a TV to a receiver, the TV only outputs stereo.
post #7 of 13
Thread Starter 
I am trying to follow your lead.
PS3 Video settings were set to "linear PCMI."

have now set to:

PS 3 Video: BD/DVD Audio Output Format (HDMI) - Bitstream
PS 3 Video: BD Audio Output Format (Optical Digital) - Bitstream

PS 3 Audio Output Format: HDMI (manual) ->Dolby Digital 5.1 Channel + Linear PCm 2 Ch (44 Hz) + Linear PCM 2 Ch (48 Hz)

Hook up is currently PS3 -> HDMI -> HDTV -> Optical Audio Out -> Z680 HTIB.

Same result as before, muted sound from surround 4 and no sound from center channel when using HDMI to HDTV and Optical from HDTV to HTIB.
post #8 of 13
Thread Starter 
Sorry I was typing and setting up when you wrote that ...will try as you say..
post #9 of 13
Thread Starter 
I did as you suggested (Run optical cable to the HTIB for audio, and HDMI to the TV for video) and get the same result.

The PS3 video setting is set as I said above:
PS 3 Video: BD/DVD Audio Output Format (HDMI) - Bitstream
PS 3 Video: BD Audio Output Format (Optical Digital) - Bitstream

I am trying with a 5.1 DVD (don't have a Blu-ray disc here).
post #10 of 13
Thread Starter 
Samsung Tech said the same as you" "..if you run optical from a TV to a receiver, the TV only outputs stereo."
post #11 of 13
Thread Starter 
In case I wasn't clear, the PS3 audio out is indeed now set to Optical Digital -> 5.1 Ch. (and + Linear PCm 2 Ch (44 Hz) + Linear PCM 2 Ch (48 Hz), both of which are grayed out by default).

And I still get the muted sound...w/o a middle channel.
post #12 of 13
What are you trying to listen to? Make sure it is a Dolby Digital or DTS 5.1 track.

If it is, are you able to somehow "reset" your Logitech setup? Also, does that setup have an "auto" feature which automatically uses the proper surround sound settings?

Your logitech just may be broken, as well.
post #13 of 13
Thread Starter 
Thanks G. Yeah, it is dolby 5.1 or DTS 5.1 on DVD discs.

I do not know of any "reset" or auto set up feature on the Logitech. There is suppose to be a button on the remote that us used to test speakers, but the remote stopped working too.

You might be right about it being a door stop for a bit garage. What gets me is it was new out of the box (new in that he gave it to me a couple of years ago and I just got around to using it), PLUS I did have a center channel working before I did a simple rewiring to move things around (it is not the wires). Pretty frustrating. I appreciate your help.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Speakers
AVS › AVS Forum › Audio › Speakers › Cannot get 5.1 Sound from Logitech Z-680 + PS3 + HDTV