or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › No 5.1/7.1 channel audio on HDMI - HP S5150 slimline desktop ATI 4350 Video Card
New Posts  All Forums:Forum Nav:

No 5.1/7.1 channel audio on HDMI - HP S5150 slimline desktop ATI 4350 Video Card

post #1 of 6
Thread Starter 
I hope this will be of some help to others.
I recently purchased a HP slimline desktop s5150t with ATI Radeon HD 4350 video card. After I got everything setup, I noticed that I only had 2 channel audio (stereo) on my Receiver connected to the PC using HDMI. I checked the HDMI Audio Device driver and found out that it is an outdated driver from Microsoft. I tried to update it, the system responded saying I have the latest updated driver. I called HP Tech Support, after spending an hour on the phone I was disappointed to come out with nothing. I continued my search on various forums and ended up in the RealTek website. After trying many drivers I found the driver ATI HDMI Audio Device R2.35 2009/10/12 17370k, I installed it and got everything working. That was a big relief Now I get DTS & Dolby sound output through the HDMI cable on my receiver

Once you are on the Realtek home page, Click on Downloads and then choose High Definition Audio Codecs (Software) and Download the driver ATI HDMI Audio Device R2.35 2009/10/12 17370k
post #2 of 6
I saw your thread and was prepared to tell you about the realtek driver, but I see you solved it. Nice work. Good to see someone with a solution rather than just a question.
post #3 of 6
Huh, wonder if this works on ATI's integrated 4200 chip. Can someone try it and provide some feedback, I can't do it on my 785G system do to receiver limitations.
post #4 of 6
I have the same problem only installing ATI HDMI Audio Device doesn't solve anything. I still only have 2 channels through HDMI.
Neither do Catalyst help, or Win7 automatic drivers for that matter. Every driver I have tried have had the exact same result.

Anyone with further ideas? I´m all out now...
post #5 of 6
Quote:
Originally Posted by EnDumEn View Post

I have the same problem only installing ATI HDMI Audio Device doesn't solve anything. I still only have 2 channels through HDMI.
Neither do Catalyst help, or Win7 automatic drivers for that matter. Every driver I have tried have had the exact same result.

Anyone with further ideas? I´m all out now...

What is connected to the HDMI port?
TV? AVR?
post #6 of 6
Quote:
Originally Posted by hirent View Post

What is connected to the HDMI port?
TV? AVR?

Onkyo tx-sr605
Everything works great if I stream to the ps3. So the problem lies in the computer.
I disabled everything except the ATI hdmi connection, and then I could choose 5.1. But the receiver read multichannel on the display only it was stereo that came out. I played Spotify for a couple of minutes and then suddenly Spotify told med the audio driver had stopped working. And after that I can only choose stereo in the settings again.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › No 5.1/7.1 channel audio on HDMI - HP S5150 slimline desktop ATI 4350 Video Card