or Connect
AVS › AVS Forum › Gaming & Content Streaming › Networking, Media Servers & Content Streaming › WDTV Live - Windows7 x32/x64 - How to share your files - Tutorial
New Posts  All Forums:Forum Nav:

WDTV Live - Windows7 x32/x64 - How to share your files - Tutorial

post #1 of 102
Thread Starter 
Hi,

As I know, noone has found solution how to avoid problems with sharing your media files over the network with Windows 7. Even with Media Server or with Network Shares...
Well, I just installed Windows7 x64 - Enterprise and after 2-3 hours of searching for solution over the internet, after trying everything - I couldn't make it work - to watch videos shared with Windows 7.

Then I stop searching and browsing the and I found solution which I would like to share with the rest of the world, to help everyone.
Here is the text version and at the end you can find video tutorials - which aren't in high definition but I hope it will help you:

OS: Windows7 x64 Enterprise edition | Evaluation Edition for IT

Mine settings:
Windows Firewall - OFF
Network: Home Network
Shared Libraries - Nothing, all OFF
Media Steaming - OFF

Advanced Sharing Setting:
Turn on network discovery
Turn on file and printer sharing
Turn on sharing so anyone with network access can read and write... - BUT, I removed (this is just ME) from: My Computer -> Right Click -> Manage -> Shared Folders -> Share: User(s) -> Right Click -> Stop Sharing
- Why I done this? -> Because when I access with WDTV Live to my pc, I do not want to see anything else except files I shared
Use 128 bit encryption
Allow Windows to manage homegroup connection

WDTV Live:
Network Setup: Automatic IP
Clear login info


This is important stuff - How to make share with Windows 7 and WDTV Live:
Part1:
My Computer -> Right Click -> Manage -> Shared folders -> Right Click on Shares -> Click New Share -> Next -> Browse folder with media files -> Next -> Next -> Select Customize Permissions -> Click Custom:
Group or user names:
- Administrators - FullControl, Change, Read - Check
- Everyone - FullControl, Change, Read - Check
(If any of these missing, add them)
Click OK -> Finish -> Finish

Part2:
Go to Computer Managment -> Shared folders -> Shares: Right Click on Share -> Properties -> Security (tab) -> Advanced -> Change Permissions:
Remove/Uncheck - Include inhertable permissions from this object's parent
REMOVE
(Then) Add Administrators - Allow EVERYTHING
(Then) Add Everyone - Allow Reading permissions (I didn't try full permisisons, but it should work) - basically everything with word "read" in it
press OK

Part3:
Go to the "Owner" Tab (in Advanced Security Settings for "Your Shared Folder")
Current owner must be "Administrators", if it's not then:
Press: EDIT, Select Administrators, check "Replace owner on subcontainers and objects" -> OK -> OK -> OK -> OK -> Exit Computer Managment


Extra notes:
You don't need to create extra user for WDTV (like some people suggested - this suggestion works great with WinXP, but it's not needed for Win7)
I tested this also with sharing whole drive -> also work without any problems.


Play your media files:
With WDTV Live go to videos menu -> Network Shares -> YourPC: and your folder should appear now in WDTV without any errors!

Hope this will help to you, please leave feedback at least to know if I helped you!?
Thank you


Video Tutorials:
How to setup sharing with Windows 7 and make it work for WDTV Live (Foder with movies example):
Download : http://www.2shared.com/file/8980507/..._-_Folder.html
Youtube: http://www.youtube.com/watch?v=zF0v7HGGw2Q

How to setup sharing with Windows 7 and make it work for WDTV Live (Foder with subfolders example):
Download: http://www.2shared.com/file/8980530/...ubfolders.html
Youtube: http://www.youtube.com/watch?v=xVZ5Um8s8jo

- I can't remember which codec you will need to watch videos, don't kill me, find out it by yourself

At the end: Sorry for my english
post #2 of 102
Thread Starter 
Update:

I got info that some of you still can't access to your media files over your WDTV Live even you followed all my steps from above...

To be honest, before I make it work, I've done alot of things and changes in Win7 that I don't even remember and I don't even know for sure what really make it work.

So I suggest you also to try this:
Control Panel -> System and Security -> Windows Firewall -> Advance Settings -> Inbound Rules:
File and Printer Sharing *** - ALL ENABLE
Network Discovery *** - ALL ENABLE

Also you can try the same with Outbound Rules.

To save your time I exported my policies, so here is the link:
http://www.2shared.com/file/8980378/.../policies.html



Please, give me your feedback, thank you
post #3 of 102
Very very Thank You! It's working this solution (Windows 7 x64)! I am Happy.
post #4 of 102
Your guide doesn't help me (on Win XP Pro), but thank you for taking the time to write a clearly worded tutorial that will help others.
Well done!
post #5 of 102
Thread Starter 
Update:

Complete steps for Win7, HD Youtube Tutorial: http://www.youtube.com/watch?v=r8o7WJ3S6po

Question for all of your who has WinXp and can't make sharing work:
Did you ever ever ever installed Win7 on your machine?
post #6 of 102
people that are having issues, check your event log for errors about "browser service"
post #7 of 102
Quote:
Originally Posted by With_Style View Post

Update:

Complete steps for Win7, HD Youtube Tutorial: http://www.youtube.com/watch?v=r8o7WJ3S6po

Question for all of your who has WinXp and can't make sharing work:
Did you ever ever ever installed Win7 on your machine?

Negative, has always been just XP Pro on this box. I just went thu Microsofts Help Topic on Troubleshoting XP Networks. Seems aall my setting are correct, I can ping the WD TVLive from here, see the attached drive on the WDTV & access it, but trying to share a folder on this PC w/ WDTVLive has proven "elusive", shall we say.
post #8 of 102
Thread Starter 
Thx for the info. I'm sorry to hear that. I didn't have any problems with WDTV Live and XPpro, It worked from the first second. So I don't know what to advise you.
I can only describe my step in WinXP, but I've checked with other users which done the same - to them this steps didn't help:
1. I created used wd, with password wd - member of administrators
2. I shared whole drive with full permissions to: WD-FULL, Administrators-FULL, Authenticated Users-FULL
3. On WD I put manually IP address:
IP: 192.168.5.99 (PC is 100, 1 is router)
SMask: 255.255.255.0
Gateway: 192.168.5.1
DNS: 192.168.5.1

You can try, also, to install second windows in Virtual Machine and try to access any data from VM. I played that way with Windows Home Server, and it worked also fine.
I was testing WHServer in VM because I'm planning to build NAS for WD

Any positive results from Win7 users here?
post #9 of 102
Thread Starter 
Bump!

Does my tutorial helped to somebody?
post #10 of 102
I have Windows 7 and I used your tutorial. It worked for all the folders/files on the C: drive, but I have an extra internal HD dedicated to media. It's the F: drive. The F: folders/files don't show up on WD TV. Any ideas?
post #11 of 102
I have tried so many tutorials and finally found one that works. Upon restarting the WDTV live, I couldn't connect to network shares anymore, even after turning it on and off 10-15 times. Anybody know what the problem could be?.

Also, I have 4 drives in my computer tower. Two of the drives power down after 10-15 minutes. All drives are connected via SATA in AHCI mode. How do I stop the drives from powering down so the WDTV can access them?
post #12 of 102
I can connect to my network shares in Windows XP with no issue, but I am not sure how secure that is. Use the anonymous with no password and it connects without issue.

I am using the Simple File sharing in XP Pro and click on the folder and allow sharing via properties sharing tab. I do not allow file changes for the folder (read only) and only keep video files in there. And I an using both router firewall and software firewall. But I always log in as Administrator.

So not sure how secure this setup is and was wondering if someone would comment or point to a guide that explains how to so this safely so no hackers can get into my system.
post #13 of 102
Thread Starter 
Quote:
Originally Posted by CadeJ View Post

The F: folders/files don't show up on WD TV. Any ideas?

Please, give me ScreenShot of: Right Click on your F drive - Properties ->
- Security Tab
- Securty Tab: Advance -> Permissions Tab
- Securty Tab: Advance -> Owner

I hope I describe it right - I'm on XP at my work.

Quote:
Originally Posted by shadow_cruiser View Post

How do I stop the drives from powering down so the WDTV can access them?

Control Panel - Power Options - Advance -> and there you turn off auto poweroff option for harddrives.


Quote:
Originally Posted by jfcarbel View Post

So not sure how secure this setup is and was wondering if someone would comment or point to a guide that explains how to so this safely so no hackers can get into my system.

You don't need to worry about security it's all in your private LAN, your IP address is changing every 24h, Router Firewall is pretty enought. You should be more interested in power saving then for security


WDTV Live - New Firmware:

WD released new Firmware for WDTV Live 1.01
It fixes alot of problems, also problems with Win7.

For now I heard from alot of people that this firmware solved all their problems.
http://www.wdc.com/wdproducts/update...y=wdfwdtv_live
post #14 of 102
Thread Starter 
CadeJ

I got your SS by PM. Well, you didn't follow my tutorial.
1. At Permissions Tab you have:
- Authenticated Users
- System
- Users (Cade-PC)

Delete them all and add only:
- Administrators - Full permissions
- Everyone - Read permissions


2. Owner is System atm, it should be:
Administrator

Also notice again, that you do not need to create wd user in Win7. If you have it, delete it.

ps: You didn't gave me SS of Security Tab

If this doesn't help you I suggest you to add me to MSN, then we can arrange Remote Control so that I can help you.

MSN: justskilled@hotmail.moc (moc = com)
post #15 of 102
Quote:
Originally Posted by With_Style View Post

Please, give me ScreenShot of: Right Click on your F drive - Properties ->
- Security Tab
- Securty Tab: Advance -> Permissions Tab
- Securty Tab: Advance -> Owner

I hope I describe it right - I'm on XP at my work.


Control Panel - Power Options - Advance -> and there you turn off auto poweroff option for harddrives.




You don't need to worry about security it's all in your private LAN, your IP address is changing every 24h, Router Firewall is pretty enought. You should be more interested in power saving then for security


WDTV Live - New Firmware:

WD released new Firmware for WDTV Live 1.01
It fixes alot of problems, also problems with Win7.

For now I heard from alot of people that this firmware solved all their problems.
http://www.wdc.com/wdproducts/update...y=wdfwdtv_live

great!
post #16 of 102
You have to create the Home Network Group then it creates a Media server. I had no problems with Windows 7 and WD live. But the WD live has everything all disorganized it seems like. Im just getting used to it though, but the picture quality is amazing while view slideshows. Works great!

Now, if I can just get my NAS to work right for movies....... You would think with WD LIve and WD Nas it would be seamless..........
post #17 of 102
Thread Starter 
Just follow my tutorial and try fw update.
post #18 of 102
Thread Starter 
Update:
OK after testing Windows 7 x64 Enterprise Edition I bought Windows 7 Ultimate x64 and I run on the same issues again. Even I updated WDTV Live I couldn't access my data over WDTV. Anyway, I solved my problem in 10min, so here is the thing:



After doing all steps I made one step more which I didn't tell you before, because I belived it's not important, but it is:

So please, make this registry change to make it work:
1. Navigate to the following location in the registry editor.
MACHINE\\System\\CurrentControlSet\\Control\\Lsa\\
2. On the right side, double-click on 'everyoneincludesanonymous' and change the 'Value data' from '0' to '1'
3. Double-click on 'NoLmHash' and change the 'Value data' from '1' to '0'
4. Navigate to the following location in the registry editor:
MACHINE\\System\\CurrentControlSet\\Services\\LanManServer\\ Parameters
5. Double-click on 'restrictnullsessaccess' and change the 'Value data' from '1' to '0'
6. Close the registry editor

Finally, restart your PC and WDTV Live!

- If you still getting error - something like: "No media in the current folder" - then do not share your DRIVE, share just folder by right click - share with - home group (read).
- ATM I don't have time to figure out how to share whole disk with Win7 ultimate - I didn't have this issues with Enterprise version.

Update:2
I make it work with whole Drive:
Part2:
Go to Computer Managment -> Shared folders -> Shares: Right Click on your Share -> Properties -> Security (tab) -> Edit -> Add:
- Your User (Full)
- HomeUsers (Full)
-> OK

Then, Advance - >
Owner: Administrators (like from tutorial)
Permissions:
Administrator, Your User, Home Users - Full
Everyone - Read & Execute (like from tutorial - 5 checkbox)

Restart WD!
post #19 of 102
Quote:
Originally Posted by shadow_cruiser View Post

I have tried so many tutorials and finally found one that works. Upon restarting the WDTV live, I couldn't connect to network shares anymore, even after turning it on and off 10-15 times. Anybody know what the problem could be?.

SAME HERE even with latest firmware. I'm on w7x64. The login page doesn't even show up.. when i click on Video->Network Shares, nothing happen.
post #20 of 102
Quote:
Originally Posted by vanylapep View Post

SAME HERE even with latest firmware. I'm on w7x64. The login page doesn't even show up.. when i click on Video->Network Shares, nothing happen.


try this
post #21 of 102
Thread Starter 
Quote:
Originally Posted by vanylapep View Post

SAME HERE even with latest firmware. I'm on w7x64. The login page doesn't even show up.. when i click on Video->Network Shares, nothing happen.

What is your problem at the end? which version of windows?
post #22 of 102
Quote:
Originally Posted by With_Style View Post

What is your problem at the end? which version of windows?

I have Windows 7 64 bit.

Sometimes, from the WDTVLive, i go to Video and click on Network Shares and nothing happens.... it just stay there..

once in a while, it shows the login screen and i can log in, but then, i log in and don't see all my shared folders.. just the user folder.
post #23 of 102
Thread Starter 
Quote:
Originally Posted by vanylapep View Post

I have Windows 7 64 bit.

Sometimes, from the WDTVLive, i go to Video and click on Network Shares and nothing happens.... it just stay there..

once in a while, it shows the login screen and i can log in, but then, i log in and don't see all my shared folders.. just the user folder.

If you see only user folder then you didn't setup permissions correct.
Compare your User Folder permissions with Shared folder, and put to the shared drive/folder the same permissions like you have them for User folder.
post #24 of 102
DO NOT EDIT THE REGISTRY

Follow these instructions to share on Windows7

(1) Run Local Security Policy applet under Administrative Tools. If you don't see administrative tools, enable it under the properties of the Start menu

(2) Under local policies -> User Rights Assignment

When you see Deny access to the computer from the network, REMOVE user guest.

(3) Under Local Policies -> User Rights Assignment, find Access this computer from the network -> add EVERYONE' and ANONYMOUS LOGON'

(4) Under local policies -> Security Options -> find Accounts: Limit local account use of blank passwords. Change the setting to disabled.

(5) Under local policies -> Security Options -> Network Access: Shares that can be accessed anonymously -> type in the name of your shares

(6) Enable the guest account; set the guest password to blank

(7) Check the share permissions on your share and make sure it has EVERYONE read

(8) Check the file permissions on the files in your share and make sure it has EVERYONE read

Enjoy.
post #25 of 102
Thread Starter 
Where did you found this? This can help to someone, but I don't think this is global solution!?

btw, why are you so against registry changes?
Basically, everything in windows is written in the registry, so it's the same if you navigate some one to change something in administrative tools or if he/she changes value in registry.

It's the same

As administrator, sometime is easiest to send to customer regkey which makes all changes you want, then to navigate it through windows.

ps: People shouldn't be scared of registry. More they get fimiliar with it they will better understand OS.
post #26 of 102
Quote:
Originally Posted by With_Style View Post

CadeJ

I got your SS by PM. Well, you didn't follow my tutorial.
1. At Permissions Tab you have:
- Authenticated Users
- System
- Users (Cade-PC)

Delete them all and add only:
- Administrators - Full permissions
- Everyone - Read permissions


2. Owner is System atm, it should be:
Administrator

Also notice again, that you do not need to create wd user in Win7. If you have it, delete it.

ps: You didn't gave me SS of Security Tab

If this doesn't help you I suggest you to add me to MSN, then we can arrange Remote Control so that I can help you.

MSN: justskilled@hotmail.moc (moc = com)

I tried this and still couldn't access the second HD. I haven't tried the tutorial updates you posted a few days ago, I'll do that later this afternoon. I did notice something, though ... if I send a file (an mp3 since video doesn't seem to work) to the WDTV from the second HD using the 'play on' option, it plays on the WDTV and then it is available after that. So I've sent a total of three mp3s to the WDTV from my F: and they still show up on the file menu, and I can play them.

It's strange. I guess I could send my entire mp3 collection to my WDTV through the 'play on' option and then I'd be able to access them, but that seems absurd.
post #27 of 102
The Local Security Group Policy Editor is only available in the Windows 7 Professional, Ultimate, and Enterpise editions. Unfortunately, it's not available in the Windows 7 Starter and Home Premium editions.

Quote:
Originally Posted by doctor media View Post

DO NOT EDIT THE REGISTRY

Follow these instructions to share on Windows7

(1) Run “Local Security Policy” applet under “Administrative Tools”. If you don’t see administrative tools, enable it under the properties of the “Start” menu

(2) Under local policies –> User Rights Assignment

When you see “Deny access to the computer from the network”, REMOVE user “guest”.

(3) Under “Local Policies” –> User Rights Assignment, find “Access this computer from the network” –> add ‘EVERYONE’ and ‘ANONYMOUS LOGON’

(4) Under local policies –> Security Options –> find “Accounts: Limit local account use of blank passwords”. Change the setting to “disabled”.

(5) Under local policies –> Security Options –> Network Access: Shares that can be accessed anonymously –> type in the name of your shares

(6) Enable the guest account; set the guest password to blank

(7) Check the share permissions on your share and make sure it has EVERYONE “read”

(8) Check the file permissions on the files in your share and make sure it has EVERYONE “read”

Enjoy.
post #28 of 102
Thread Starter 
As I said, this isn't global solution.
post #29 of 102
This worked for me. I can now access all folders on all drives (the ones I want to). I go through the Network Shares menu on WDTV now instead of the Media Server menu.

Quote:
Originally Posted by doctor media View Post

DO NOT EDIT THE REGISTRY

Follow these instructions to share on Windows7

(1) Run Local Security Policy applet under Administrative Tools. If you don't see administrative tools, enable it under the properties of the Start menu

(2) Under local policies -> User Rights Assignment

When you see Deny access to the computer from the network, REMOVE user guest.

(3) Under Local Policies -> User Rights Assignment, find Access this computer from the network -> add EVERYONE' and ANONYMOUS LOGON'

(4) Under local policies -> Security Options -> find Accounts: Limit local account use of blank passwords. Change the setting to disabled.

(5) Under local policies -> Security Options -> Network Access: Shares that can be accessed anonymously -> type in the name of your shares

(6) Enable the guest account; set the guest password to blank

(7) Check the share permissions on your share and make sure it has EVERYONE read

(8) Check the file permissions on the files in your share and make sure it has EVERYONE read

Enjoy.
post #30 of 102
Thanks With_Style !!! My MVIX Ultio has been useless to me for the last few weeks. After upgrading to W7 I could only get videos to play if they were in the Users/Default folder. That meant I would have to always move the file I wanted to watch to that folder from my other hard drive before watching. Arghhh!

Thanks so much!
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Gaming & Content Streaming › Networking, Media Servers & Content Streaming › WDTV Live - Windows7 x32/x64 - How to share your files - Tutorial