or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › PLEASE, need help with my Sharp LCD
New Posts  All Forums:Forum Nav:

PLEASE, need help with my Sharp LCD

post #1 of 10
Thread Starter 
I have a Sharp Aquos LC-52D85U. This is my second TV, same model #. I just got this new one after three failed repair attempts by Geek Squad. Unfortunately, it appears to be headed down the same path.

I've had this new one for just a couple days. All of a sudden, out of the blue, the power goes off, and I get a blinking green power light.

The first TV started with the same problem. They ended up replacing the power board, main board, and two other boards in the TV. They said they replaced all boards and everything except the display panel. The problem developed in that TV into where it would turn off, and then back on on its own. This second TV is starting with the same problem the first one did.

Could it have anything to do with my power coming from the wall, or through the surge protector? What are the odds that TWO tv's have the same exact problem?

Any help or suggestions would be greatly appreciated.
post #2 of 10
I would say that it could happen either way, 2 bad sets (same issue) or bad power.

I would look at where you live first. Older house or apartment (By older I mean over 40 years)? An older neighborhood in general? When you turn on the TV after it has been off for a couple of hours do you get the lights dimming a great deal sometimes or all the time?

You could just be getting power spikes and dropouts that are affecting your set. The best thing you could do is to get a someone in with a meter that can measure the power at your outlets for several hours while you do what ever it is that is normal. If you have power that is dropping below 100VAC or going above 130VAC from your outlets, this is probably your issue. I am not suprised that the "Geek Squad" did not check for this.

If this is the case and you have bad power, a surge protector no matter how expensive will not help you. Also a inline noise filter will not work as well, you will have to move IMO.
post #3 of 10
Modern power supplies shouldn't be THAT sensitive. If u have the same prob with multiple sets, I'd just ask them to give you another model.
post #4 of 10
Thread Starter 
Thanks for your thoughts. I live in the suburbs, in a fairly new development in a 6 year old house. If it helps any, before this LCD, I had a Toshiba rear projection that worked perfectly for 8 years or so plugged into the same power.

I'll see if I can find someone with a meter like that to see if I can measure it. It's weird, it happens like once every few hours or so, but, at times, can happen 3 or 4 times an hour. It seems like it happens more in the morning...couldn't be related to temperature, could it?
post #5 of 10
remove all connectors / cables from the back, and most importantly remove the antenna cable.... and then do the test. Does it still shut down?

Boky
post #6 of 10
Is there any difference between the source, resolutionand/ or interface connection that you are using withe the new TV from that which you used with the old TV?
post #7 of 10
Thread Starter 
The only cables I have plugged in are the power cable, and one set of component cables. What test are you referring to, the test with the power meter?

Thanks.
post #8 of 10
Thread Starter 
Walford, I am using actually the same component cables I used on my older rear-projection Toshiba. Those cables connect to my AV receiver and I don't think anything should have changed there.
post #9 of 10
remove EVERYTHING from the back of the TV, leave mains cable plugged-in (obviously, right?), turn the TV ON, tune to any channel (you’ll get no picture and no sound) and let me know if the TV is still shutting down...

Boky
post #10 of 10
Thread Starter 
Thanks Boky. I'll try that tonight. It'll probably be tomorrow when I'll post those results.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › PLEASE, need help with my Sharp LCD