or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Insignia 42" LCD video delay NS-L42Q120-10A
New Posts  All Forums:Forum Nav:

Insignia 42" LCD video delay NS-L42Q120-10A

post #1 of 3
Thread Starter 
We have just moved into a new house and we networked the entire house for computer, phone and AV. We have FIOS coming into a central point with Internet and AV access plugs in most of the rooms. We also have a central audio system which allows us to channel audio throughout the house.

In the process, we purchased a number of TV's/display devices (Dynex, Vizio, Samsung and Insignia) and all have worked well except for our Insignia 42". For some reason, the video of the Insignia's is slower than the sound when it is being piped through the central audio system. It is also slower than the other televisions as the video on a Dynex in another room is about a second faster. It is quite disconcerting to watch a show where the audio is ahead of the video.

Does anyone have advice? Is this a setting problem or a technical problem (new model - hardware/firmware issue)? We have visited Best Buy where we purchased the devices and their advice has been to bring them back and purchase something else. However, we like the price point and we don't know that another brand/model will solve the problem. Any help is appreciated. We aren't AV experts and are quite frustrated.
post #2 of 3
Is the resolution going to the Insignia its native resolution? If the Insignia has a game mode is it enabled?
post #3 of 3
leighmill did you ever resolve this issue?
I just purchased this same unit yesterday and am seeing the same problem. I have spent hours reconfiguring my audio system troubleshooting this. I finally hooked up my old CRT side-by-side with the LCD. I am using the same feed for the CRT & LCD, I just swap cables (tried composite and Svideo). The LCD is VERY slow producing picture AND audio.

The only way to get my surround sound system an audio signal to match the LCD video and audio is to use the LCD's toslink output to feed the system, but It does not send out pro logic, DTS or anything other than basic stereo? No way I am going to just deal with stereo sound with a 6.1 system installed...

My concern is that even that work around is not acceptable as we do some gaming on this tv, a big delay like this is going to make games unplayable.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Insignia 42" LCD video delay NS-L42Q120-10A