or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › FFdshow and reclock not connecting?
New Posts  All Forums:Forum Nav:

FFdshow and reclock not connecting?

post #1 of 5
Thread Starter 
Have been playing about with getting reclock working within vista media center and thanks to others help here I've got it sussed for recorded TV playback (I think!) such that ffdshow will correctly pass the audio to reclock which is detecting the right frame rate (25fps as I'm in PAL land) and outputting it as you'd expect.

However, anything else I've encoded into mkvs doesn't seem to play, either in VMC or in graphstudio. VMC gives me a "unable to play video no codec installed error."

Having played about with it a bit futher in graphstudio, it seems that the problem is actually with ffdshow not wanting to connect to the reclock renderer.

Is there something in the ffdshow output settings which would cause this?

Inserting dscaler audio decoder into the chain for example and it works fine so suggests to me the problem is how ffdshow is setup. If I turn off reclock then ffdshow passes the audio to the default directshow audio renderer just fine.

For reference the files I'm trying I encoded in h.264 with a DTS or AC3 soundtrack.

Any ideas much appreciated!
post #2 of 5
- Codecs: AC3 liba52 (or libavcodec), DTS libdts (or libavcodec); liba52 calculates in fp for better precision.
- Output > Pass-through: uncheck AC3/DTS (obviously).
- Output > Supported output sample formats: check all 16/24/32/32 fp; uncheck AC3/LPCM (just to make sure that ffdshow can output the best PCM format the renderer supports)
post #3 of 5
isnt it easier just to use ac3filter for audio?

you may also want to "check" in reclock settings "SPDIF something" box if you actualy decoding sound on externar reciever
post #4 of 5
Thread Starter 
Thanks both. Got it working now. It was "Output > Pass-through: uncheck AC3/DTS" that I needed to change, but interesting that you commented that this should "obviously" be unchecked, as to my mind at least I would have thought to leave this on?

Surely you want to pass-through the AC3/DTS untampered then let reclock do it's stuff, or is it that reclock can't re-encode unless these have already been decoded?
post #5 of 5
The input audio to ReClock must be LPCM as ReClock varies the speed of the sound in real time to force the sound to stay in sync with the video (that's one of the original purposes of ReClock). If you choose "AC3 Pass-through" in ffdshow, then another AC3 decoder (of the highest merit value) will be inserted between ffdshow and ReClock.

Actually ReClock supports "SPDIF mode", but this is not recommended.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › FFdshow and reclock not connecting?