post #1 of 1
Thread Starter 
I have a weird problem with my impact Acoustics 6x2 Component Video Matrix Selector (Model# 40697) The one that cablestogo has.


Less than a year ago, I installed this matrix switch, everything worked fine until recently. And I had recently replaced the original with another one under warranty assuming the device was just defective. They both have sames problems. Seems too coincidental that I would have same problem on both.

The problem : when all devices are plugged in (inputs/outputs) the switch will only work for about 30 secs, then it seems like it locks up.
In order to switch between inputs or outputs, i have to un-plug the power cord and then plug it back in and make my selections immediately after its powered backup.

My Configuration :
I have 5 input devices connected - DISH DVR, DISH RCVR, XBOX360, PS3, and a Wii - all use component video and a combination of digital/analog audio connections.
Each of these devices are not directly connected to the matrix switch, they are each going through a 4-way splitter before they are connected to the inputs of the matrix switch.
I have two displays connected to the outputs
Output 1 - Phillips Plasma TV and Sony AV receiver
Output 2 - LG LCD TV and Yamaha AV receiver

some of the things I have done to troubleshoot so far.
(1) I have replaced the original unit (the replacement unit has same symptoms) - I know coincidence is considered, but seems like there has got to be a different problem other than both units are defective.

(2) I have switched out the power adapters and even switched to alternate power sources.

(3) I have tested the unit with all device cables disconnected - and this seems to work 100% all the time - so why does it work when nothing is connected ?

(4) I have tested the unit with a variety of device combinations plugged in, attempting to see if i can track it down to a specific input or output. - I get inconsistent results, sometimes, if i have only one or two cables plugged in it works, but its not consistent enough on the same inputs or outputs to really determine specifically which input or output is causing a problem...

(5) I have power cycled the 4-way splitters, thinking maybe a splitter may be malfunctioning possible causing a problem with an input on the matrix, but none of these efforts lead to any conclusions.

Strange thing is that I have not changed any of the device inputs or outputs or cables since I began using this matrix. It worked for at least 6-9 months before i discovered this problem. Its weird that I have same problems even with the replacement unit immediately after i installed it to replace the original one.

Does anyone have any thoughts or troubleshooting tips or ideas?
Anyone have similar experiences with this or any other matrix switch?


Thanks in advance

Jeremy