or Connect
AVS › AVS Forum › Display Devices › Direct View (single tube) CRT Displays › Philips 34-inch HDTV--no picture
New Posts  All Forums:Forum Nav:

Philips 34-inch HDTV--no picture

post #1 of 4
Thread Starter 
I have a 34-inch Philips HD tube set; the other day the picture went out. I have audio but literally no picture. The green pilot light does come on; however, clicking on the remote's menu button brings up nothing, so I know the picture is not working.

Also, when I touch the screen I don't feel any static electricity. When I shut the set off, I do NOT see the typical flash of light you get when a set works but you just have the wrong input selected.

I did unplug and replug the set, but nothing changed. Is there anything else I can try short of repair? Is there a way to reset the set itself, to see if that's the problem? The kids were playing with the remote a few days ago and locked me out of the input. When I went to put in the unlock code, I got no picture.

Thanks.
post #2 of 4
Flyback or video output transistor is blown. Most likely flyback - if the video output transistor would've failed it usually fails shorted, and the power supply would shut down to protect itself.

Repair shop is your best bet.
post #3 of 4
Thread Starter 
Thanks very much for your quick reply. Happy new year from Los Angeles.
post #4 of 4
Happy new year from Bucharest as well.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Display Devices › Direct View (single tube) CRT Displays › Philips 34-inch HDTV--no picture