or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Rythmik Audio Subwoofer thread
New Posts  All Forums:Forum Nav:

Official Rythmik Audio Subwoofer thread - Page 251

post #7501 of 15154
Quote:
Originally Posted by Smigro View Post

Hell yeah...just took delivery of my new FV15HP with the 550 amp, man is this thing massive. eek.gif I expected it to be big, but I had no idea it would be this big. Not to sure this will fit into my Mazda 3 so looks like I need to have one of my buddies come to my work with a truck to get this thing home for me. I will not be able to get to play with this until the weekend though. mad.gif

LOL, as a previous Mazda 3 owner I think it is safe to assume it won't fit either smile.gif

Congrats, looks like a lot of fun smile.gif
post #7502 of 15154
Had three beers last night and ordered a Rythmik FV15HP to replace my SVS 25-31PCI. Single dude's Christmas gift to himself, haha. Can't wait to get this beast!

Smigro, is there a difference between the sub you ordered and the one I ordered? Congrats on the new purchase BTW!!
post #7503 of 15154
Quote:
Originally Posted by dstew100 View Post

There was a ULS 15 and a FV15HP at the last PA GTG, check out that thread for some of the detailed reviews. I arrived a little late, only heard a portion of the ULS demo, and was still getting my bearings so was not really critically listening yet. What I heard sounded good, but I really couldn't compare well enough, look at the thread, graphs included.
There's the whole sealed (more shallow rolloff so potentially deeper but at less output) vs ported (more output down to port tune) difference. Plus the Rythmik is servo based so it is likely a little cleaner. I love my FV15HP, and even though I suspect it to be a bit better than the HSU, I don't think it's a huge gap. I think they are in the same ballpark performance wise. If I were in your shoes it would really depend on how much I could sell the HSU's for, I'd prefer the Rythmiks, but wouldn't drop a grand into a slight upgrade.
Did you see Gorilla's passive caps in the AVS store, that would be a pretty substantial jump up IMO. I was picking pieces of his ceiling out of my hair after that demo. I love my Rythmik but those things are SPL monsters. You'd need to pick up a good pro amp for them too though.
Do you have a buyer for the HSU's?

Thanks, I'll check out that thread. The hsu's play plenty deep, but I'm looking for a little more output. Don't have a buyer lined up for the hsu's, as I'm just starting to think about making a change. I haven't had a good ported sub, only the sealed hsu's or jamo c80 sealed subs before that in the theater, so I'm not sure how much output I think I'm missing. Or maybe it's just time for some new toys
post #7504 of 15154
Quote:
Originally Posted by K5/SS View Post

Had three beers last night and ordered a Rythmik FV15HP to replace my SVS 25-31PCI. Single dude's Christmas gift to himself, haha. Can't wait to get this beast!
Smigro, is there a difference between the sub you ordered and the one I ordered? Congrats on the new purchase BTW!!
Sounds like a great Christmas gift. I'm a married guy, so it's going to take Vodka, not just three beers to pull the trigger on one or probably two of the beasts.
post #7505 of 15154
Quote:
Originally Posted by ack_bk View Post

LOL, as a previous Mazda 3 owner I think it is safe to assume it won't fit either smile.gif
Congrats, looks like a lot of fun smile.gif

I actually took it out of the shipping box and it fit snugly in the back seat. Now I just need to get it upstairs. Will post pics once I get it set up.
post #7506 of 15154
Quote:
Originally Posted by K5/SS View Post

Had three beers last night and ordered a Rythmik FV15HP to replace my SVS 25-31PCI. Single dude's Christmas gift to himself, haha. Can't wait to get this beast!
Smigro, is there a difference between the sub you ordered and the one I ordered? Congrats on the new purchase BTW!!

Haha, that is what this single dude did too. Kind of hefty for a Christmas gift, but I got a good bonus ths year so could justify it.

If you got the standard one, the only difference is the amp. I went with the 550 amp instead of the 600 amp. Accordiing to Rythmik it is only a drop off of .5dB so I figured saving $100 was worth it. Pretty much covered the shipping.
post #7507 of 15154
Quote:
Originally Posted by Smigro View Post

I actually took it out of the shipping box and it fit snugly in the back seat. Now I just need to get it upstairs. Will post pics once I get it set up.

Haha, nothing will stop a determined man and his subwoofer....

Don't throw your back out trying to carry it yourself smile.gif
post #7508 of 15154
Dang... I kind of wish I saved a $100. Is that version available in gloss black also? Just got the UPS shipping conformation...140lbs!!
post #7509 of 15154
Wow these puppy's are selling like hotcakes right now. Rightfully so. New owners, you will not be disappointed.
post #7510 of 15154
Quote:
Originally Posted by Smigro View Post

Accordiing to Rythmik it is only a drop off of .5dB so I figured saving $100 was worth it.
I have the 600 watt amp but...
Double power to get 3 db louder (audibly that's one notch up, you can likely detect smaller changes than 3db, but 3db is "a bit louder")
600 watts is 3db louder than 300 watts. So apparently if you log graph between 300watts and 600watts, 550 is about 2.5 db more than 300.
$100 well saved and another great example of Brian offering great value.
post #7511 of 15154
Quote:
Originally Posted by ack_bk View Post

Haha, nothing will stop a determined man and his subwoofer....
Don't throw your back out trying to carry it yourself smile.gif

I am waiting for help to do that...I have a bad enough back as it is. I went down with my dad to watch the Eagles lose again so I would not have able to mess with it tonight anyway.
post #7512 of 15154
Quote:
Originally Posted by K5/SS View Post

Dang... I kind of wish I saved a $100. Is that version available in gloss black also? Just got the UPS shipping conformation...140lbs!!

I am pretty sure it is, but either way I am sure you will be happy with it.

Yeah I was shocked to see the 140 lb weight on this also. I was even more shocked when it arrived at work on a regular UPS truck. Kind of sucks for them that are expected to move a 140 lb package by themselves.
post #7513 of 15154
Quote:
Originally Posted by dstew100 View Post

Wow these puppy's are selling like hotcakes right now. Rightfully so. New owners, you will not be disappointed.

Yup, word of mouth is the best and cheapest advertisement.
post #7514 of 15154
Have you wrestled that beast up the stairs yet. I am waiting patiently for some pictures and your first impressions. Popcorn in hand...
post #7515 of 15154
Quote:
Originally Posted by BOTBOTCHAI. View Post

Yes , i have test it before with master volume -20db. I not heard any flapping sound from my subwoofer . Only once i heard my subwoofer flapping is when I playing the AVS test disc 10hz test tone . I was jump from my couch and i tell myself I will never ever play it again.LOL.
Just wanna give a feedback regarding the flapping noise issue on my FV15HP. After switching off DynamicEQ, the flapping noise is still there but softer. Still audible at master volume -25dB. With Audyssey MultEQ switched off, the noise is still there. Sigh... called the boss from SoundFusion... hoping for a driver replacement to rectify my problem.

To everyone out there who plan or have just purchased a new Rythmik subwoofer, make sure you do a frequency sweep to check for distortion from the subwoofer. CLICK HERE for the official RealTraps test tone. Although it's a rare case, you'll never know you might have got a lemon. eek.gif
post #7516 of 15154
Quote:
Originally Posted by qguy View Post

Why was it delivered to your office ?

I figured it was just easier that way instead of taking the day off to wait at home for UPS.
post #7517 of 15154
Quote:
Originally Posted by K5/SS View Post

Have you wrestled that beast up the stairs yet. I am waiting patiently for some pictures and your first impressions. Popcorn in hand...

Not yet, I took the day of today do hopefully I can get it done during the day today.
post #7518 of 15154
Ok so I finally got me of my buddies to stop by and help me get this beast upstairs. Part one complete. So I get it into place and if OT it all hooked up and the settings to what I think are correct. So before I finish doing this and before I even turned the AVR on I start hearing a fairly audible hum coming from the I believe the back of the sub ( amp??).

Is this normal and if not has anyone had this issue? I would hate for the to be an issue and have to lug this thing back to work to ship it, but hnestly I only sit about 6 ft away from my sub and I will not be ale to take hearing that thing hum like that.

Any one with suggestions would be greatly appreciated.

Ed
post #7519 of 15154
Ground loop?

Install a two prong cheater plug?
post #7520 of 15154
Quote:
Originally Posted by BeeMan458 View Post

Ground loop?
Install a two prong cheater plug?

This is what someone just suggested to me. Got to see if I have one. Weird that ths did not happen with my other sub though.
post #7521 of 15154
Quote:
Originally Posted by Smigro View Post

Ok so I finally got me of my buddies to stop by and help me get this beast upstairs. Part one complete. So I get it into place and if OT it all hooked up and the settings to what I think are correct. So before I finish doing this and before I even turned the AVR on I start hearing a fairly audible hum coming from the I believe the back of the sub ( amp??).
Is this normal and if not has anyone had this issue? I would hate for the to be an issue and have to lug this thing back to work to ship it, but hnestly I only sit about 6 ft away from my sub and I will not be ale to take hearing that thing hum like that.
Any one with suggestions would be greatly appreciated.
Ed

it's a ground loop issue....
post #7522 of 15154
Quote:
Originally Posted by Smigro View Post

This is what someone just suggested to me. Got to see if I have one. Weird that ths did not happen with my other sub though.

Did your other sub have a three prong plug, or a two prong plug? If a two prong plug, then no ground loop problem as there's no ground to loop to.

Try disconnecting the subwoofer connection from the AVR. If a ground loop problem, then disconnecting anything but the power cord should remove the loop condition. This would apply even if attached to a metal rack or any kind of EQ. Anything that would allow a ground condition to exist between two different items.
post #7523 of 15154
Cheater plug will not help. The amp doesn't even have a ground on it.
post #7524 of 15154
Quote:
Originally Posted by mtdking View Post

Cheater plug will not help. The amp doesn't even have a ground on it.

Disconnect everything from the sub but the power cord. A ground loop condition can exist if two appliances are connected.
post #7525 of 15154
Unplug your RCA input cable and see if it goes away. Make sure you are not on auto on to test it or you might not have the amp on to see if there is still a hum.
post #7526 of 15154
Quote:
Originally Posted by mtdking View Post

Cheater plug will not help. The amp doesn't even have a ground on it.

Our H600PEQ3 and H550PEQ3 do have ground pin. A cheater plug should get over the problem. Now our H600/H550 amplifiers have double insulation of the main. Customers occasionally have ground loop issue. In the future, I may ask the manufacturer to use the class 2 configuration.
Edited by Rythmik - 12/14/12 at 3:42pm
post #7527 of 15154
Your picture on your website shows no ground!
post #7528 of 15154
Quote:
Originally Posted by mtdking View Post

Your picture on your website shows no ground!

You are correct those photos do shown no ground pin. They were from 2008 (can't believe it has been that long). After 2009-2010, we switched to 3 prong IEC power socket. I have all the new photo shoot done for PEQ3, XLR2, XLR3, and PEQ. We will update the photo shortly.
post #7529 of 15154
Well I can say that I did try unhooking the RCA cable and it did not go away, this was tried with the selector switch set to not auto If I pulled the power plug though it would go away.

That being said I went to Home Depot and got a cheap $.69 three to two adapter plug. It was weird because at first I was fine and then it's he buzz would flicker on and off. It did that for a few minutes and now ithree last 15 minutes it has not hummed.

I think what I may do since the outlet on the back of my room is on a different circuit (house is from the 40's and has weird wiring) is run an extension cord to the sub from there and see if the problem persists. If I works fine that way I may just get a surge protector for that outlet and pug the sub in there.
post #7530 of 15154
Watch out for dimmer switches or torchiere type lights with a dimmer on the same electrical circuit. I had some very audible buzz until I shut off my light.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Official Rythmik Audio Subwoofer thread