or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Toshiba 40RV525U bricked by firmware update pls HELP!
New Posts  All Forums:Forum Nav:

Toshiba 40RV525U bricked by firmware update pls HELP!

post #1 of 16
Thread Starter 
To upgrade from 1.04 to 1.05, I downloaded the 2 files listed (STX40TAAD105_20090202.ecc & STX40TAAD-SAM40.ecc) from Toshiba's link http://support.toshiba.ca/support/ce...?docid=D000020 and put them on a FAT32 formatted USB stick. I followed all instructions to the letter, and I saw the expected screens, including the completion progress screen, and the last one which said to remove the stick and click 'OK'. I removed the stick and hit 'OK'.

It didn't do anything for about a minute, I kept hitting 'OK' and then the TV finally did a power reset (the power LED went off, then back on again). When the power LED came back on, all I have now is a black screen, and it will not respond to the remote, except for power on/off.

Then I went back and looked at the files, I saw that the first one had not downloaded completely, it was only 271K! I downloaded it from the link again (now 3.1 MB), put it on the stick and tried to start the firmware update again, but the TV doesn't recognize it, the LED on the USB stick comes on for only a split second during powerup, then goes out and stays out. I leave it unplugged for over 1/2 hour between attempts, same thing.

The firmware troubleshooting guide says “If current FW is newer than service FW version, it will not allow updating and no message box will appear (looks same as USB not recognized)”, from this Link: http://support.toshiba.ca/support/ce...W%20Update.pdf

Since I updated from 1.04 to a ‘bad’ 1.05, maybe the TV thinks that the 1.05 on the stick is not recent enough, and won’t allow me to upgrade it again? If that’s it, then maybe a hex editor to make it versions 1.06 or greater? I don’t know!

Can someone please help me rescue this TV? TIA, Al.
post #2 of 16
I'd call toshiba and see if they can help you

and btw i think when it comes to TV's its not bricked its doorstop'd
post #3 of 16
Thread Starter 
Forgot to mention, I call them at 800-268-3404 as listed on that firmware page, RNA. I don't expect them to help. BTW, is there hope in it being a doorstop vs. a brick?

PS, I also try other support numbers like Phone: 800-631-3811, but I stay on hold forever, the recording has already told me dozens of times that my call is important to them :-(
post #4 of 16
Thread Starter 
Update: I used Hex editor Tiny Hex and found 5 instances of 1.05 in each of the two files. I changed them to 1.06, didn't work. I also tried to change the '105' string in one of the file names to '106', didn't work, USB still lights up for only a split second.

Still hope someone can help, TIA.
post #5 of 16
the doorstop thing was a joke

ie the TV is now just a doorstop

I think your pretty much screwed without help from Toshiba simply because flashing firmware is a very touchy process and if it goes wrong in any way with most devices it creates a brick and the only way to correct it is to reprogram the TSOP on the mainboard via a hardware interface like a JTAG port

its much like cell phones

Android phones like the G1 for example contain 2 parts to their software the SPL and the actual Rom. reflashing a rom is not risky on them because the SPL will still allow the phone to turn on and flash a new rom again giving you basic control of the phones hardware to fix the problem. if you flash a bad SPL to your phone however you are bricked and the only way to save the phone is to take it apart and do a hardware flash of the chips and people still have not yet figured out how to do it (but HTC the phone manufacture sure can do it)
post #6 of 16
Thread Starter 
Sorry I didn't get the joke, now it makes sense.

I know it's my own damn fault for doing this, now I actually remember that way back in the 90's, all firmware would be contained in an archive file and it wouldn't extract if corrupt cuz it checked the crc. Hard to believe that Toshiba doesn't do that or give you a hash to check it with, but shame on me for not being more careful.

Thanks much, Frito. Guess I'm going to the store tomorrow to get a new TV, no way I'm going to miss the big game, y'know??
post #7 of 16
yeah crappy way to loose a TV

and yeah android flash files are .zip file and it checks CRC before flashing

i've flash my sony 32xbr6 like times without problems but i did make sure the file size was correct before i did it
post #8 of 16
Thread Starter 
Update: TV is still dead, still trying to get hold of Toshiba. I considered that I should do what I could to whoever might fall into the same quicksand. Here is md5 & size info from Quicksfv (the 2nd file was the corrupt file, note that the hash is the same for both, indicating that they are identical):

3185152 STX40TAAD-SAM40.ecc
3185152 STX40TAAD105_20090202.ecc
aec75b375e52d74a265d9af78638953e *STX40TAAD-SAM40.ecc
aec75b375e52d74a265d9af78638953e *STX40TAAD105_20090202.ecc
post #9 of 16
I know that this is a silly question, but, did you unplug the tv for a few minutes after the firmware update? That is also one of the final instructions to the firmware update. I did the update and then unplugged the set and waited 3 minutes and then back in and all worked good.
post #10 of 16
Thread Starter 
Thanks for the followup, I just tried to power up after a few days of being unplugged, same thing. The instructions for the suffix 'U' models say "6) “Remove the USB Flash Drive” from the TV receiver. Press the “Enter” button on the TV remote. After several seconds the TV receiver will reboot. Firmware updating is complete." That's exactly what I did, and exactly what happened albeit with the LONG delay when I clicked "Enter".

I know that other Toshiba firmware instructions have you unplug the TV, but these did not.
post #11 of 16
Same happened to me. did you find a fix yet?
post #12 of 16
This is really sad to read that two people had this happen already. I'm surprised that the TV does not check that the files are good or that Toshiba does not even compress their firmware to add some level of corruption protection to the files. I would call and complain big time.
post #13 of 16
Thread Starter 
Originally Posted by fishbotic View Post

Same happened to me. did you find a fix yet?

Yup, repairman replaced system board
post #14 of 16
Thread Starter 
Originally Posted by banduraj View Post

This is really sad to read that two people had this happen already. I'm surprised that the TV does not check that the files are good or that Toshiba does not even compress their firmware to add some level of corruption protection to the files. I would call and complain big time.

Call who, exactly? Name someone in 'Customer Care' who really gives a care...
post #15 of 16
The same thing happened to me. However, I did not download the firmware update myself, I had Toshiba send it to me which makes it worse. First they sent me the wrong one, then a week later (after calling them again) I received the correct one. I plugged it in and all went well up to the last step. After removing the USB and pressing enter, the tv made several loud static-like noises and then rebooted only to find that it was nothing but a black screen. Not only that, but when I called Toshiba to tell them they said they will call me in a day or two to LET ME KNOW when some one will be out. That's right just to let me know. Who knows how long it will take after they "let me know". And to top it all off it's right in the middle of march madness. I'll tell you this much, if they come out and can't fix it, my next tv will be on them. I feel bad for the repair guy honestly he doesn't know what he's in for. I hope he's good at his job. Btw Toshiba is horrible. What kind of customer service is that? Oh sorry we broke your tv , well be out in a week to fix it. I'll never buy a Toshiba again.
post #16 of 16
Dear All,

I recently had a problem when flashing the firmware on a Toshiba 40RV753B (UK version) LCD Television. The firmware flash did not complete and the set would not turn on with the remote (no picture, no sound). The solution to this was to:

(1) Get a blank thumbdrive and install the latest firmware upgrade from Toshiba. It was important to first full format the drive with FAT16 and not have any other partitions on it (such as CDFS as you sometimes get on free ones that have stuff on it from attending a conference).
(2) With the thumbdrive not in the unit, press and hold the ON button (on the unit not he remote) for 10s until the lights flash. At this point the green light will come on and reset the unit (this may not fix the problem, in my case it lead to the green light staying on permanently and still no picture or sound).
(3) Put the Thumbdrive in the proper USB firmware upgrade slot (USB1 - not the one for the WLAN).
(4) Hold down three buttons-> Menu/Return and Source/OK and the ON button on the Unit for 10s.
(5) If your thumbdrive has a light you may see it blink. The light on the unit will turn yellow.
(6) Don't do anything for half an hour. Then the light will turn green.
(7) Remove the Thumbdrive
(8) Press the On button for 10s until the light flashed again indicating it is resetting the unit.

This worked for me. I design home theatre systems so I know a little about them. Good luck.

-bradiko (Audio3 Ltd.)
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Toshiba 40RV525U bricked by firmware update pls HELP!