or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › EDID Overrides to solve bitstreaming issues for ATI 5xxx's
New Posts  All Forums:Forum Nav:

EDID Overrides to solve bitstreaming issues for ATI 5xxx's - Page 2

post #31 of 3940
Thread Starter 
Quote:
Originally Posted by nholdcroft View Post

Hi. Thanks for the speedy response! Sorry for the next question but I'm not 100% clear on all this stuff, even after reading the forums. Are you saying that the JVC projector (video) part doesn't matter, and that if I just take one of your existing mods (which includes the 906) it should work fine with my 905?

Thanks again.

What I'm saying is that, regarding bitstreaming of HD audio codecs (DTS HD & TrueHD) your Onkyo 905 will have no issues with current ATI drivers on your 5450 (as its audio block is the same as the 906's, which is what I'm using for the mods).

Now, as for the video part: are you having issues with the proj. connected to the HDMI splitter and the 5450?
post #32 of 3940
Hi. Got it! Thanks!

I've got no issues on the video side. It allworks great via the splitter. However, at the moment I only get a stereo (2 channel) option on the audio side in the control panel sound configuration i.e. no 5.1, 7.1, TrueHD etc. and nothing but stereo output to my 905. I've installed the latest ATI drivers from their site for the 5450 and installed the realtek 2.42 ati hdmi driver from the realtek website but still no joy.

I thought I'd try the EDID mod to try to solve it, but I guess that is not the answer!
post #33 of 3940
Thread Starter 
And your player is ... MPC-HC, TMT3, PDVD9 or WinDVD2010?

Have you set the Realtek driver to 5.1 or 7.1 on Windows?

... one more question: is the HDMI splitter HDCP compliant?
post #34 of 3940
amd&ati, think again, what's missing?

We are tired with ati issues for years but ati is not tired at all being in this funny situation.

Thanks a lot tulli, encore to you
post #35 of 3940
Hi. To be honest, I've not even got to the HD audio codec stage yet. I'm hardware ready i.e. 5450, Blu-ray drive etc but I can't even get past the stereo only output in the Sound configuration (see attached screenshot) - so don't appear to have an option to set the realtek driver to anything else.

Once resolved I'll start playing with TMT3 for the HD audio codecs. I've connected the HDMI to Input 1 on my Onkyo and the splitter is definitely HDCP (HDMI 1.3b) compliant (I've played Blu-rays a while back via it, albeit without HD audio). Any ideas why I'm not seeing anything but stereo in the sound configuration? Thanks.
LL
post #36 of 3940
Thread Starter 
Could be a problem in the Onkyo. Have you set HDMI to "AMP" (no TV audio passthrough")? That's how it's called in my Denon.
post #37 of 3940
Unfortunately, yes. I've set the HDMI pass through off in the Onkyo 905 settings so that isn't it... I must admit, I'm at a bit of a loss. I thought the 5450 with the latest ati catalyst drivers + the realtek ati hdmi driver would work. I didn't expect to be spending my time trying to get DD and DTS to work let alone the HD audio codecs! Thanks.
post #38 of 3940
Thread Starter 
Ok, can you please clarify how the htpc, onkyo, proj., and other devices are connected through the splitter. For, depending on how they are connected there could be an EDID isssue after all, and an EDID override would definitely be needed!

I will start doing your mod anyway, so that you try it.
post #39 of 3940
I believe the splitter is causing the issue. It's probably reporting the lowest common accepted format for all devices (which would be LPCM 2.0).
post #40 of 3940
Thread Starter 
Exactly, vladd.

@nholdcroft, I attach your mod. It should solve your audio issues, but video timings, color range, etc., will be all your projector's, so see how it affects your other display devices. If so, we'll deal with that later, but first see if audio issues are solved.

 

JVCHD750 - Onkyo905.zip 1.21484375k . file
post #41 of 3940
Tulli / Vladd, you guys are spot on. I took the splitter out of the chain and I had all the audio codecs, 5.1, 7.1 etc options in the sound configuration. I put the splitter back in the chain and I'm back to stereo, with picture on one of my TV's but no longer on the JVC projector. Thanks for the mod, I'll give it a go tomorrow night (it's 1am here in the UK now) and report back. Many thanks!
post #42 of 3940
the JVC rs20 / Denon avr5308 EDID hack worked for dts master audio so far... the trial i have of TMT3 doesnt allow Truehd so havent tested with that yet.

Thanks again!
post #43 of 3940
Thread Starter 
Quote:
Originally Posted by hifiaudio2 View Post

the JVC rs20 / Denon avr5308 EDID hack worked for dts master audio so far... the trial i have of TMT3 doesnt allow Truehd so havent tested with that yet.

Thanks again!

Great! Will add it to the list.
post #44 of 3940
Just in case, according to many sources Catalyst 10.2 is coming out today, let's see what's happening there.
post #45 of 3940
Hi. I did try out the mod Tulli provided last night (thanks) - luckily I had my home server to restore my htpc... Once I'd installed the inf file my TV video flickered on and off repeatedly and the JVC projector didn't show a picture, but my Onkyo 905 (feeding the projector over HDMI) kept flicking repeatedly (every few seconds) between signal and no signal on the display -- the good news being that when it had a signal it was multi-channel indicating the htpc was recognising the capabilities of the Onkyo.

I guess this means the inf files I provided to Tulli are no good? I generated them a while back on the same htpc but via the Gigabyte motherboard integrated HDMI port using Moninfo.

Is it possible to integrate the Onkyo audio block with the generic pnp monitor inf file (I have no picture issues with the generic monitor inf) or will this not work? If so, I'll have another go at generating inf files to retry the mod if you're up for it Tulli.

Thanks.
post #46 of 3940
Thread Starter 
Quote:
Originally Posted by Andy o View Post

Just in case, according to many sources Catalyst 10.2 is coming out today, let's see what's happening there.

Yup, will check it out, thx Andy.
post #47 of 3940
Thread Starter 
Quote:
Originally Posted by nholdcroft View Post

Hi. I did try out the mod Tulli provided last night (thanks) - luckily I had my home server to restore my htpc... Once I'd installed the inf file my TV video flickered on and off repeatedly and the JVC projector didn't show a picture, but my Onkyo 905 (feeding the projector over HDMI) kept flicking repeatedly (every few seconds) between signal and no signal on the display -- the good news being that when it had a signal it was multi-channel indicating the htpc was recognising the capabilities of the Onkyo.

I guess this means the inf files I provided to Tulli are no good? I generated them a while back on the same htpc but via the Gigabyte motherboard integrated HDMI port using Moninfo.

Is it possible to integrate the Onkyo audio block with the generic pnp monitor inf file (I have no picture issues with the generic monitor inf) or will this not work? If so, I'll have another go at generating inf files to retry the mod if you're up for it Tulli.

Thanks.

The .inf files you provided were fine IMO. Looks like that for whatever timings that went through the splitter every hdmi device had a hard time syncing in. So maybe the splitter is just not passing through the timings coming from the htpc?

Again you can test if the override is fine by plugging the Onkyo-Projector chain directly to the htpc.

As for the GenericPnP default monitor driver, AFAIK it cannot be modded.
post #48 of 3940
Thanks again Tulli, got everything working now, that mod helped....now it's just some fine tunning for image quality.

Cheers
post #49 of 3940
Quote:
Originally Posted by bcray View Post

Fantastic. Thanks so much for being helpful with all this. I'll try it this evening and report back.

Worked like a champ. Thanks again Tulli.
post #50 of 3940
Thread Starter 
Just tested CAT 10.2 ... no TrueHD on my DENON 988 without the EDID Override ...
post #51 of 3940
I have read through this several times, but still a bit confused. I have a Panasonic Plasma TH-50PZ700U and an Onkyo Tx-sr706 receiver. Can I use one of the already provided EDID override files even though none are my exact combination, or should I provide the inf files with the method described by Tulli for a custom EDID? Thanks for any help. Anxious to get bitstreaming working.
post #52 of 3940
Quote:
Originally Posted by Tulli View Post

Just tested CAT 10.2 ... no TrueHD on my DENON 988 without the EDID Override ...

Any chance this update could fix the mismapped DTS surround channels, or is that only going to come from the player developer...?
post #53 of 3940
Thread Starter 
Quote:
Originally Posted by thrang View Post

Any chance this update could fix the mismapped DTS surround channels, or is that only going to come from the player developer...?

No changes in the ATI HDMI audio driver as far as I have seen. There's still the "silent stream" bug. Didn't check the version number and I have just uninstalled it as it gave me inconsistent black levels, so went back to 9.12 hotfix.
post #54 of 3940
Thread Starter 
Quote:
Originally Posted by FranklinT View Post
I have read through this several times, but still a bit confused. I have a Panasonic Plasma TH-50PZ700U and an Onkyo Tx-sr706 receiver. Can I use one of the already provided EDID override files even though none are my exact combination, or should I provide the inf files with the method described by Tulli for a custom EDID? Thanks for any help. Anxious to get bitstreaming working.
Yes. Look for a "type" similar tou your setup, in this case a Panasonic Plasma TV + ONKYO AVR ... hmm, just checked and there is not that specific combination ...

The Panasonic Plasma + DENON AVR will work for you but I'll post a proper one with an ONKYO AVR in a moment ...

EDIT:

OK, use this one.

 

Panasonic TH-42PZ700U - ONKYO 905.zip 1.2158203125k . file
post #55 of 3940
Hello Tulli, I have tried the mod SONY LCD + DENON AVR and it he has not served, I you upload the inf as you said to me, Thank you

 

ANGY26730.zip 1.9697265625k . file
post #56 of 3940
Thread Starter 
Quote:
Originally Posted by angy26730 View Post

Hello Tulli, I have tried the mod SONY LCD + DENON AVR and it he has not served, I you upload the inf as you said to me, Thank you

Those are 128-byte captures. Please keep in mind that the full 256-byte EDID cannot be captured on a 5xxx card.

What exactly are your issues with the mod you applied?
post #57 of 3940
Quote:
Originally Posted by thrang View Post

Any chance this update could fix the mismapped DTS surround channels, or is that only going to come from the player developer...?

Could you elaborate on this DTS surround problems? I know of one that happens with all 5.1 decoded audio in a system with Windows set to 7.1, but not only with DTS. If it's happening while bitstreaming, then it's likely your receiver.
post #58 of 3940
I've done some testing on my system tonight and my troubles are definitely stemming from my hdmi splitter. I have tried the following scenarios:

1. Connect htpc directly to Onkyo 905 and from there to the JVC HD-750 projector -- EDID overide supplied by Tulli works great

2. Connect htpc to hdmi 4 way splitter and from there to a/ Onkyo and then JVC HD-750 and b/ LG LCD TV -- I get video switching on and off repeatedly on the LG and no video on the JVC (have to do system restore to restore viewable video again).

3. As per 2, but don't connect splitter to the LG. I get no picture on the JVC but my Onkyo does indicate multi-channel, so the splitter seems to be cutting out the picture.

So this leaves me to conclude that a different combination of inf files (e.g. Onkyo and LG) are not going to make a difference because the problem appears to lie with the splitter.

Has anyone else had this issue? Any recommendations on an HDMI splitter that will pass the EDID overide information correctly? Thanks.
post #59 of 3940
Thread Starter 
Excellent analysis!

Now, does your 905 really have 2 HDMI-out? (just googled so I don't know). Are they both active simultaneously? If so you could put the splitter behind the Onkyo, then send HDMI1-out to the proj. and HDMI2-out to the splitter, and then of course from the splitter to the other HDMI display devices.
post #60 of 3940
Hi Tulli,

Can you help me with EDID for the Pioneer PDP-6020FD and Marantz SR8001 combo. I didn't anything similar on your list. Thanks.

Attachment 167453

 

Pioneer PDP-6020FD MarantzSR8001.zip 1.98828125k . file
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › EDID Overrides to solve bitstreaming issues for ATI 5xxx's