or Connect
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › HD-A1 overheating/turning off?
New Posts  All Forums:Forum Nav:

HD-A1 overheating/turning off?

post #1 of 3
Thread Starter 
Back when HD-DVD first started I jumped on board pretty quick and bought an HD-A1 which of course besides the long load time I loved it. I had no issues whatsoever.

After moving into a new home I somehow lost the power cord, but at this point HD-DVD was no more and I had already bought a blu ray player so I just told myself that when I had a chance I'd get around to getting a new power cord. well I finally got a new power cord some two years later or so lol.

So I powered it up and everything seemed to be going fine until after watching a movie for I'd say maybe 30 minutes it powered itself down....I thought at first it was maybe a defective disk? ( I was watching children of men hd-dvd, which I read had some problems) but after trying several other movies it seemed to be powering down by itself at random times also.

now I read that the XA2 had some kind of bug that did this, but has anyone experienced this with the A1? Is it something that a latest firmware update could possibly solve or is my machine simply overheating and about to bite the dust?
post #2 of 3
This can be that CPU cooling module is clogged with dust. Remove the top cover, and find the small fan which lies flat on top of the main cpu. Remove the fan ( 2 screws), revealing the fins for the copper cooling module. Blow it out thoroughly w/canned air. That should take care of the problem.
post #3 of 3
Thread Starter 
That's exactly what it was! I opened it up and it was COVERED in dust, which I don't know why I didnt think of that considering it was sitting unused for nearly two years.............lol. I'm watching a movie now and no issues whatsoever so far.

Thank you so much for the help!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HD DVD Players
AVS › AVS Forum › Blu-ray & HD DVD › HD DVD Players › HD-A1 overheating/turning off?