or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Official Emotiva XPA-5 Owners Thread
New Posts  All Forums:Forum Nav:

Official Emotiva XPA-5 Owners Thread - Page 5

post #121 of 1944
Just got My XPA-5 yesterday and it is a GREAT amp!! But I must say that emotiva needs to up there customer service. My amp was damaged (cosmetic) 2 bolts on one side where damaged because it was hit from the front and left side of frame was bent and the housing was pushed back and snapped off the bolts that hold the cover on. The front alluminium pieces where also bent and had one of the bolts snapped off. I managed to get all the bolts out and replaced and bent the alluminium piece back so it looks perfect but I couldn't straighten the frame perfectly so the outside cover does not seat with the front panel on one side..small gap...see pics below. I called customer service and they said they will try to fix it and see what they can do...I said the frome is bent I want a new one? She said well then "you" ship it back. They should be shipping this back NOT me. This was not done by fedex either bcause you can clearly see where someone tried to fix this and the dent on the thick front panel has a scrape on it and that would not happen thru the foam, this was done at the factory INMHO. I just think that after I spent $800.00 with them and I get a damaged product they should ship it back and give me a new one...not try to fix a damaged one. So I guess I am keeping this one but will NEVEr buy another product from emotiva. I had very high hopeds for this company and after all the good reviews I thought I had a winner...guess not. I will update this after I talk to someone else becuse sometimes you get the wrong person on the phone so we will see.

How would you feel if you recieved your amp in tis condition?







post #122 of 1944
I have had several quality control factory damage issues with Emotiva. Yours are worse than mine. I would suggest speaking with someone else at Emotiva. Not Vincent. I had a bad experience with him. He also tried to offer to fix a new amp that had problems. I said no way. This is not a repair situation. It's a brand new amp. They should send you a call tag and instantly send you a brand new amplifier before they even get your current amp back. They eventually did get it right and sent me a new amplifier.
post #123 of 1944
Quote:
Originally Posted by Secret Squirrel View Post

I have had several quality control factory damage issues with Emotiva. Yours are worse than mine. I would suggest speaking with someone else at Emotiva. Not Vincent. I had a bad experience with him. He also tried to offer to fix a new amp that had problems. I said no way. This is not a repair situation. It's a brand new amp. They should send you a call tag and instantly send you a brand new amplifier before they even get your current amp back. They eventually did get it right and sent me a new amplifier.

I agree, the box was in perfect shape...this was done at the factory and somone actually tried to fix it because of the scarpes on the fram that someone tried to bend back. They sent it anyway, fedex gets blamed. I should get a replacement before this one goes anywhere...why should I by without my HT because they made a mistake?
post #124 of 1944
I sent them pictures to prove what happened in my case. The proof was in the pictures. The boxes in my case where also fine. A display on one of the amps I got looked like a cat used it for a scratching post. This was under the sticker that comes on the display. Another amp I got had a dent on the top of the cover. They claimed that could of happened from the factory over torquing the screws. Well then don't let the idiots at the factory use power screw drivers if they can't torque the screws properly. I got all kinds of excuses from them. All of them where BS in my opinion. Once the higher ups saw the pictures they where speechless and then backtracked very quickly.
post #125 of 1944
Quote:
Originally Posted by Secret Squirrel View Post

I sent them pictures to prove what happened in my case. The proof was in the pictures. The boxes in my case where also fine. A display on one of the amps I got looked like a cat used it for a scratching post. This was under the sticker that comes on the display. Another amp I got had a dent on the top of the cover. They claimed that could of happened from the factory over torquing the screws. Well then don't let the idiots at the factory use power screw drivers if they can't torque the screws properly. I got all kinds of excuses from them. All of them where BS in my opinion. Once the higher ups saw the pictures they where speechless and then backtracked very quickly.

Mine has dents to LOL!! I have pics also!
post #126 of 1944
What the hell do we need to do when opening new gear - document it all with video? This sucks royally - no visible damage to the box, yet damage inside. It HAD to have been done at the location that packed it.

Good luck with this. Keep being the squeaky wheel. Have you posted on *their* forum?

jeff
post #127 of 1944
Quote:
Originally Posted by pepar View Post

What the hell do we need to do when opening new gear - document it all with video? This sucks royally - no visible damage to the box, yet damage inside. It HAD to have been done at the location that packed it.

Good luck with this. Keep being the squeaky wheel. Have you posted on *their* forum?

jeff

My thoughts exactly...the one that gets me is on the inside where I took the cover off to see why the bolts didn't line up there was pry marks where somone tried to bend it back? I will haver to post this on the forum I think...not real pleased. I am in no way saying the amp sucks...great amp but a great amp should be followed up with great customer service. for example...GIK accoustics would replace any item I get with out hesitation if it where damaged.
post #128 of 1944
Yes, take it to the Emotiva forum. Be nice. You'll catch my flies with honey than with vinegar.
post #129 of 1944
Could be why they offer free shipping.

Just kidding. Emotiva has been for the most part excellent at CS.
post #130 of 1944
Quote:
Originally Posted by joerod View Post

Could be why they offer free shipping.

ROFLMAO!!...okay that was good!
post #131 of 1944
I would have to agree joerod. I got my xpa5 and had it for about a week, and one of the leds was flickering. I called sarah and told her, and they sent me a brand new amp that day. They sent a shipping label in the new amp box and I shipped that one back.
post #132 of 1944
Quote:
Originally Posted by pepar View Post

Yes, take it to the Emotiva forum. Be nice. You'll catch my flies with honey than with vinegar.

I just posted the link to this thread on the emo forum.
post #133 of 1944
Quote:
Originally Posted by nezff View Post

I just posted the link to this thread on the emo forum.

Good thinking.
post #134 of 1944
Quote:
Originally Posted by pepar View Post

Yes, take it to the Emotiva forum. Be nice. You'll catch my flies with honey than with vinegar.

Quote:
Originally Posted by pepar View Post

What the hell do we need to do when opening new gear - document it all with video? This sucks royally - no visible damage to the box, yet damage inside. It HAD to have been done at the location that packed it.

Good luck with this. Keep being the squeaky wheel. Have you posted on *their* forum?

jeff

Quote:
Originally Posted by joerod View Post

Good thinking.

http://emotivalounge.proboards.com/i...&page=3#349554
post #135 of 1944
Quote:
Originally Posted by nezff View Post

I would have to agree joerod. I got my xpa5 and had it for about a week, and one of the leds was flickering. I called sarah and told her, and they sent me a brand new amp that day. They sent a shipping label in the new amp box and I shipped that one back.

This is what I would like done....I love the product (great amp)...I must have talked to the wrong person or something because nothing of the sort was offered to me.
post #136 of 1944

You posted this on the other board? "I just hope that what the guy is claiming happened is not true"...I assure you it is true.
post #137 of 1944
I didn't say it wasn't true. 50/50
post #138 of 1944
Quote:
Originally Posted by nezff View Post

I didn't say it wasn't true. 50/50

I misunderstood then.
post #139 of 1944
Okay I got off tye phone with emotiva and they have staisfied me and beyond....new unit coming and has a shipping label. I must have talked to the wrong person the first time.

GOOD job emotiva...VERY much appreciated!
post #140 of 1944
Quote:
Originally Posted by robc1976 View Post

Okay I got off tye phone with emotiva and they have staisfied me and beyond....new unit coming and has a shipping label. I must have talked to the wrong person the first time.

GOOD job emotiva...VERY much appreciated!

Who did you talk to this time?

I told you they were good to their customers. Rachel or Sarah was the one that took care of me the first time.
post #141 of 1944
Quote:
Originally Posted by nezff View Post

Who did you talk to this time?

I told you they were good to their customers. Rachel or Sarah was the one that took care of me the first time.

I talked to Kathy Laufman "president" she was a bit mad this was not done already and is going to find out how it happened.

I thank you for the info to!
post #142 of 1944
Quote:
Originally Posted by robc1976 View Post

I talked to Kathy Laufman "president" she was a bit mad this was not done already and is going to find out how it happened.

I thank you for the info to!

Well, I honestly wouldnt have gotten off the phone with them the first time. I would have to speak to someone higher up, and if that didnt work, someone higher than that if that was possible. If it didnt get solved that way, then you could have posted about it here.
post #143 of 1944
Quote:
Originally Posted by nezff View Post

then you could have posted about it here.

Noone was available because it was late friday and she said "it was policy" wich it wasn't...she wanted to go home probally LOL!!
post #144 of 1944
monday then.
post #145 of 1944
Quote:
Originally Posted by nezff View Post

monday then.

Uh...I called them today and it is Monday??
post #146 of 1944
I am still waiting affordable multi-channel class D amplification Doesn't seem like it will happen anytime soon. Only option I know of is to go with $1600 worth of pro amps or so.
post #147 of 1944
Quote:
Originally Posted by robc1976 View Post

Uh...I called them today and it is Monday??

I meant before you post something about them. You got your issue taken care of right? Like I said you would. I just wouldnt have posted anything until I got to the bottom of it and talked to the HEAD person.
post #148 of 1944
Quote:
Originally Posted by MichaelJHuman View Post

I am still waiting affordable multi-channel class D amplification Doesn't seem like it will happen anytime soon. Only option I know of is to go with $1600 worth of pro amps or so.

http://www.reddragonaudio.com/products/
post #149 of 1944
Quote:
Originally Posted by nezff View Post

http://www.reddragonaudio.com/products/

That's not affordable. $700 for a monobloc? No thanks. I saw no multi-channel offererings at that site.

I am talking about a 5 channel and/or 7 channel class D amp for maybe $1200. At least 150 watts / channel.

Given that Crown can sell a single chassis, stereo amp for with 200x2 into 8 ohms, class D, for around $400, does not seem unreasobable for someone to be able to sell a 5 channel amp for around $1200, with $1500 max for 7 channel amp.

I assume the demand (or assumed demand,) is not there.

One of my favorite options is probably Outlaw's 7125, but it's 50 pounds. I would guess it has sufficient power for most people's needs.
post #150 of 1944
Quote:
Originally Posted by nezff View Post

I meant before you post something about them. You got your issue taken care of right? Like I said you would. I just wouldnt have posted anything until I got to the bottom of it and talked to the HEAD person.

Thats the problem, I shouldn't have to go all the way to the top if the system is correct....sorry but I am NOT going to have a finger pointed at me for posting truthful things....should have been able to be fixed with the 1st person I talked to...if not...that person needs to be fired. End of story.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Official Emotiva XPA-5 Owners Thread