or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Official Sharp Aquos LC-60E88UN Owner's Thread.
New Posts  All Forums:Forum Nav:

Official Sharp Aquos LC-60E88UN Owner's Thread. - Page 3

post #61 of 1527
Quote:
Originally Posted by topr View Post

What Sharp do you have?

I believe this is the official LC-60E88UN owner's thread.
post #62 of 1527
Quote:
Originally Posted by veragoxx View Post

I have had this set for 2 weeks. I purchased 3 tvs from Magnolia and set them up in my house. This Sharp beat out the 65" paniconic viero and the 63" Samsung plasma. I had lag during gaming (360/ps3) called sharp and the rep told me that the tv was so new that they had not yet gotten the specs for it. However he did say to turn off fine motion control and to turn off cinema mode. I did and I have zero lag. This TV is fantastic. I read some comments and someone mentioned this set was not LED....it is. I still have the specification sticker on the side of my TV that says LED. Not LIKE LED, so it is a true LED. Of course all LED are in fact LCDS <------ I am feeling like Dr. Seuss! The 240hz on this set make it seem to me when Im watching that I am actually on the set of the movies. So lifelike it is unreal. No motion blur at all to report. This is straight out of the box. Speakers on the TV are terrible, you will need a sound bar or surround, whichever is clever!

Quote:
Originally Posted by Frank_K View Post

I believe this is the official LC-60E88UN owner's thread.

According to the post it doesn't sound like it.
post #63 of 1527
Yeah I'm 100% sure this is not a LED tv...
post #64 of 1527
I see what you mean - there is a bit of a discrepancy in the TV's description.
the 88UN is the only Sharp with 240hz (I believe) but it is not LED according to all the literature.
post #65 of 1527
The Sharp 88UN,
Is an LCD TV,
It's not LED,
Nor is it DLP.

It's a CCFL backlit LCD TV,
The HZ on it are 240,
And if you agree, let's go play Fallout 3.

As for the input switch delay, yes it does take 2-3 seconds sometimes to switch between PS3 and cable TV, or non HD channels to HD channels...but man...are you saying that's a legit "issue"?

That's like saying, "Man, I coulda been 2 minutes earlier to work this morning but I had to put on stupid clothes again today..."

Hey, I put on my 3D, 20X, UV, FLIR sunglasses earlier today to see if I had any radioactive thermal horizontal/vertical cross banding on my TV and hold crap, I do! There was also dust on my TV and that is not acceptable, which is why i'm returning it asap for a new TV. This time im gonna cover my TV in couch cover plastic before anything can come in contact with it, and have a high priest bless the TV to ward off will-o-wisps, which of course everybody knows are the main cause of clouding and poor black levels...
post #66 of 1527
Quote:
Originally Posted by chicomandell View Post

I checked the sharp site and there is very little info on this set. No PDF of the manual is available. I've seen conflicting specs on whether this has an ethernet port and/or a usb port. Not a deal breaker either way, just curious for those that have it already. Mine will be here on Friday

Not to be a pest, but it looks like my original question got passed by. So I'll ask again. Can someone with the tv let me know if the set has USB and Ethernet inputs? More important can you play audio/video direct from the USB and does the TV work with the Aquos Net feature? They delayed my shipment so I'm just curious to know in the mean time. Any info would be much appreciated.

Thanks

Chico
post #67 of 1527
LC-60E88UN ...... Getting back to the TV being LED.....I think I might be wrong. I will go back to Magnolia and take a picture, salesman told me it was a True LED and I did see that it said LED on the Price/ Quick Spec thing. If I can get a picture of it I will post. If I am wrong I will feel bamboozled by tom foolery. Hence, the set is SOOOOOO good that I will keep it for sure!
post #68 of 1527
Quote:
Originally Posted by chicomandell View Post

Not to be a pest, but it looks like my original question got passed by. So I'll ask again. Can someone with the tv let me know if the set has USB and Ethernet inputs? More important can you play audio/video direct from the USB and does the TV work with the Aquos Net feature? They delayed my shipment so I'm just curious to know in the mean time. Any info would be much appreciated.

Thanks

Chico

There is a usb port i assume since the firmware update instructions call for you to put the firmware on a usb drive and shows plugging in the usb drive to the tv.

I noticed where one poster had upgraded the firmware and the unit wouldn't power up the next day. Has anyone else upgraded the firmware? RESULTS PLEASE>>>>
post #69 of 1527
Quote:
Originally Posted by macbillybob View Post

There is a usb port i assume since the firmware update instructions call for you to put the firmware on a usb drive and shows plugging in the usb drive to the tv.

I noticed where one poster had upgraded the firmware and the unit wouldn't power up the next day. Has anyone else upgraded the firmware? RESULTS PLEASE>>>>


I updated my firmware the day after I got my TV, like over 3 weeks ago, and had 0 issues whatsoever.

Has there been another firmware update? I have only done 1 so far. 0 issues.
post #70 of 1527
Quote:
Originally Posted by veragoxx View Post

LC-60E88UN ...... Getting back to the TV being LED.....I think I might be wrong. I will go back to Magnolia and take a picture, salesman told me it was a True LED and I did see that it said LED on the Price/ Quick Spec thing. If I can get a picture of it I will post. If I am wrong I will feel bamboozled by tom foolery. Hence, the set is SOOOOOO good that I will keep it for sure!

This is NOT an LED TV!

This is a regular CCFL backlit LCD TV. There is nothing LED about it...
post #71 of 1527
Quote:
Originally Posted by mikegmi2 View Post

I updated my firmware the day after I got my TV, like over 3 weeks ago, and had 0 issues whatsoever.

Has there been another firmware update? I have only done 1 so far. 0 issues.

The one I downloaded was dated 5/20/2010.
post #72 of 1527
Quote:
Originally Posted by mikegmi2 View Post

This is NOT an LED TV!

This is a regular CCFL backlit LCD TV. There is nothing LED about it...

Agreed but be careful what you say. The "on indicator light" might be an LED.
post #73 of 1527
Here are the TV's connections...
LL
post #74 of 1527
Quote:
Originally Posted by macbillybob View Post

The one I downloaded was dated 5/20/2010.

Ah I must not have this one yet...i'll have to go get it...any noticable differences, what does this update fix/do?
post #75 of 1527
Quote:
Originally Posted by mikegmi2 View Post

Ah I must not have this one yet...i'll have to go get it...any noticable differences, what does this update fix/do?

Don't have my TV yet. Set for delivery on Tuesday.

Just trying to get prepared. Wall mount is here but I believe I will wait on the TV before mounting the mount. Get the height just right etc.

The firmware update says something about 1080i/720p improvement from HDMI inputs. Didn't really read closely.
post #76 of 1527
Quote:
Originally Posted by macbillybob View Post

Don't have my TV yet. Set for delivery on Tuesday.

Just trying to get prepared. Wall mount is here but I believe I will wait on the TV before mounting the mount. Get the height just right etc.

The firmware update says something about 1080i/720p improvement from HDMI inputs. Didn't really read closely.

Yea it looks like its just an update to the previous firmware update, as the previous one said the exact same thing:

"This Firmware Update improves performance on some digital and analog channels as well as improving performance of 1080i/720p signals input via HDMI.

This update includes all previous fixes and improvements.

Version U1004011
Date: 5/20/2010"
post #77 of 1527
Quote:
Originally Posted by chicomandell View Post

for the price ($1649 + Free Shipping at Dell) I couldn't pass it up. Hard to find a 60 inch LCD at all, much less one for a good price like that.

Quote:
Originally Posted by Dell View Post

We're sorry, the coupon code you have entered has already expired or has reached the maximum redemption limit

Bummer... that was a great deal.
post #78 of 1527
Quote:
Originally Posted by mikegmi2 View Post

Here are the TV's connections...

thanks for the info guys, the delivery company surprized me with the TV today so was able to see for myself. No ethernet, but that's ok, I stream netflix and all that through my PS3 anyways.
post #79 of 1527
Delivery co suprised me too. Mine is coming tomorrow morning. Early birthday present.

Got my mount and a new bluray player.

Glad I slipped in under the wire on the Dell deal.

Edit:
It is here, plugged in and working. Other that the color too high the picture looks fantastic. All I have done so far is hook up the cable box and bluray. Got plenty of work to do this weekend. Mounting, audio hookups etc.
post #80 of 1527
Missed the Dell deal, was going to order but had to leave and then never got back to it. Some other sites have it for the same price as Dell did after tax, but I'm not sure if they are reputable or not...
post #81 of 1527
Hey all, anyone out there have a PS3? When playing games on this tv it seems the backgrounds of some games are not very smooth. I've expirimented with all the motion and digital noise settings and they don't seem to make that much of a difference, and I have the AV Mode set to game (which disables film mode). Just curious what ur experiences are with this.


Also I've notice that when watching HDTV that when the camera pans across the it can seem a little stuttery (if that's a word), basically it's not smooth. If I turn off all of the enhancements, like film mode, digital noise, and motion it seems better but some channels it doesn't seem to make a difference.

Playing DVD and Bluray I don't see this issue so it may be something with the cable box? I've tried setting to 720p and 1080i, but doesn't make much of a difference. Just looking if anyone has experienced this?
post #82 of 1527
Hello all, had my 88 delivered today and have run into an issue with my ps3 playing games.
When playing certain games my tv looses sync and never regains it. in this case Naruto Ultimate ninja storm (cell shaded based fighter)(720p/480p on box)
the tv is great for the general menu, options screen,character and level select screens, but once it goes to load the actual level the tv goes black and never reconnects. So I have to physically shut off the ps3 by hand and reboot to get a lock.
I am set at dot for dot mode, hdmi.
Now I have not updated my firmware yet, so perhaps this will help resolve it. But I'm curious if anyone else is experiencing anything similar or can recreate it.
post #83 of 1527
Quote:
Originally Posted by chicomandell View Post

Hey all, anyone out there have a PS3? When playing games on this tv it seems the backgrounds of some games are not very smooth. I've expirimented with all the motion and digital noise settings and they don't seem to make that much of a difference, and I have the AV Mode set to game (which disables film mode). Just curious what ur experiences are with this.


Also I've notice that when watching HDTV that when the camera pans across the it can seem a little stuttery (if that's a word), basically it's not smooth. If I turn off all of the enhancements, like film mode, digital noise, and motion it seems better but some channels it doesn't seem to make a difference.

Playing DVD and Bluray I don't see this issue so it may be something with the cable box? I've tried setting to 720p and 1080i, but doesn't make much of a difference. Just looking if anyone has experienced this?

I updated my firmware and also turned off the active contrast and that seems to make a big difference. All is pretty much normal now.
post #84 of 1527
The Dell coupon for this set is back again for a few more days. It is good until 6/3.
post #85 of 1527
Quote:
Originally Posted by elDub13 View Post

The Dell coupon for this set is back again for a few more days. It is good until 6/3.

Have a link? I can't find anything but the original which says it's been used up.
post #86 of 1527
Quote:
Originally Posted by bpmurr View Post

Have a link? I can't find anything but the original which says it's been used up.

Use coupon code "L9VTKB5L3FGKCR" on the Dell website.
post #87 of 1527
Happy to say that this TV has lived up to everything I had hoped for, especially considering that deal through Dell. I will attach pics of it once I get settled in as I just moved. You will absolutely need a soundbar though as the speakers are terrible and project out of the back. I bought the JVC TH BA3 and it is awesome deal for that price. The TV is extremely light and easy to hang on wall. Two things though:
I have been playing around with settings to get the pic right, used Robs as well that he provided in the forum, but I still see some issues now and again where it looks a bit grainy at times. Anyone have settings they can share that are working well? I do not game, its just HD channels, movies, CNBC and sports. Overall it is very nice and looks great, just wanted to get some input.
Also I downloaded the update onto a USB drive and when plugging into the side USB port to update it tells me there is no software on the drive. Am I missing something there and does it make a nice picture diff?
Thanks..
post #88 of 1527
Quote:
Originally Posted by paperboy1974 View Post

Happy to say that this TV has lived up to everything I had hoped for, especially considering that deal through Dell. I will attach pics of it once I get settled in as I just moved. You will absolutely need a soundbar though as the speakers are terrible and project out of the back. I bought the JVC TH BA3 and it is awesome deal for that price. The TV is extremely light and easy to hang on wall. Two things though:
I have been playing around with settings to get the pic right, used Robs as well that he provided in the forum, but I still see some issues now and again where it looks a bit grainy at times. Anyone have settings they can share that are working well? I do not game, its just HD channels, movies, CNBC and sports. Overall it is very nice and looks great, just wanted to get some input.
Also I downloaded the update onto a USB drive and when plugging into the side USB port to update it tells me there is no software on the drive. Am I missing something there and does it make a nice picture diff?
Thanks..

your USB memory card should be formatted in FAT and you must extract the contents of the zip file directly to the root directory of the card to be recognized. do not place it in a folder or let it extract to a folder. If you've done all that and it still doesn't recognize it then try re-downloading and try again as you file may be corrupt.

Update on my issue: The firmware update resolved my sync issues with playstation games.
post #89 of 1527
Have had my LC-60E88UN two weeks now. No issues, it's preforming fine. I went ahead and got the Sharp BD-MPC41U Home Theater System to go with it. No issues as well, works great. I got the Linksys LIWET610N Wireless Ethernet bridge to hook it up for Netflix, also works great, just plugged it into my router then plugged it into the BD-MPC41U and it hooked right up. I needed two HDMI cables and one Optical audio cable to hook everything up. Total cost of everything including the cables was $2,296.14. Not bad for a 60" complete system. Now if it only keeps working for longer than my last TV (five years ). FYI it was a Sony, I'll never buy another Sony. I have another Sharp CRT TV that's still going after over ten years! Should have stuck with Sharp all along.
post #90 of 1527
Quote:
Originally Posted by jchas41 View Post

I wanted to provide an update on my situation with my problem set. Today I received my replacement E88 and I am happy to report it is 100 times better! Screen uniformity is way more even, with no trace of the horizontal lines my old set had. Blacks also look darker on this set, I'm sure as a result of less backlight bleeding.

Also, as an FYI, their is a new firmware update available for the E88. Released yesterday. Not sure what is does yet...

Looks like I may have the same issue that you were having with the white bands. Noticed it last night just before turning my set off in the dark. Since you already went trhough this process I have a few questions for you. Did u contact Sharp directly? How did they exchange the TV? Did u have to ship your TV back first and then they sent you a new one? Just want to see if it's worth the hassle. Any info you can provide would be greatly appreciated. Thanks

Chico
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Official Sharp Aquos LC-60E88UN Owner's Thread.