or Connect
AVS › AVS Forum › Display Devices › Plasma Flat Panel Displays › The Official LG xxPK950 Owner's Discussion Thread
New Posts  All Forums:Forum Nav:

The Official LG xxPK950 Owner's Discussion Thread - Page 3

post #61 of 1360
Quote:
Originally Posted by td2243 View Post

Zak, can you tell a difference in the other features as well, like the contrast ratio and did yours have the Magic Remote? Maybe they all do, I don't know. Thanks

According to the specs, the 550's contrast ratio is 3M:1 and the 950's 5M:1. As I understand it, there is no strict industry standard for how these numbers are derived so when trying to compare between sets, they have little meaning - though you'd think that numbers given by the same manufacturer would have some merit relatively speaking. PQs on each are decent and I don't recall 1 being that different from the other (except for the glare problem of the 550 and I, admittedly subjectively, seem to think the blacks on the 950 are a little deeper). I am about 1-2 weeks away from having mine professionally calibrated.

The magic remote is included with the 950 along with the standard remote. I have a Philips Pronto TSU9200, so I don't use either one of the LG remotes.

Otherwise, the 950 has internet (but doesn't include Pandora - which is something I use a lot) and has the wireless dongle included with the set. But since a lot of (mine included) BluRay players have WiFi internet (mine includes Pandora, NetFlix, VUDU, etc), I really don't use the internet capabilities of the TV.

The 2 things that stand above the 550 to me are the TruBlack filter and the form factor of the set's design. It was a lot of $$$ to upgrade but I just couldn't live with the 550 due to the glaring reflectivity of the screen.
post #62 of 1360
Thanks. I'll probably get this model, it is just a question of when. Hopefully within a month.
post #63 of 1360
Hello ,

I'm owner of the 60PK950. After testing the screen i Found Some Kind of clouding on light colors like this:

"can Not post Picture Links"

After updating to Software 4.11 from 4.08 i have 4 Little lighter stripes in the Middle of the screen.

In German HiFi Board some other people also have this issue. also with the pk990?

Some One here has this Problem of clouding - a problem that Plasma screens should not have.
post #64 of 1360
Quote:
Originally Posted by KLN-AM View Post

Hello ,

I'm owner of the 60PK950. After testing the screen i Found Some Kind of clouding on light colors like this:

"can Not post Picture Links"

After updating to Software 4.11 from 4.08 i have 4 Little lighter stripes in the Middle of the screen.

In German HiFi Board some other people also have this issue. also with the pk990?

Some One here has this Problem of clouding - a problem that Plasma screens should not have.

If it's the same thing I saw on my 550, it gets better over the first 100-200 hours. Very strange I agree.

Software update?! I wonder if that has the sharpening fix.
post #65 of 1360
How do you update? I've got version 04.02.01 on my 50PK950 and version 04.04.01 on my 60PK950. Both are connected to the internet but when I do the check if there is a software update available it never finds one.
post #66 of 1360
Quote:
Originally Posted by Daveys View Post

How do you update? I've got version 04.02.01 on my 50PK950 and version 04.04.01 on my 60PK950. Both are connected to the internet but when I do the check if there is a software update available it never finds one.

what Country did you choose? - I selected Germany and Ehen i push the netcast Button the screen checks for Updates and uptades when New software is available
post #67 of 1360
Quote:
Originally Posted by KLN-AM View Post

what Country did you choose? - I selected Germany and Ehen i push the netcast Button the screen checks for Updates and uptades when New software is available

I've choosen The Netherlands and when I check for an update I go to the menu and push the red button to go to the service menu. In the service menu the first option to choose is "Software update". When I go there I see the current version and I can choose to check for an update-version. When I choose to check it never finds an update.

When I choose German in the language menu I can update to version 04.11.00 but is this save to do and where can I find what the update means (what will change, etc)?
post #68 of 1360
Quote:
Originally Posted by Daveys View Post

I've choosen The Netherlands and when I check for an update I go to the menu and push the red button to go to the service menu. In the service menu the first option to choose is "Software update". When I go there I see the current version and I can choose to check for an update-version. When I choose to check it never finds an update.

When I choose German in the language menu I can update to version 04.11.00 but is this save to do and where can I find what the update means (what will change, etc)?

I don't know if there are any problems and never find a changelog for any versions.
post #69 of 1360
Quote:
Originally Posted by KLN-AM View Post

I don't know if there are any problems and never find a changelog for any versions.

I've just updated the 60" and everything works fine and I don't see any changes in the menu or whatever. When I juse the Netcast it does a software check. That's the only difference.
post #70 of 1360
Check to see if changing the input label to PC on a 1080/60p signal makes the screen blank for a second. Actually you'd have to look at text to see if that image processing is actually gone, as it may still blink to disable the CMS when labeling it as PC.
post #71 of 1360
Quote:
Originally Posted by shaddix View Post

Check to see if changing the input label to PC on a 1080/60p signal makes the screen blank for a second. Actually you'd have to look at text to see if that image processing is actually gone, as it may still blink to disable the CMS when labeling it as PC.

No, the PP bug is definitely not fixed!

Anyone knows the changes of firmwares?
post #72 of 1360
has anyone an explaination for the clouding?
post #73 of 1360
Quote:
Originally Posted by KLN-AM View Post

has anyone an explaination for the clouding?

I don't know, but it does clear up over the first couple hundred hours.
Used to be very visible on the whitewash but now I really have to hunt to see any uniformity issues.
post #74 of 1360
I live in the US and have a 60PK950 with FW revision 03.00.04. I have a wireless internet connection and if I do a search for newer revisions it doesn't find anything. LG's support page article on FW upgrades states to only use a wired connection for downloading new software (to help ensure there's no data corruption in the download - http://lgknowledgebase.com/kb/index....y&EntryID=6439). Does this set enforce this condition? Meaning - will it only enable downloads if you are using a wired connection? Has anyone successfully upgraded their FW over a wireless connection?

Thanks in advance.
post #75 of 1360
Quote:
Originally Posted by zakmichaels View Post

I live in the US and have a 60PK950 with FW revision 03.00.04. I have a wireless internet connection and if I do a search for newer revisions it doesn't find anything. LG's support page article on FW upgrades states to only use a wired connection for downloading new software (to help ensure there's no data corruption in the download - http://lgknowledgebase.com/kb/index....y&EntryID=6439). Does this set enforce this condition? Meaning - will it only enable downloads if you are using a wired connection? Has anyone successfully upgraded their FW over a wireless connection?

Thanks in advance.

Yes I did it. Country setting: Germany - that's all.
post #76 of 1360
Quote:
Originally Posted by KLN-AM View Post

Yes I did it. Country setting: Germany - that's all.

I wonder if there are any adverse effects of this (I'm not sure which country you reside in or which model TV you have) since Europe has a different broadcast standard than the US (PAL vs NTSC) and model number for this set (990 vs 950)?
post #77 of 1360
i have the 950 because of the threadname it should be clear :-)

for the 990 i have no experience. But I'm pretty shure that the 950 can PAL, Secam and NTSC.
post #78 of 1360
Thread Starter 
For US owners, software version 4.00.00 is available for download today. Updating as I type..
post #79 of 1360
Thread Starter 
Actually, downloaded and installed 4.00 and now downloading version 5.00.. strange
post #80 of 1360
Can you check to see if this new firmware has a fix for the undefeatable halos/ringing?
post #81 of 1360
Thread Starter 
Never had that issue
post #82 of 1360
Just ordered my pk950 and it should arrive on Saturday. I just hope I made the right decision by choosing the pk950 over the pk550.
post #83 of 1360
Thread Starter 
Final version was 5.00.00. Screen looks amazing.. blacks are definitely darker. Would be nice to see a change log. LG site is worthless.
post #84 of 1360
Quote:
Originally Posted by Yeoman View Post

Final version was 5.00.00. Screen looks amazing.. blacks are definitely darker. Would be nice to see a change log. LG site is worthless.

This remark makes me even more impatient. Can't wait to try out this bad boy
post #85 of 1360
Same here.

Nice to know LG is addressing issues, unlike some other brands.
post #86 of 1360
Pardon my ignorance, but what all is the firmware update on the 950 supposed to address. I'm sorry if that is listed somewhere and I missed it.
post #87 of 1360
Quote:
Originally Posted by td2243 View Post

Pardon my ignorance, but what all is the firmware update on the 950 supposed to address. I'm sorry if that is listed somewhere and I missed it.

undefeatable halos/ringing, possible isf grayscale functions not working properly. possible 24p issues.

I am very anxious to find out if these have been fixed. And I've been sending requests to LG every week or so asking for lower input lag lol.
post #88 of 1360
I don't know what halos and ringing are, so I don't think I want to know.
post #89 of 1360
Thread Starter 
Quote:
Originally Posted by shaddix View Post

undefeatable halos/ringing, possible isf grayscale functions not working properly. possible 24p issues.

I am very anxious to find out if these have been fixed. And I've been sending requests to LG every week or so asking for lower input lag lol.

Why don't you download and find out?
post #90 of 1360
Quote:
Originally Posted by Yeoman View Post

Why don't you download and find out?

I have NA PK550, but I spent like a month swapping TVs and the pk750/950 pp bug is what caused me to drive an extra three hours with tv loaded on the truck getting 11mpg
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Plasma Flat Panel Displays
AVS › AVS Forum › Display Devices › Plasma Flat Panel Displays › The Official LG xxPK950 Owner's Discussion Thread