or Connect
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Subwoofer lacking performance
New Posts  All Forums:Forum Nav:

Subwoofer lacking performance

post #1 of 6
Thread Starter 
I bought a BIC Acoustech PL-200 sub sometime back in January. I have been unimpressed with the performance and I can't seem to figure out the problem. When I bought the sub I read many reviews of which everyone seemed pleased with the power and range. So far, it seems to me like it is lacking in power, and I have tinkered with everything I can think to do. I have a Yamaha RX-V2700 receiver, and I read that alot of people seem to have trouble with the YPAO calibration on the sub. I tried making manual adjustments, I have moved the sub around the room, but it just doesn't seem like it has the power it should. Especially considering I upgraded from an inexpensive 8" sub, I just dont see or feel that much difference. I keep playing back scenes from movies that should shake the house, but it dissappoints. Maybe I am missing something in the set up, maybe this sub is a dud, or maybe it just isnt as powerful as I thought it would be. I am not an AV guru and I just don't have time to screw with it everyday so I was hoping someone may have some help.
post #2 of 6
1. Do you have a really big room?

2. Have you just tried forgetting what the calibration says and turning the gain/sub db on receiver and testing that way?

3. What is your gain currently at?

Theres something seriously wrong if its not kicking the crap out of an 8 inch inexpensive sub.
post #3 of 6
Quote:
Originally Posted by TTUMech View Post

....................so I was hoping someone may have some help.

Spend more money.
post #4 of 6
ok nevermind, i didnt read the part where you manually adjusted it. You ever taken the grill off and watched to see if its moving pretty good? I would contact bic, either way... especially if its soundling like an 8 inch cheap sub
post #5 of 6
Have you checked that your amps bass managment is set on "small"?
post #6 of 6
Make sure it's setup correctly and is level matched with your other speakers. If all else fails, buy a bigger sub
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › Audio › Subwoofers, Bass, and Transducers › Subwoofer lacking performance