or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Onkyo TX-SR606 and Xbox 360 HDMI issues
New Posts  All Forums:Forum Nav:

Onkyo TX-SR606 and Xbox 360 HDMI issues

post #1 of 4
Thread Starter 
Hi guys. I've been trying to figure this one out for ages, but to no avail.

I have an Onkyo TX-SR606. I have a PS3 and Xbox 360 connected via HDMI, a digital optical from a mac mini input and then HDMI to my TV.

The only source I have problems with is the Xbox 360. After about 2-5 minutes of having the console on, the receiver will start flashing the HDMI light and the TV will flicker on and off with signal.

I've switched HDMI ports, changed HDMI cables, checked settings on both the Onkyo and the Xbox, but still getting it almost every time I boot it up.

It's hard to explain really well what happens, so I recorded it and threw it up on Youtube. If you just want to see it in action, skip to 2:30.



Any ideas how to stop this?
post #2 of 4
Reading your tests, it seems that the issue is with the Xbox 360. One more trouble shooting step is to try another Xbox 360. Any friends have one with HDMI they could bring over?

Also, you might get Onkyo specific answers in the 606 owners thread.
post #3 of 4
Thread Starter 
Ah yes, one additional point. When I plug the 360 directly into the TV, I don't get the issue. My initial thought is that it's the HDCP handshake between the receiver and the xbox, but it doesn't make sense as to when it happens.
post #4 of 4
It's the Onkyo 606's hdmi board starting to act up. I had exactly the same problem: it started with my PS3 then jumped to the Xbox 360. Problems disapper when either one is connected to the TV directly. I had one month left in my warranty, so I took for service. After replacing the board, everything's working fine now.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › Onkyo TX-SR606 and Xbox 360 HDMI issues