or Connect
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Mitsubishi LT-40133
New Posts  All Forums:Forum Nav:

Mitsubishi LT-40133

post #1 of 6
Thread Starter 
Hi
I have a Mitsubishi LT-40133, I just started getting a bunch of colored lines on the right side of the TV! the strip of lines are about 4" wide here is a picture. The lines show up with or without any inputs



Any idea what could be wrong?
Is this TV worth fixing??
post #2 of 6
Unless it is under warr. I would get a new TV. You have a bad panel
post #3 of 6
mine is doing the same thing....goes away after it warms up....plan on getting a vizio soon...I'm done with mitsubishi....this is the second TV with them and the last
post #4 of 6
This model and all Mitsubishi LCDs have been discontinued.
post #5 of 6
Quote:
Originally Posted by silvermaxd View Post

mine is doing the same thing....goes away after it warms up....plan on getting a vizio soon...I'm done with mitsubishi....this is the second TV with them and the last

Before you get a Vizio, read some of the posts on here about them. It seems they've been in some hot water lately for offering no support and saying that their TVs are unrepairable.
post #6 of 6
I have now got the exact same problem with the same TV. Did you get it fixed? If so what did it cost and what was actually wrong with it? Any help would be appreciated.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: LCD Flat Panel Displays
AVS › AVS Forum › Display Devices › LCD Flat Panel Displays › Mitsubishi LT-40133