or Connect
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › The "Official" TX-NR708 Owners Thread
New Posts  All Forums:Forum Nav:

The "Official" TX-NR708 Owners Thread - Page 45

post #1321 of 1620
I must concur, there's absolutely nothing wrong with my 708! It has preformed as hoped and anticipated. Been playing with it about 3 months now, very pleased by what I hear. I haven't tried internet radio or streaming my music from my PC yet, but I did connect it to my network and had no problem checking for an update (had the current one). What really made me pull the trigger is something not mentioned much at all on this thread the ability to compare rears, heights and wides. I have enough speakers to set up all the 11.2 lay out, and I have spent a bit of time doing A/B/C comparisons Haven't done as much critical listening and comparing heights as with the rears and wides though. Most of the critical listening has been strictly audio (but I have two (5.1) concert DVD's one being Pulse by Pink Floyd - Awesome!). I got to admit, I do really enjoy the wides tremendously! They definitely allow a more complete stage presence from Bach to ZZ Top! The better of those 6 speakers are the rears since there is more and more 7.1 movie soundtracks becoming available. I will get around putting the heights thru a more strenuous work out/comparison, I just got to figure out a few more DVDs/Blu rays that will help in that phase of my testing/playing/tweaking (any one have some suggestions?) I will also get to the streaming and the internet radio, but I'm not in a terrific hurry, I'm just having all sorts of fun. This is a good product, you won't be terribly disappointed if you get one (on the presumption you don't get a bad one, and every manufacturer has some slip past QC)
post #1322 of 1620
Anyone know if there's a way to get song info displayed on the receiver's display? Slacker and Pandora both provide Song, Artist, Album and time played info on the TV. The receiver displays iRadio (source name) and time played. I'd prefer to see Artist and Song info if that's possible.

I tried "Display" but it took me up a level to the internet radio presets menu.
post #1323 of 1620
Quote:
Originally Posted by ElHefe View Post
I dug my Harmony 880 out of a box (just moved) and it wouldn't work either.
Well it looks like my 708 is really, really dead.

Last night it would randomly switch back to the CBL/SAT input by itself, and this morning the entire front panel became unresponsive (even the power button didnt work). It also refused to switch out of CBL/SAT (switching immediately back from whatever I put it in with the iPhone app).

Looks like it's service center time, which in my experience never ends well.
post #1324 of 1620
What is the difference between the 708 and this one? I only found Sirius.12v trigger for zone 2 and the RS-232 connection. The RC270 is about a $100 less than the 708.
post #1325 of 1620
Quote:
Originally Posted by ElHefe View Post

Well it looks like my 708 is really, really dead.

Last night it would randomly switch back to the CBL/SAT input by itself, and this morning the entire front panel became unresponsive (even the power button didnt work). It also refused to switch out of CBL/SAT (switching immediately back from whatever I put it in with the iPhone app).

Looks like it's service center time, which in my experience never ends well.


How long did you own the 270? I really want to get a new avr, especially an Onkyo. Although after reading through these forums it seems they don't have such a good reliability record. It seems like Yamaha has the best from what I have read on here. I have only owned regular Pioneer, each over 6 years, and never had a problem with either. I am afraid to take a $500 chance.
post #1326 of 1620
Quote:
Originally Posted by Dcmkx2000 View Post

How long did you own the 270? I really want to get a new avr, especially an Onkyo. Although after reading through these forums it seems they don't have such a good reliability record. It seems like Yamaha has the best from what I have read on here. I have only owned regular Pioneer, each over 6 years, and never had a problem with either. I am afraid to take a $500 chance.

This unit is about 3 months old (got it for Christmas).

FWIW, I've been a loyal Onkyo customer for over a decade, and owned multiple avrs from them. This is the first that has ever had a problem of any sort. I'm hoping that I just got a lemon and that it's not indicative of a fall-off in manufacturing quality.

I'm getting it to my local service center tomorrow and hopefully it's just an issue with the front panel. My local service center has terrible reviews on Google though so hopefully it all works out! If not I'm calling Onkyo and demanding a replacement/refund.
post #1327 of 1620
Quote:
Originally Posted by TrawlerJoe View Post

Personally, I'd start with the receiver, and try to budget in the speakers soon after. In the meantime, you'll get the new audio formats and new features.

Who knows, maybe you'll be happy with the old speakers. The Audyssey equalization will probably help quite a bit.

Thanks a lot. This is the current system I have:
http://www.us.onkyo.com/model.cfm?m=...ss=Systems&p=s

It looks like the speakers are 8OHM which is good as I shouldn't have problems upgrading just the receiver for now. Out of curiosity, how much better do you think the sound will be just upgrading the speakers and getting DTS-HD and True HD?
post #1328 of 1620
Quote:
Originally Posted by rgathright View Post

What is the difference between the 708 and this one? I only found Sirius.12v trigger for zone 2 and the RS-232 connection. The RC270 is about a $100 less than the 708.

There is also one less hdmi connection. The 270 is 100w per channel & the 708 is 110w per channel. Both use the same power supply so, I would assume that figure is useless.
post #1329 of 1620
Quote:
Originally Posted by Dcmkx2000 View Post


How long did you own the 270? I really want to get a new avr, especially an Onkyo. Although after reading through these forums it seems they don't have such a good reliability record. It seems like Yamaha has the best from what I have read on here. I have only owned regular Pioneer, each over 6 years, and never had a problem with either. I am afraid to take a $500 chance.

Take these forums with a grain of salt. People only post issues here so of course that is mostly what you see. Hundreds of us are using these without issues so we have nothing to post. My pioneer elite 84txsi is in the shop. I never had one break in my lifetime. This is the first.
post #1330 of 1620
if streaming from wm player, will it display album art?
post #1331 of 1620
Quote:
Originally Posted by Dcmkx2000 View Post
if streaming from wm player, will it display album art?
It does on mine. music that is.
Biggz
post #1332 of 1620
Is there anyway to get Zone2 commands to display on the receiver's front panel? or through OSD if the TV happens to be on?
post #1333 of 1620
Quote:
Originally Posted by ElHefe View Post

Well it looks like my 708 is really, really dead.

Last night it would randomly switch back to the CBL/SAT input by itself, and this morning the entire front panel became unresponsive (even the power button didnt work). It also refused to switch out of CBL/SAT (switching immediately back from whatever I put it in with the iPhone app).

Looks like it's service center time, which in my experience never ends well.

Wondering if you're problem has been resolved. Just last night my 708 developed a remote problem. I changed batteries, verified remote ID was same on receiver and remote, reset remote, hard reset of receiver. After the hard reset, remote would work but only within a 1-2 foot range of the receiver. I'm beyond my 30 days to exchange it. I have already done that once, as I developed the CBL/SAT and unresponsive front panel you describe above, on my first unit, within a couple of days of setting it up.
post #1334 of 1620
I'm having a strange problem that I haven't seen reported elsewhere. I listen to KLOS (Mark & Brian!) via vTuner every morning. On a daily basis, it reverts back from KLOS to another preset station (always the same one). For about a month, I couldn't pull in KLOS at all - after selecting its preset, after attempting to connect, it would just jump back to the same station it reverts to now (which is apparently my "default" preset station). So, I'm suspecting the problem may be on KLOS's side somehow. Has anyone else noticed anything similar? I'm using the latest firmware, and have zero issues/complaints otherwise (other than the well-documented crazy scaling of the volume control).

BTW, anyone with an iPad should download O-Remote. It's absolutely incredible, though considerably less so on the crowded iPhone screen than on the iPad. For the iPhone, Onkotron is a great solution.
post #1335 of 1620
Hi guyz, I just bought my first AV receiver the TX NR708 and absolutely love it so far. Its been 1 week and is working awesome. I do however have one small issue. I have 3 laptops one XP, one Windows 7 and the other Vista and was able to stream music from all except XP. I have tried everything but cannot see the XP in the available server list.

I have windows media player 11 and have enabled sharing from the library command and made sure i gave access to the 708. I also turned off Firewall but for some reason no matter what i do cannot get the 708 to recognize my XP.

Any help would be gladly appreciated.

Also how do i upgrade my AVR over ethernet?
post #1336 of 1620
I didnt need to do any firmware update. When I went to the firmware update option it said i already ave the latest firmware.
post #1337 of 1620
Quote:
Originally Posted by schalekar View Post

Also how do i upgrade my AVR over ethernet?

You must have internet access, not just network access to your server. P. 66 in the manual:

Receiver > Setup on the remote
Hardware Setup > Firmware Update > Via NET
post #1338 of 1620
Quote:
Originally Posted by dmlynn View Post

Wondering if you're problem has been resolved. Just last night my 708 developed a remote problem. I changed batteries, verified remote ID was same on receiver and remote, reset remote, hard reset of receiver. After the hard reset, remote would work but only within a 1-2 foot range of the receiver. I'm beyond my 30 days to exchange it. I have already done that once, as I developed the CBL/SAT and unresponsive front panel you describe above, on my first unit, within a couple of days of setting it up.

Sounds like an IR conflict with another device. Did you ever investigate that option?
post #1339 of 1620
Quote:
Originally Posted by dmlynn View Post
Wondering if you're problem has been resolved. Just last night my 708 developed a remote problem. I changed batteries, verified remote ID was same on receiver and remote, reset remote, hard reset of receiver. After the hard reset, remote would work but only within a 1-2 foot range of the receiver. I'm beyond my 30 days to exchange it. I have already done that once, as I developed the CBL/SAT and unresponsive front panel you describe above, on my first unit, within a couple of days of setting it up.
It's still at the service shop. I should know something this Friday. I'll be sure to post an update.

Weird that you've had (are having?) the same issue. Maybe some got out of the factory with bad front panels?

Anyway, the warranty is good for 2 years. You just need to find a local authorized service center nearby. Mine asked me to show my reciept to prove my date of purchase.
post #1340 of 1620
So today my 708 decided to stop responding to all remote controls, nothing works via remote. I tried using my Harmony One (re-updated to be sure) and the regular remote - nothing. I also tested both remotes on a different Onkyo receiver (606) in another room and confirmed that they are both working normally.

???
post #1341 of 1620
Quote:
Originally Posted by litew8 View Post

Sounds like an IR conflict with another device. Did you ever investigate that option?

Not sure what the conflict would be or how to go about investigating.
I use a Monster AVL-300 for control of everything else in my system, which are all working fine (no other Onkyo products). When I hold the Monster within a couple of feet of the 708 receiver it will control it, just like the 708's remote. But further than that and I get no response. After resetting the remote to factory, it will intermittently control the 708 from a distance for a few minutes, or not. But eventually the distance seems to reduce to a foot or 2 at best. Incredibly frustrating!
post #1342 of 1620
Quote:
Originally Posted by Osirus23 View Post

So today my 708 decided to stop responding to all remote controls, nothing works via remote. I tried using my Harmony One (re-updated to be sure) and the regular remote - nothing. I also tested both remotes on a different Onkyo receiver (606) in another room and confirmed that they are both working normally.

???

Sounds like you're having the same problem I'm having. Did you purchase your 708 recently?
post #1343 of 1620
Quote:
Originally Posted by ElHefe View Post

Quote:
Originally Posted by dmlynn View Post

Wondering if you're problem has been resolved. Just last night my 708 developed a remote problem. I changed batteries, verified remote ID was same on receiver and remote, reset remote, hard reset of receiver. After the hard reset, remote would work but only within a 1-2 foot range of the receiver. I'm beyond my 30 days to exchange it. I have already done that once, as I developed the CBL/SAT and unresponsive front panel you describe above, on my first unit, within a couple of days of setting it up.

It's still at the service shop. I should know something this Friday. I'll be sure to post an update.

Weird that you've had (are having?) the same issue. Maybe some got out of the factory with bad front panels?

Anyway, the warranty is good for 2 years. You just need to find a local authorized service center nearby. Mine asked me to show my reciept to prove my date of purchase.

Just a quick update. Spoke with the service shop and they've got Onkyo's engineering department involved. I'm not sure if that's a standard practice but it certainly sounds like a pretty high level of escalation.
post #1344 of 1620
Quote:
Originally Posted by ElHefe View Post


It's still at the service shop. I should know something this Friday. I'll be sure to post an update.

Weird that you've had (are having?) the same issue. Maybe some got out of the factory with bad front panels?

Anyway, the warranty is good for 2 years. You just need to find a local authorized service center nearby. Mine asked me to show my reciept to prove my date of purchase.

For a 708? Are they high? That model has been on the market for a bit less than a year. How could it possibly be out of warranty?
post #1345 of 1620
Quote:
Originally Posted by rworne View Post

For a 708? Are they high? That model has been on the market for a bit less than a year. How could it possibly be out of warranty?

Yeah, that's what I said. Guy at the shop said he needed it because he needed a purchase date for the warranty paperwork.
post #1346 of 1620
Quote:
Originally Posted by ElHefe View Post

Sounds like you're having the same problem I'm having. Did you purchase your 708 recently?

Got it in December.

I messed around in the settings last night, cycled through a few remote options - in the end every setting was left in the same place it was to begin with, but the remote was magically working again.
post #1347 of 1620
Quote:
Originally Posted by ElHefe View Post


Yeah, that's what I said. Guy at the shop said he needed it because he needed a purchase date for the warranty paperwork.

They should be told to use the manufacturing date. Quite a few companies embed that in the serial number or some other code on the back.
post #1348 of 1620
Hi all, just bought a NR708.

I recently purchased Energy CF-70 and at home I still have a set of Energy Classic 5 and Klipsch Quintet II, I think I will connect them to make it 7.1 system, which one is better? Energy or Klipsch ? thanks !
post #1349 of 1620
Quote:
Originally Posted by oxyi View Post

Hi all, just bought a NR708.

I recently purchased Energy CF-70 and at home I still have a set of Energy Classic 5 and Klipsch Quintet II, I think I will connect them to make it 7.1 system, which one is better? Energy or Klipsch ? thanks !

Energy IMO, but spec wise the Klipsch beat those speakers by 15hz.


Energy Sat: 115Hz-20KHz 89db. 100W total
Klipsch Sat: 100Hz-20kHz 90db. 100W total
post #1350 of 1620
Hey Guyz... Wondering if anyone could help me out with my networking problem. Everything else seems to be working fine except my Windows XP laptop is not found by the Onkyo. I am pretty sure i did everything correct but stilll its not finding my XP. I have Windows Media player 11 and haev enabled sharing and given permissions to Onkyo on my XP m/c to play music and also tried turning off firewall.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Receivers, Amps, and Processors
AVS › AVS Forum › Audio › Receivers, Amps, and Processors › The "Official" TX-NR708 Owners Thread