or Connect
AVS › AVS Forum › Display Devices › Rear Projection Units › My Sony KDF-70XBR950 power light turns green when powering up and blinks 6 times
New Posts  All Forums:Forum Nav:

My Sony KDF-70XBR950 power light turns green when powering up and blinks 6 times

post #1 of 5
Thread Starter 
My Sony KDF-70XBR950 power light turns green when powering up and blinks 6 times. Everything is still working fine but have noticed a strong smell of something being burned inside the TV. Thought the lamp was overheating but when checking the lamp it did not show any sign of heating damage. Opened up the rear cover as per instructions I have found on this site but could not see anything that was burned. However the fan on the back of the lamp seems to bring out the smell from inside somewhere.
As I at the moment live in Brazil and is going to the US next week I have ordered a new lamp and also a new G1 board A1302365A as I saw some one with a similar problem thought this was the problem.
Question: Does the lamp overheat at the end of life? My lamp is original and has some 6500h, and picture is still very good. Or is it a fan problem causing the overheating. Smell starts after just 5 minutes of use so the TV is not being used any more.
Appreciate any help that could help me buy the faulty parts when being back in the US.
post #2 of 5
It is either the G1 (power supply) or the thermal fuse is open. The thermal fuse is located near the lamp and has gray and black wires going to a black 2 pin connector above the optic block. You can check it with an Ohm meter to see if it is open. If it is open you need to determine WHY! Probably the fan on top of the optic block is clogged and needs to be replaced.
post #3 of 5
Thread Starter 
Quote:
Originally Posted by divesrq View Post

It is either the G1 (power supply) or the thermal fuse is open. The thermal fuse is located near the lamp and has gray and black wires going to a black 2 pin connector above the optic block. You can check it with an Ohm meter to see if it is open. If it is open you need to determine WHY! Probably the fan on top of the optic block is clogged and needs to be replaced.

Thanks for indication, got me a new G1 (power supply) but before installing, I would like to check the thermal fuse you mentioned to make sure it won't fail again because of a faulty fan unit, however I can't find the thermal fuse. Can you give some hint where to look?
post #4 of 5
Hello Folke,

Can u pls tell me where did you buy your part
post #5 of 5
I, as well, have been dealing with a dead, 6 red blinks kdf-70xbr950 issue since May of this year. I have replaced the G1 board twice (giving the benefit of a doubt that the 1st G1 was dead)...still the same 6 blinks. I also replaced the lamp ballast...still no-go. I keep hearing about this thermal fuse that is supposedly in my TV, but I cannot find it! I believe that it's there, but I just don't know what it looks like. Where is it EXACTLY?? Pics maybe of you have them???

I've taken the whole things apart practically. Optical block, q-box assembly, door sensor, blah blah...everything practically. Looked and researched it all...I think. I still cannot get the TV to fire up. No picture, no sound, just those damned 6 blinks.

I want to upgrade the thermal fuse(not sure how to upgrade a fuse, but whatever, maybe the answer will be obvious when I can fnd somewhere to buy one). The other thing is this...if 6 blinks is a +BOVP to the G1 board from the C2 board, maybe I should try replacing the C2 board????

Items to buy:
1st: Thermal Fuse
2nd: C2 board
3rd: Sledge hammer

Any ideas??

Also, I have tech's service manual for the KDF-70XBR950/60XBR950 in PDF format. I uploaded it to mediafire. Here is the link: www DOT mediafire DOT com/?6vnwruzdczn8272
...hope it helps someone...I hope someone can give me some meaningful and effective direction on how to solve my problem.

Thanks!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Rear Projection Units
AVS › AVS Forum › Display Devices › Rear Projection Units › My Sony KDF-70XBR950 power light turns green when powering up and blinks 6 times