or Connect
AVS › AVS Forum › HDTV › HDTV Technical › Coupon Eligible Converter Box (CECB) › Is my box (Zenith DTT 910) dead?
New Posts  All Forums:Forum Nav:

Is my box (Zenith DTT 910) dead?

post #1 of 3
Thread Starter 
I just got my zenith dtt901 out of storage, hooked it up to the tv, tried both RF and RCA connections, am sure I did everything right (I have dtt900 that I am currently using, so just copied the connections). The box turns on but on the tv I get only snow or the blue screen (depending on whether I set to video or channel 3 or 4). I know the box is reacting to the remote cause the blue light blinks when I change channels on the remote. But it seems that no antenna signal is being passed to the tv. I had used the box for only a few weeks over a year ago and it was fine. Is there something I might be missing? I can't get a menu to show up on the tv at all, so can't change any settings in the box. Why would it just die when not being used? Thanks for any ideas.
post #2 of 3
Sorry for the late reply.

If the box worked before and isn't working now, it's either broken or not connected right.

Go to: http://www.lg.com/us/support/index.jsp

Enter DTT901 and take a look at the owners manual.
post #3 of 3
Thread Starter 
Quote:
Originally Posted by Ken H View Post

Sorry for the late reply.

If the box worked before and isn't working now, it's either broken or not connected right.

Go to: http://www.lg.com/us/support/index.jsp

Enter DTT901 and take a look at the owners manual.

Thank you, I guess it's broken (I have the original manual and am sure I was connecting it right), but that's very disappointing considering I had barely used it. I was going to sell it on Ebay--that's why I got it back out and tried it--had been keeping it in reserve in case my DTT900 quit, but that one is working fine.
New Posts  All Forums:Forum Nav:
  Return Home
AVS › AVS Forum › HDTV › HDTV Technical › Coupon Eligible Converter Box (CECB) › Is my box (Zenith DTT 910) dead?