or Connect
AVS › AVS Forum › Video Components › Home Theater Computers › XBMC Media Center : Setup Guide, Knowlege Base & Support
New Posts  All Forums:Forum Nav:

XBMC Media Center : Setup Guide, Knowlege Base & Support - Page 5

post #121 of 3139
Yeah, I was hoping that it would support bitstreaming. I wasn't expecting much since they said that this wouldn't even be implemented in Dharma. I thought that maybe they had secretly stuck this feature in at the last minute in the final build ;-).
post #122 of 3139
Maybe this line in the changelog is what is causing the anticipation? No mention of HD Audio, though...

Quote:


* Added raw bitstream pass-through support for MP1, MP2, MP3, and AAC encoded audio tracks
post #123 of 3139
Quote:
Originally Posted by skool View Post

Yeah, I was hoping that it would support bitstreaming. I wasn't expecting much since they said that this wouldn't even be implemented in Dharma. I thought that maybe they had secretly stuck this feature in at the last minute in the final build ;-).

They are currently reworking the audio part of XBMC with a new audio core called AudioEngine, this new audio core will bring HD Audio bitstreaming to XBMC once it's been integrated. I believe they are targeting inclusion of AuioEngine into the next official release which will be Eden, although it may pop up in the SVN trunk before that.

Progress on AudioEngine can be followed at http://forum.xbmc.org/showthread.php?t=78289
post #124 of 3139
Sorry for the noobish question, but from what I am reading, XBMC will not bitstream HD audio ? Correct ? Regardless of connection (HDMI) ?
post #125 of 3139
Quote:
Originally Posted by jimjimmyjones85 View Post

Sorry for the noobish question, but from what I am reading, XBMC will not bitstream HD audio ? Correct ? Regardless of connection (HDMI) ?

This question is answered in the post directly above yours.
post #126 of 3139
xbmc noob here, i just got Dharma 2 days ago and have been messing around with it but theres still a few things i dont understand. most of my movies are vob files, and i cant seem to get xbmc to see them. i see some instructions in the xbmc wiki, but theyre for the previous build, and they say to click options that just arent there in dharma. i converted a few to mkv using the highest quality settings in handbrake, and im not impressed, the quality of the original vob played in vlc is much higher. how can i get xbmc to see my vob's?
post #127 of 3139
Does anyone know a way to get Rhapsody offline file playback within XBMC? It works within 7mc and MB (for obvious reasons), but for the life of me I cannot get it to playback within XBMC. I am certain it has to do with the file player being used but winamp plays the offline files and of course WMP does but have yet to figure out a solution.

I have about 8gb of music downloaded for offline playback that holds most of the music my wife and I listen to but what keeps me from XBMC is having to switch back to 7mc for playback.
post #128 of 3139
Quote:
Originally Posted by omgitsoop View Post

xbmc noob here, i just got Dharma 2 days ago and have been messing around with it but theres still a few things i dont understand. most of my movies are vob files, and i cant seem to get xbmc to see them. i see some instructions in the xbmc wiki, but theyre for the previous build, and they say to click options that just arent there in dharma. i converted a few to mkv using the highest quality settings in handbrake, and im not impressed, the quality of the original vob played in vlc is much higher. how can i get xbmc to see my vob's?

What instructions are you referring to - have you set the content on your media and scraped them to the library? If not have a look here http://forum.xbmc.org/showthread.php?t=38964. or alternatively the first page of this thread.

Make sure your rips are in strict DVD Format, with both AUDIO_TS and VIDEO_TS (vob, ifo etc files here) folders within the movie folder.
post #129 of 3139
Quote:
Originally Posted by steelman1991 View Post

What instructions are you referring to - have you set the content on your media and scraped them to the library? If not have a look here http://forum.xbmc.org/showthread.php?t=38964. or alternatively the first page of this thread.

Make sure your rips are in strict DVD Format, with both AUDIO_TS and VIDEO_TS (vob, ifo etc files here) folders within the movie folder.

I see, It now sees them after adding an AUDIO_TS file to all the folders, although for whatever reason it shows each movie coming up twice, one playable and one not, until i moved the ifo files to the AUDIO_TS folder, which seems weird. Also, some of my movies are broken up into 1gb increments because that was the default setting in dvd decrypter, and my xbmc doesnt seem to get along with that at all, it shows up as a playable movie but it doesnt want to actually play it. Thoughts?
post #130 of 3139
Is there anyway to make XBMC bitstream hd audio?
post #131 of 3139
Quote:
Originally Posted by echoesian View Post

Is there anyway to make XBMC bitstream hd audio?

Sigh..... no one wants to read the posts here. If you want to bitstream from XBMC currently you either need to use the DSPLayer build or launch MPC HC from XBMC:

MPC HC:
http://www.mediasmartserver.net/2010...layer-in-xbmc/

DSPlayer:
http://www.mediasmartserver.net/2010...sing-dsplayer/
post #132 of 3139
Quote:
Originally Posted by omgitsoop View Post

I see, It now sees them after adding an AUDIO_TS file to all the folders, although for whatever reason it shows each movie coming up twice, one playable and one not, until i moved the ifo files to the AUDIO_TS folder, which seems weird. Also, some of my movies are broken up into 1gb increments because that was the default setting in dvd decrypter, and my xbmc doesnt seem to get along with that at all, it shows up as a playable movie but it doesnt want to actually play it. Thoughts?

Firstly removing the ifo file from the VIDEO_TS to AUDIO_TS breaks the DVD format protocol and therefore won't play. You will have to move them back to even hope to play the files - the AUDIO_TS should always be empty.

1GB segements is normal - no need to do anything. To get rid of the double entries run a Clean Library scan - System\\Video\\Library\\Clean Library.
post #133 of 3139
Quote:
Originally Posted by steelman1991 View Post

What instructions are you referring to - have you set the content on your media and scraped them to the library? If not have a look here http://forum.xbmc.org/showthread.php?t=38964. or alternatively the first page of this thread.

Make sure your rips are in strict DVD Format, with both AUDIO_TS and VIDEO_TS (vob, ifo etc files here) folders within the movie folder.

Mine seem ok, but my question is more along the lines of the term, scraped.

What does it do and how is it enabled or done ?

Quote:
Originally Posted by dbone1026 View Post

Sigh..... no one wants to read the posts here. If you want to bitstream from XBMC currently you either need to use the DSPLayer build or launch MPC HC from XBMC:

MPC HC:
http://www.mediasmartserver.net/2010...layer-in-xbmc/

DSPlayer:
http://www.mediasmartserver.net/2010...sing-dsplayer/

I think I will just wait for the experts to incorporate into the product.
post #134 of 3139
Quote:
Originally Posted by jimjimmyjones85 View Post



I think I will just wait for the experts to incorporate into the product.

I'm going to try to set mine up today, if it works I will be more than happy to help you set yours up. I got my first taste of bitstreamed audio the other night in Total Media Theater (was a great moment when the blue light showed up on my Denon display!). I'm hooked now, but I want it integrated into XBMC!
post #135 of 3139
Good news and bad news

Bad news : One of the developers working on the DS Player build is in a exam session so we may have to wait 1-2 weeks for a new DS Player build.

Good news : We won`t have to wait that long since liquidskin76 is going to compile a build from the recent code (Dharma based). He`s not one of the devs working on the DS Player build so it won`t be official but it will be a good temporary replacement for those of us who want HD audio and the EVR renderer.

Good news 2 : Aeon MQ 2.6 should be released before Christmas


Pics





post #136 of 3139
Quote:
Originally Posted by airduct View Post

thanks for the greeneyez for the xbmc writeup...just a few quickquestions:

1) i am still on winxp pro... is your win 7 link a free copy? do i need a serial or activation code after i install it?

2) does media center master work for winxp?

3) do i need win7 to set this up? or can i stick with winxp? thanks... i'll continue reading the thread

4) fyi... just got the wd hd tv live plus...but i think i am going to install/setup a xbmc htpc

1) No, it`s an official download from the MS Store, you still need a key, It`s just the ISO image.

2) Yes, as far as i know.

3) You can set it up on XP if you want, but you loose DXVA (hardware acceleration) which only works on Windows 7

3) XBMC eats a WD Live for breakfast
post #137 of 3139
Quote:
Originally Posted by jimjimmyjones85 View Post

Mine seem ok, but my question is more along the lines of the term, scraped.

What does it do and how is it enabled or done ?



I think I will just wait for the experts to incorporate into the product.

Based on the instructions posted it's really not that terribly hard. Honestly I would give it a shot because in the end it will help you understand the system better and make you more comfortable with trying experimental things.
post #138 of 3139
Quote:
Originally Posted by jimjimmyjones85 View Post

Mine seem ok, but my question is more along the lines of the term, scraped.

What does it do and how is it enabled or done ?



I think I will just wait for the experts to incorporate into the product.

When you added a folder to the library (add source), did you tell it what type of content it is (Movies/TV Shows/Music Videos)? That`s what Frank meant by "scrapped" . It asks for it when you and a folder with the Add soruce button.

Scrappers are a piece of software that downloads information (posters/backgrounds/movie information like synopsis etc.) from places like TheTVDB.

XBMC has integrated scrappers, or you can use Media Center Master to save them locally. Either way, you still have to tell XBMC what type of content that folder contanins.
post #139 of 3139
Quote:
Originally Posted by steelman1991 View Post

Firstly removing the ifo file from the VIDEO_TS to AUDIO_TS breaks the DVD format protocol and therefore won't play. You will have to move them back to even hope to play the files - the AUDIO_TS should always be empty.

1GB segements is normal - no need to do anything. To get rid of the double entries run a Clean Library scan - System\\Video\\Library\\Clean Library.


All the movies that I moved the ifo files to audio_ts play fine, and it refreshes every time I turn on, and all the files with everything in the video_ts come back as doubles, and all the files with separated ifo and vob in audio_ts and video_ts respectively, don't double up and play fine. Do I have funky setting in the scraper that's causing that? But yes, im playing a movie with the ifo in the audio_ts file right now and its playing perfect. Im guessing that's not normal?
post #140 of 3139
Greeneyz just wanted to see if you saw my post before about setting up movie collections.
post #141 of 3139
I wonder if anyone has seen this problem. I record television programs using a Hauppage 1600 but when I play them back they are clipped vertically by about 20 percent. If I move away from the program to another section of Media center when the small image is displayed I get no clipping.
post #142 of 3139
As much as I admire XBMC's visual presentation, there is one annoyance I'm having which maybe someone has some insight on.

I'm using really high-res versions of movie posters for my skin, but XBMC seems to compress them really badly. While for many views this is relatively minor, since the posters are displayed relatively small anyway, if I'm using a skin with an Info view where you can view a full-screen poster, like in Aeon, it looks severely compressed.

Any thoughts would be greatly appreciated!
post #143 of 3139
Quote:
Originally Posted by frankspin View Post

Greeneyz just wanted to see if you saw my post before about setting up movie collections.

Yup, i saw it. I`m going to include in the guide tomorrow morning (i have some updated on iOS/Android/Win7Phone interfaces to include, and i`m going include the metadata manager web interface and mention how to handle movie collections with it.

Also, Netflix integration is coming to the guide, since the addon has finally reached the main repository, but still requires some modifications in the playercorefactory.xml file to work.
post #144 of 3139
Quote:
Originally Posted by cnm25 View Post

As much as I admire XBMC's visual presentation, there is one annoyance I'm having which maybe someone has some insight on.

I'm using really high-res versions of movie posters for my skin, but XBMC seems to compress them really badly. While for many views this is relatively minor, since the posters are displayed relatively small anyway, if I'm using a skin with an Info view where you can view a full-screen poster, like in Aeon, it looks severely compressed.

Any thoughts would be greatly appreciated!

Use Media Center Master as set up in the guide to scrape local metadata. This way, you will have 1500x1000 resolution posters and 1080p backdrops. Aeon MQ supports 1080p backdrops.
post #145 of 3139
Quote:
Originally Posted by GreenEyez View Post

Use Media Center Master as set up in the guide to scrape local metadata. This way, you will have 1500x1000 resolution posters and 1080p backdrops. Aeon MQ supports 1080p backdrops.

Thanks GreenEyez, I'll give Media Center Master a shot and see if there's any improvement, as I've been using Media Companion until now. Fundamentally, it seems like XBMC compresses the images after adding a source as in your guide; have you had success in getting full resolution movie posters showing, that look as good inside XBMC as they would outside?

Some of my posters are made up of 1000s vs 1000s of pixels and look razor sharp on my computer monitor, but they look noticeably blurry in a fullscreen Info view. If that's just the way XBMC compresses images, I can live with it, but I just want to make sure I'm not fighting a battle that can't be won..
post #146 of 3139
Hate to bring back up my earlier post but wanted to check if Offline file playback is simply a dead issue within XBMC and if so I should probably just stick to 7mc.
post #147 of 3139
Quote:
Originally Posted by omgitsoop View Post

All the movies that I moved the ifo files to audio_ts play fine, and it refreshes every time I turn on, and all the files with everything in the video_ts come back as doubles, and all the files with separated ifo and vob in audio_ts and video_ts respectively, don't double up and play fine. Do I have funky setting in the scraper that's causing that? But yes, im playing a movie with the ifo in the audio_ts file right now and its playing perfect. Im guessing that's not normal?

Yep not normal - I would even hazard a guess that its existence in the wrong folder is part of the problem. I just tried as an experiment your set-up and moved the .ifo file to the AUDIO_TS folder - mayhem, seems to break the 'stacking' operation of xbmc (I got 4 entries which directly correlates with the number of .vob files). Move it back to its correct position and hey presto 1 entry.

Unless your library is huge, I would suggest that you completely uninstall xbmc, including the profile folder and reinstall, making sure your DVD folders are correct.

Before you do that though could you confirm your scraper settings, from the set/edit content menu. Which options have you chosen when setting up the scraper.
post #148 of 3139
So what happens if I don't have/can't find my appdata folder? Trying to integrate MPC-HC and for the life of me cannot find this folder.

I am using Win7 x64 and the latest official release (Dharma).
Under C:\\program files (x86)\\XBMC I have the following folders:

addons
language
media
sounds
system
userdata

I have a playercore.xml file in the userdata folder, but after following the guide on mediasmartserver.net I would like to be able to set it to only play mkv's which have "DTS-HD" in them. According to the guide, you need an additional playercorefactory.xml file in your user appdata folder. I do not have this folder under c:\\users\\htpc\\

I do have appdata under C:\\windows\\system32\\conig\\systemprofile and there is a roaming folder, but no XBMC folder inside of that, which I need apparently.

Any help is greatly appreciated. The guide I am using is here:
http://www.mediasmartserver.net/2010...layer-in-xbmc/
post #149 of 3139
Sorry Double Post
post #150 of 3139
Quote:
Originally Posted by Black993 View Post

So what happens if I don't have/can't find my appdata folder? Trying to integrate MPC-HC and for the life of me cannot find this folder.

I am using Win7 x64 and the latest official release (Dharma).
Under C:\\program files (x86)\\XBMC I have the following folders:

addons
language
media
sounds
system
userdata

I have a playercore.xml file in the userdata folder, but after following the guide on mediasmartserver.net I would like to be able to set it to only play mkv's which have "DTS-HD" in them. According to the guide, you need an additional playercorefactory.xml file in your user appdata folder. I do not have this folder under c:\\users\\htpc\\

I do have appdata under C:\\windows\\system32\\conig\\systemprofile and there is a roaming folder, but no XBMC folder inside of that, which I need apparently.

Any help is greatly appreciated. The guide I am using is here:
http://www.mediasmartserver.net/2010...layer-in-xbmc/

App Data is a hidden folder - you may have to unhide it from Control Panel\\Folder Options\\View\\Show Hidden Files, folders and drives.

The path is C:\\Users\\Username (Whatever you chose during Win set-up)\\AppData
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Theater Computers
AVS › AVS Forum › Video Components › Home Theater Computers › XBMC Media Center : Setup Guide, Knowlege Base & Support