or Connect
New Posts  All Forums:Forum Nav:

Vizio XWR100 Router

post #1 of 2
Thread Starter 
Purchased the Vizio XWR100 router and two Vizio TV's (M221NV and E322VL) with internet apps. The router is supposed to support 3 simultaneous wireless networks. By default Vizio sets the SSID for these networks as VIZIO HD, VIZIO and CLASSIC. The Classic and Vizio networks broadcast on the 2.4GHz band and the Vizio HD network broadcasts on the 5GHz band. Both TV's are able to see the Classic and Vizio networks however niether can see the Vizio HD network. The router has the 5GHz network enabled and the SSID is set to broadcast. Also my laptop which is dual band is unable to see the 5GHz network. Two calls to tech support resulted in the same answer which basically consists of if my internet download speed is not fast enough you won't be able to use the Vizio HD network. I consider myself fairly knowledgeable about simple home networking which includes wireless routers however I've had 2 different "tech support" people tell me the same thing so I'm turning to the forums to help reassure myself. So I'm saying that regardless of the internet speed, if my router has the 2.4GHz and 5GHz radios turned on and broadcasting their SSID should I not be able to see them?
post #2 of 2
I'm no expert, but just set this router up myself and agree you should see them all. However, are you sure the devices you are trying to connect to the router wireless are 5ghz capable? I assume you know that unless they are, they will only be able to "see" the 2.4ghz band.

Incidentally, for the price - this is a great deal. Unless you need more options for tweaking and can live without gigabit - hard to beat this on performance and price.
New Posts  All Forums:Forum Nav:
  Return Home